Fcitx 4.2.9.8 and fcitx-qt5 1.2.5

17 views
Skip to first unread message

Weng Xuetian

unread,
Jul 31, 2020, 9:58:24 PM7/31/20
to fcitx-a...@googlegroups.com, fcit...@googlegroups.com, fcitx
Hi All,

As you might know, fcitx5 is being actively developed and it's in good shape.
I highly recommend you give it a try if your distribution provides it. Some
manual configuration need to be done with the config tool for now but the latest
git introduced the ability to add some default input method if your system
language matches the built in profile.

To learn more about fcitx 5 changes, https://www.csslayer.info/wordpress/?
s=road+to+fcitx+5 you may find more technical details from my blog.

But for the sake of bug-fixing and compatibilty, we still have this new release
for fcitx 4.2.9.8 and fcitx-qt5 1.2.5.

As fcitx 4.2.9.8, the most important changes are:
1. fix issue with appindicator on gnome-shell.
2. Relicense the im module to BSD to allow Proprietary software for bundling
it. This was already done for the Qt5 counter part, but never done for Qt4
version. This is mainly to allow WPS to reuse our up-to-date im module to
support fcitx 5.
3. Slightly change to the tray menu to remove some redudant entries.

As for fcitx-qt5 1.2.5, many fixes are ported from fcitx5 counter part during
the developement. Some fixes related to focus and relative rect to allow the
correct input window positioning on gnome-shell wayland mode.

Regards,
Xuetian


Reply all
Reply to author
Forward
0 new messages