聊聊scratch-text-editor的破事

126 views
Skip to first unread message

井上红月

unread,
Sep 9, 2016, 10:32:05 AM9/9/16
to fcitx
scratch-text-editor是elementary团队开发的一个编辑器,
开发至今都无法正常使用ibus和fcitx,
我也有一段时间没关注这个团队。
因为今晚就会出新版本,昨天早上看了一下最近的更新,
发现fcitx上电视了,啊打错了。

讲真,我是一直不知道这是谁的问题,哪里的问题,
估计以后没以后了,
我看到bug就这样关了。

其实之前也有人试过,xim可以用。
现在把gtk3的模块删掉就了事了。
确实现在也可以用了,
像这样。

昨天忘了用scratch录,
我只想问问诸君,你怎么看?



井上红月

unread,
Sep 9, 2016, 3:18:38 PM9/9/16
to fcitx
顺便贴上刚刚发布的正式版fcitx-diagnose,

mummy2458@mummy2458:~$ fcitx-diagnose
# 系统信息:
1.  `uname -a`:

        Linux mummy2458 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

2.  `lsb_release -a`:

        No LSB modules are available.
        Distributor ID: elementary
        Description: elementary OS 0.4 Loki
        Release: 0.4
        Codename: loki

3.  `lsb_release -d`:

        Description: elementary OS 0.4 Loki

4.  `/etc/lsb-release`:

        DISTRIB_ID="elementary"
        DISTRIB_RELEASE=0.4
        DISTRIB_CODENAME=loki
        DISTRIB_DESCRIPTION="elementary OS 0.4 Loki"

5.  `/etc/os-release`:

        NAME="elementary OS"
        VERSION="0.4 Loki"
        ID="elementary"
        ID_LIKE=ubuntu
        PRETTY_NAME="elementary OS 0.4 Loki"
        VERSION_ID="0.4"
        HOME_URL="http://elementary.io/"
        SUPPORT_URL="http://elementary.io/support/"

6.  桌面环境:

    桌面环境为 `gnome3`。

7.  Bash 版本:

        BASH_VERSION='4.3.46(1)-release'

# 环境:
1.  DISPLAY:

        DISPLAY=':0'

2.  键盘布局:

    1.  `setxkbmap`:

            xkb_keymap {
            xkb_keycodes  { include "evdev+aliases(qwerty)" };
            xkb_types     { include "complete" };
            xkb_compat    { include "complete" };
            xkb_symbols   { include "pc+us+inet(evdev)" };
            xkb_geometry  { include "pc(pc105)" };
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us", "", ""

3.  Locale:

    1.  全部可用 locale:

            bg_BG.utf8
            C
            ca_AD.utf8
            ca_ES.utf8
            ca_ES.utf8@valencia
            ca_FR.utf8
            ca_IT.utf8
            cs_CZ.utf8
            C.UTF-8
            da_DK.utf8
            en_AG
            en_AG.utf8
            en_AU.utf8
            en_BW.utf8
            en_CA.utf8
            en_DK.utf8
            en_GB.utf8
            en_HK.utf8
            en_IE.utf8
            en_IN
            en_IN.utf8
            en_NG
            en_NG.utf8
            en_NZ.utf8
            en_PH.utf8
            en_SG.utf8
            en_US.utf8
            en_ZA.utf8
            en_ZM
            en_ZM.utf8
            en_ZW.utf8
            hu_HU.utf8
            id_ID.utf8
            ja_JP.utf8
            ko_KR.utf8
            nb_NO.utf8
            nl_AW
            nl_AW.utf8
            nl_BE.utf8
            nl_NL.utf8
            pl_PL.utf8
            POSIX
            sv_FI.utf8
            sv_SE.utf8
            th_TH.utf8
            tr_CY.utf8
            tr_TR.utf8
            uk_UA.utf8
            vi_VN
            vi_VN.utf8
            zh_CN.utf8
            zh_HK.utf8
            zh_SG.utf8
            zh_TW.utf8

    2.  当前 locale:

            LANG=zh_CN.UTF-8
            LANGUAGE=zh_CN
            LC_CTYPE="zh_CN.UTF-8"
            LC_NUMERIC=zh_CN.UTF-8
            LC_TIME=zh_CN.UTF-8
            LC_COLLATE="zh_CN.UTF-8"
            LC_MONETARY=zh_CN.UTF-8
            LC_MESSAGES="zh_CN.UTF-8"
            LC_PAPER=zh_CN.UTF-8
            LC_NAME=zh_CN.UTF-8
            LC_ADDRESS=zh_CN.UTF-8
            LC_TELEPHONE=zh_CN.UTF-8
            LC_MEASUREMENT=zh_CN.UTF-8
            LC_IDENTIFICATION=zh_CN.UTF-8
            LC_ALL=

4.  目录:

    1.  主目录:

            /home/mummy2458

    2.  `${XDG_CONFIG_HOME}`:

        环境变量 `XDG_CONFIG_HOME` 没有设定。

        `XDG_CONFIG_HOME` 的当前值是 `~/.config` (`/home/mummy2458/.config`)。

    3.  Fcitx 设置目录:

        当前 fcitx 设置目录是 `~/.config/fcitx` (`/home/mummy2458/.config/fcitx`)。

5.  当前用户:

    脚本作为 mummy2458 (1000) 运行。

# Fcitx 状态:
1.  可执行文件:

    在 `/usr/bin/fcitx` 找到了 fcitx.

2.  版本:

    Fcitx 版本: `4.2.9.1`

3.  进程:

    找到了 3 个 fcitx 进程:

         3283 fcitx <defunct>
         3304 fcitx
         8924 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` 工作正常.

# Fcitx 配置界面:
1.  配置工具封装:

    在 `/usr/bin/fcitx-configtool` 找到了 fcitx-configtool。

2.  用于 GTK+-2.0 的配置界面:

    **未找到 gtk2 的配置界面.**

3.  用于 GTK+-3.0 的配置界面:

    在 `/usr/bin/fcitx-config-gtk3` 找到了 `fcitx-config-gtk3`。

4.  KDE 的配置界面:

    **`kcmshell4` 未找到.**

# 前端设置:
## Xim:
1.  `${XMODIFIERS}`:

    环境变量 XMODIFIERS 已经正确地设为了 "@im=fcitx".
    从环境变量中获取的 Xim 服务名称为 fcitx.

2.  根窗口上的 XIM_SERVERS:

    Xim 服务的名称与环境变量中设置的相同.

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    环境变量 QT4_IM_MODULE 已经正确地设为了 "fcitx".

2.  qt5 - `${QT_IM_MODULE}`:

    环境变量 QT_IM_MODULE 已经正确地设为了 "fcitx".

3.  Qt 输入法模块文件:
    找到了 Qt5 的输入法模块: `/usr/lib/x86_64-linux-gnu/qt5/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so`.
    找到了 Qt4 的输入法模块: `/usr/lib/x86_64-linux-gnu/qt4/plugins/inputmethods/qtim-fcitx.so`.

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    **环境变量 GTK_IM_MODULE 的值被设为了 "xim" 而不是 "fcitx". 请检查您是否在某个初始化文件中错误的设置了它的值.**
    **您正在 gtk 程序中使用 xim.**

    **您可以在 [Linux 输入法支持耻辱堂](http://fcitx-im.org/wiki/Hall_of_Shame_for_Linux_IME_Support) 找到一些会在使用 xim 时出现问题的应用程序. 包括应用程序卡死在内的更多使用 xim 可能出现的普遍问题请参见 [这里](http://fcitx-im.org/wiki/XIM/zh-cn).**

    **请使用您发行版提供的工具将环境变量 GTK_IM_MODULE 设为 "fcitx" 或者将 `export GTK_IM_MODULE=fcitx` 添加到您的 `~/.xprofile` 中. 参见 [输入法相关的环境变量: GTK_IM_MODULE](http://fcitx-im.org/wiki/Input_method_related_environment_variables/zh-cn#GTK_IM_MODULE).**

2.  `gtk-query-immodules`:

    1.  gtk 2:

        **无法找到 gtk 2 的 `gtk-query-immodules`.**

        **无法找到 gtk 2 的 fcitx 输入法模块.**

    2.  gtk 3:

        **无法找到 gtk 3 的 `gtk-query-immodules`.**

        **无法找到 gtk 3 的 fcitx 输入法模块.**

3.  Gtk 输入法模块缓存:

    1.  gtk 2:

        在 `/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache` 找到了 gtk `2.24.30` 的输入法模块缓存.
        版本行:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk2.0-0/gtk-query-immodules-2.0 from gtk+-2.24.30

        已找到 gtk `2.24.30` 的 fcitx 输入法模块.

            "/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        在 `/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache` 找到了 gtk `3.18.9` 的输入法模块缓存.
        版本行:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 from gtk+-3.18.9

        **无法输入法模块缓存 `/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache` 中找到 fcitx**

        **无法在缓存中找到 gtk 3 的 fcitx 输入法模块.**

4.  Gtk 输入法模块文件:

    1.  gtk 2:

        找到的全部 Gtk 2 输入法模块文件均存在.

    2.  gtk 3:

        找到的全部 Gtk 3 输入法模块文件均存在.

# 配置:
## Fcitx 插件:
1.  插件配置文件目录:

    找到了 fcitx 插件配置目录: `/usr/share/fcitx/addon`.

2.  插件列表:

    1.  找到了 27 个已启用的插件:

            fcitx-autoeng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-imselector
            fcitx-ipc
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-lua
            fcitx-notificationitem
            fcitx-pinyin
            fcitx-pinyin-enhance
            fcitx-punc
            fcitx-quickphrase
            fcitx-remote
            fcitx-rime
            fcitx-spell
            fcitx-table
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  找到了 0 个被禁用的插件:

3.  插件库: 

    所有插件所需的库都被找到。

4.  用户界面:

    找到了 2 个已启用的用户界面插件:

        fcitx-classic-ui
        fcitx-kimpanel-ui

## 输入法:
1.  找到了 2 个启用的输入法:

        fcitx-keyboard-us
        rime

2.  默认输入法:

    您已经正确的将一个键盘输入法 "fcitx-keyboard-us" 设为默认.

# 日志:
1.  `date`:

        2016年 09月 10日 星期六 03:05:51 CST

2.  `~/.config/fcitx/log/`:

        总用量 0

3.  `~/.config/fcitx/log/crash.log`:

    `~/.config/fcitx/log/crash.log` 未找到.

这是daily源的,我先睡了,明天有空再试试其他问题。

Weng Xuetian

unread,
Sep 9, 2016, 5:48:16 PM9/9/16
to fcitx
´_>` 反正肯定是他们自己的锅,特别是自己搞 widget 的话,ibus 都不行不要来找我们,去找这个 editor 的麻烦啊。

´_>` 有兴趣去 gdb attach 上去看看发生了什么。我不用 elementary。

--
You received this message because you are subscribed to the Google Groups "fcitx" group.
To unsubscribe from this group and stop receiving emails from it, send an email to fcitx+unsubscribe@googlegroups.com.
To post to this group, send email to fc...@googlegroups.com.
Visit this group at https://groups.google.com/group/fcitx.
For more options, visit https://groups.google.com/d/optout.

井上红月

unread,
Sep 10, 2016, 12:58:04 AM9/10/16
to fcitx
你这也太早了吧。
你的肯定我已收到,刚好最近也要尝试SVP。
如果有新的背锅情报,我会汇报的。(笑)

Yu Su

unread,
Apr 13, 2017, 3:05:15 AM4/13/17
to fcitx
well...看界面不错,刚下了个,到现在为止还是输入不了
Reply all
Reply to author
Forward
0 new messages