Using fcitx in fbterm (no GUI)?

40 views
Skip to first unread message

Ryan Lue

unread,
Oct 31, 2017, 4:58:27 AM10/31/17
to fcitx
Hi,

I'm on Debian 9.2 with only a virtual terminal and fbterm. (XOrg is
_not_ installed on my system. I'm trying to use fcitx with fbterm only.)

I've followed all the directions in the wiki:

1. Install fcitx

    $ sudo apt install fcitx fcitx-chewing fcitx-frontend-fbterm
    $ im-config        # ~/.xinputrc now contains 'run_im fcitx'

2. Configure fbterm

    $ sudo setcap 'cap_sys_tty_config+ep' $(which fbterm)
    $ sudo usermod -Ga video $(whoami)

3. Launch fbterm using fcitx-fbterm-helper

    $ fcitx-fbterm-helper -l

After following these steps, Ctrl-Space still doesn't switch from
English to Chewing.

What do I need to do to make it work? I've tried:

* reading the manual and the the FAQ Page on the wiki, and
* running fcitx-configtool, and uncommenting all the default settings.

The output of fcitx-diagnose is at https://pastebin.com/uANZNSyd

~/.config/fcitx/config is at https://pastebin.com/KQHYfpMe

Any help would be greatly appreciated.
Message has been deleted

Weng Xuetian

unread,
Nov 5, 2017, 1:48:09 PM11/5/17
to fcitx
I'm not so sure what happened to you. Maybe you're missing some addons?

I haven't test if for long time but I just tried and it still works on
my system.

fcitx-module-dbus , dbus-x11 need to be installed (sounds weird but
you'll need it). fcitx doesn't seem to be running after you run
fcitx-fbterm-helper, probably it thinks there's no available frontend
because it couldn't initialize any.
> --
> You received this message because you are subscribed to the Google Groups
> "fcitx" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to fcitx+un...@googlegroups.com.
> To post to this group, send email to fc...@googlegroups.com.
> Visit this group at https://groups.google.com/group/fcitx.
> For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages