Install/Upgrade issue, PHP 5.2/5.3 - problem with GitHub certs?

50 views
Skip to first unread message

Darryl Lee

unread,
May 23, 2011, 2:57:22 AM5/23/11
to fb...@googlegroups.com
Hi, so I was able to use curl to download fbcmd_update.php from github.  But when I try to run it with either 5.2 or 5.3 (my webhost recently upgraded), I'm getting the error:

%php fbcmd_update.php 
fbcmd update utility [version 2.91] 
http://fbcmd.dtompkins.com/update
...Could not download: [https://github.com/dtompkins/fbcmd/raw/master/fbcmd_update.php]
When I tried to wget the file, I noticed the complaint about github's SSL cert.  Could this be the issue?

I don't have sudo rights on this machine, so I edited the install_lib_dir and install_bin_dir to point to paths within my home directory.

I tried hacking the script to ignore download problems, but that doesn't work when it actually needs to read filelist.txt and iterate through the list of files.  I was able to download filelist.txt manually using curl, and was thinking about hacking the installer to open the local file, but I have no idea if that'll work, and I'm a pretty poor hacker to begin with.

Appreciate any ideas.  Thanks!

sprajag...@gmail.com

unread,
Jan 7, 2014, 6:12:51 AM1/7/14
to fb...@googlegroups.com
This is a proxy issue. I have this too. The problem is a php function called @file_get_contents which needs extra instructions to work behind proxy.
http://stackoverflow.com/questions/1336262/file-get-contents-behind-a-proxy
This thread has the instructions. I haven't succeeded in getting it to work, either. But this must be the way.

Dan Griswold

unread,
Jul 2, 2014, 4:41:56 PM7/2/14
to fb...@googlegroups.com
I too am unable to install. I can wget fbcmd_updat.php with no errors. Yet when I run

$ php fbcmd_update.php install

then I get the "Could not download" error.

I am not using a proxy. I get no errors more specific than the above error, so I'm not even certain how to diagnose the problem. And the place where it fails seems unnecessary, anyway, as the program just tries to download a file that is equivalent to itself.

Any ideas?
Reply all
Reply to author
Forward
0 new messages