Fastr 2.1.0 Release

20 views
Skip to first unread message

Hakim Achterberg

unread,
Apr 13, 2018, 10:05:40 AM4/13/18
to fastr...@googlegroups.com
We just release Fastr 2.1.0, this updated add a few new features. The Docker/Singularity support has been dusted off and test and a SLURM Execution plugin has been added.

The full changelog can be found at: https://fastr.readthedocs.io/en/2.1.0/static/changelog.html

The packages are uploaded to pypi, so installing should be as simple as pip install fastr==2.1.0 or pip install --upgrade fastr==2.1.0 to upgrade.

If you experience any problems or would like to request features for future version, please post to the discussion group.

The next non-bugfix release should be Fastr 3.0.0 which will switch over to Python3!

Marcel Zwiers

unread,
Apr 13, 2018, 10:26:28 AM4/13/18
to Hakim Achterberg, Fastr Users
The announcement is somewhat confusing wrt the version (interchanging between 2.0.0 and 2.1.0)...

2018-04-13 16:05 GMT+02:00 Hakim Achterberg <hakim.ac...@gmail.com>:
We just release Fastr 2.0.0, this updated add a few new features. The Docker/Singularity support has been dusted off and test and a SLURM Execution plugin has been added.

The full changelog can be found at: https://fastr.readthedocs.io/en/2.0.0/static/changelog.html

The packages are uploaded to pypi, so installing should be as simple as pip install fastr==2.1.0 or pip install --upgrade fastr==2.1.0 to upgrade.

If you experience any problems or would like to request features for future version, please post to the discussion group.

The next non-bugfix release should be Fastr 3.0.0 which will switch over to Python3!

--
You received this message because you are subscribed to the Google Groups "Fastr Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to fastr-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/fastr-users/2b457c57-0a17-44a1-a2d7-a1349f65587f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hakim Achterberg

unread,
Apr 13, 2018, 10:29:41 AM4/13/18
to Fastr Users
Hi Marcel,

It appears it is Friday afternoon and my mind is already focusing on the weekend... I thought I had changed that, I just edited the announcement, of course the email cannot be changed anymore. Anyways, the new version is obviously 2.1.0

Kind regards,
Hakim

Marcel Zwiers

unread,
Apr 13, 2018, 10:56:29 AM4/13/18
to Fastr Users
Thanks for the new version! Two things I noticed on my system:
  1. "pip install --upgrade fastr==2.1.0" has never worked for me (gives error messages). The only thing that works is a new install
  2. After "pip install fastr" I get this "ImportError: No module named boto3" which disappears after I do "pip install boto3"
Have a nice weekend!
Marcel

Op vrijdag 13 april 2018 16:05:40 UTC+2 schreef Hakim Achterberg:
Reply all
Reply to author
Forward
0 new messages