Fastnetmon Advanced: xdp native mode not working

73 views
Skip to first unread message

Mario R

unread,
May 23, 2022, 9:29:03 AM5/23/22
to FastNetMon user group
Hello

my company is thinking about switching from fastnetmon community to fastnetmon advanced. Since there is no more netmap support in the current advanced version I am trying to set up XDP (native mode).
OS: Debian 11

Here's my configuration:
https://pastebin.com/xGgUE55S

The config as it is in the pastebin works fine and shows traffic.
However, as soon as I type "set main force_native_mode_xdp true" & commit, all the counters go to zero and stay at zero.

Here's the logs:
https://pastebin.com/5uFyuN0C

Note that I am using Intel XL710 as requested per the documentation:
# lspci | grep 710
04:00.0 Ethernet controller: Intel Corporation Ethernet Controller XL710 for 40GbE QSFP+ (rev 02)

This is the error message that's in the logs after activating native mode:
2022-05-23 15:07:05,771 [INFO] Interface ens161 has enabled flag 'promisc' already
2022-05-23 15:07:05,771 [INFO] Will use native XDP mode
2022-05-23 15:07:05,771 [ERROR] Cannot assign BPF microcode to interface ens161 error code: -17 error: File exists

Has anyone succeeded in running fastnetmon advanced in xdp native mode?

Mario R

unread,
May 23, 2022, 9:43:04 AM5/23/22
to FastNetMon user group
I think I found out what I did wrong: I need to reboot after activating native mode. Problem solved.

Pavel Odintsov

unread,
May 23, 2022, 9:43:54 AM5/23/22
to Mario R, FastNetMon user group
Hello!

Thank you for the update! Glad to see interest in the XDP plugin.

--
Follow us on social media: Twitter: https://twitter.com/fastnetmon | Facebook: https://www.facebook.com/fastnetmon/ | LinkedIn: https://www.linkedin.com/company/fastnetmon/
---
You received this message because you are subscribed to the Google Groups "FastNetMon user group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to fastnetmon+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/fastnetmon/dae4e9a5-fbb0-46bf-9787-661e25ea0ad4n%40googlegroups.com.


--

___________

Kind regards,

Pavel Odintsov

CTO, FastNetMon LTD

fastnetmon.com


Mario R

unread,
May 25, 2022, 7:43:25 AM5/25/22
to FastNetMon user group
Hello Pavel

I'm having trouble with Fastnetmon Advanced. fastnemon_client only seems to count TCP, UDP and GRE traffic but not ICMP or raw IP. Counters stay at zero if I use e.g. ICMP. Is that the intended behaviour?

Pavel Odintsov

unread,
May 25, 2022, 7:48:33 AM5/25/22
to Mario R, FastNetMon user group
Hello!

That's definitely not expected. FastNetMon counts all traffic types which include IP addresses. Everything with IPv4 or IP6 header will be tracked.

You can enable debug log to check how FastNetMon parses your traffic:
sudo fcli set main dump_all_traffic true
sudo fcli commit

Then you will be able to see all packets in textual format in /var/log/fastnetmon/fastnetmon.log

NB! As Advanced edition customer you're eligible for priority and private support available from: https://support.fastnetmon.com/hc/en-gb/requests/new

Reply all
Reply to author
Forward
0 new messages