3.02/3/03でネットワークからコピーしようとするとエラー

1,473 views
Skip to first unread message

Susumu Sasaki

unread,
Sep 1, 2015, 2:28:02 AM9/1/15
to fast...@googlegroups.com
3.02でネットワークからローカルへのコピーがエラーが頻発しているので3.03に上げても同様
で、管理者モードでやってみると・・と、思ったら
GetVolumeInformation(ログオン失敗: ユーザー名を認識できないか、またはパスワードが間違っています。1326) : \\server名\共有名\
となり実行出来ませんでした。

元のエラーの方のログを二回分貼っておきます。
コピー中にだんまりになり、Xボタン押しても駄目というのも発生しています。
例外が出た時に必ずログを参照しろとのメッセージが出たかどうかは済みませんが未確認です。
ログ参照が出た後に継続して実行させると、又幾らかはコピー出来るんですが、そのうちに止まります。
ひとまず、今日は2.11に戻して様子を見ます。

------ FastCopy(64bit) ver3.03 -----
 Date        : 2015/09/01 14:26:08
 Code/Addr   : c0000005 / 000000014000E19C
 AX/BX/CX/DX : 0000000000000001 / 0000000000000000 / 000000007774DACA / 0000000000000000
 SI/DI/BP/SP : 0000000000000000 / 00000000002769A8 / 0000000000000000 / 000000005E06F860
 08/09/10/11 : 000000005E06F7D8 / 0000000000000000 / 0000000000000000 / 0000000000000293
 12/13/14/15 : 000000000000003B / 000000000000002B / 0000000000000000 / 0000000000000000
------- stack info -----
0000000000000000 0000000000000000 000000000000000A 000000014000C7C3
000000000000000A 0000000000000001 000000000000003B 0000000000000000
(2015/09/03 白水: 中身は拝見しましたので、BBS上ではダンプ表示の一部を省略します)
------------------------

------ FastCopy(64bit) ver3.03 -----
 Date        : 2015/09/01 15:15:49
 Code/Addr   : c0000005 / 000000014000E19C
 AX/BX/CX/DX : 0000000000000001 / 0000000000000000 / 000000007774DACA / 0000000000000000
 SI/DI/BP/SP : 0000000000000000 / 00000000002E69A8 / 0000000000000000 / 000000005E0BF860
 08/09/10/11 : 000000005E0BF7D8 / 0000000000000000 / 0000000000000000 / 0000000000000293
 12/13/14/15 : 000000000000003B / 000000000000002B / 0000000000000000 / 0000000000000000
------- stack info -----
0000000000000000 0000000000000000 000000000000000C 000000014000C7C3
000000000000000C 0000000000000001 000000000000003B 0000000000000000
(2015/09/03 白水: 中身は拝見しましたので、BBS上ではダンプ表示の一部を省略します)
------------------------

Hiroaki SHIROUZU

unread,
Sep 1, 2015, 3:14:02 AM9/1/15
to fast...@googlegroups.com
ご連絡有難うございます。

問題個所は明快なのですが、API呼び出し前後で(呼び出し規約的に)変化してはいけないレジスタが変化しているのが原因…API側に問題がある可能性はありますが、今のところ謎です。

詳細の原因ログが取れる用バイナリを作って動作させることはできますか?
(一番良いのは、デバッガで当該部分(ReadFileProc()のGetFileTime()呼び出し前後)をステップ実行してレジスタ(rsi)を見ることですが…)

それから管理者権限に昇格した場合、そのアカウントでネットワークドライブを認識させないと見えません。
昇格させたウィンドウでSourceボタン等からファイル選択ダイアログを出して、ネットワークドライブアクセスさせてみてください。

Hiroaki SHIROUZU

unread,
Sep 1, 2015, 3:57:19 AM9/1/15
to FastCopy掲示板
それと 32bit版のv3.03での動作も確認しておいていただけると助かります。
(x64用でのみ発生する問題の可能性もありますので)

Susumu Sasaki

unread,
Sep 1, 2015, 9:25:21 PM9/1/15
to FastCopy掲示板
今32bit版の3.03で同じようなコピーを行っています。
テスト用の実行も可能です。
(ただ、発生するまでにかかる時間が・・・いつ発生するかわからないのが)

権限に関しては了解しました。

Susumu Sasaki

unread,
Sep 3, 2015, 1:25:37 AM9/3/15
to FastCopy掲示板
32bit版で200G以上(容量溢れでやりなおしてるからトータルで多分400Gくらい)コピーしてるけど同じ症状が出ません。
その代わりに
WriteFileWait(ファンクションが間違っています。1) : g:\2015-08\2015-08-05\65\6569\00656931\xxxxx.pdf
WriteFile(ファンクションが間違っています。1) : g:\2015-08\2015-08-05\65\6569\00656935\xxxxx.exe
CreateFile(指定されたパスが見つかりません。3) : g:\2015-08\2015-08-05\65\6569\00656987\xxxxx.zip
(具体的なファイル名は伏せてます)
ってのが多発してる・・

Hiroaki SHIROUZU

unread,
Sep 3, 2015, 3:41:04 AM9/3/15
to fast...@googlegroups.com
64bit版の例外はRead時のものですが、32bit版ではWrite側で問題のようですね。
環境やマシンに何か特徴などがあれば教えてください。(ローカル&サーバのバージョン等)

下記に実験版を用意しました。
従来と同じ問題が発生した場合、エラーメッセージ(Detect rsi changed)を出した後に例外を出すように変えています。

もし問題がおきましたら、例外メッセージ(fastcopy.logに記録)と例外ログをお送り頂けると助かります。

Susumu Sasaki

unread,
Sep 4, 2015, 6:52:14 AM9/4/15
to FastCopy掲示板
環境はDELLのPowerEdgeでXeon L5630/32GBにWin7/64bit HDDが150GのRAID1を3パーティションに分けて、基本的には同じ構成のOSが入ってますが、テスト用環境なのでインストールされているソフトが違います。ただ、今回のは全て同じ環境で実行しているので、その点は関係無い筈。
ファイルのコピー先は4T×3が入って居るドライブにその都度一台ですが、システムドライブに試しても居ますが、こちらは容量不足で大抵すぐに停止しちゃうので無視です。
済みませんが、この後テストをしかけて帰宅しちゃうので結果は月曜日になります。
(このテストで作業が止まっているのも有るので月曜で一度終了して本番作業させます)

Susumu Sasaki

unread,
Sep 4, 2015, 7:00:06 AM9/4/15
to FastCopy掲示板
あ、スタートしたらいきなり
WriteFile(ファンクションが間違っています。1) : g:\2015-08\2015-08-03\65\6566\xxxxx
書き込めていない訳じゃ無く大量の書き込みは発生してますね。
このまま放置します。
(「そこそこいい性能のPCください」と依頼したら使い終わったサーバー渡されたので、サーバールームに実機が居て触れない。設定中に隣のデスクに置いてたら五月蠅い五月蠅い)

Susumu Sasaki

unread,
Sep 4, 2015, 7:07:13 AM9/4/15
to FastCopy掲示板
あ、サーバー側はServer2012です。R2には上げてない。
マシン構成的にはクライアントと大差無い筈です。PowerEdgeでXeonL5630/32GB
HDDはOSが300G/に3Tが4台
社内のライセンスの問題でサーバー側がESET 4.5、問題の出ているクライアントがESET 4.2です。
サーバー側でv.3.03で他のサーバーから大量にコピーしてる方は全然エラー出ないんです。

Hiroaki SHIROUZU

unread,
Sep 4, 2015, 11:38:39 AM9/4/15
to FastCopy掲示板
詳細なご報告ありがとうございます。

こういった内容は初めてですが、いろいろと奇妙に見えますね。
下記のうち実施可能な物をご確認して頂けると助かります。

1.イベントビューアで、ハードウェアやOS関係のエラーメッセージ等

2.設定→I/O設定で、重畳数を1にする(=非同期I/Oを使わない)

3.MS製のProcessMonitorで、ReadFile/WriteFile がエラーになっている行(&できれば、そのハンドルを開いたCreateFileイベント)

4.他のコピーツール(robocopy等)では問題ないかどうか

Hiroaki SHIROUZU

unread,
Sep 5, 2015, 10:45:30 AM9/5/15
to FastCopy掲示板
> 4.他のコピーツール(robocopy等)では問題ないかどうか

そうそう、v2.11 で確認しておいていただけると助かります。

Susumu Sasaki

unread,
Sep 7, 2015, 7:23:25 AM9/7/15
to FastCopy掲示板
ひとまず重畳数を1にした3.04b1では状況は変わらず
イベントビューアーでは
>コードの整合性によって、イメージ ファイルのページ ハッシュが有効でないと判断されました。このファイルはページ ハッシュを使用せず正しくない方法で署名されたか、無許可の変更によって破損した可能性があります。無効なハッシュはディスク デバイス エラーの可能性を示している場合もあります。
が一つと
>ページング操作中にデバイス \Device\Harddisk1\DR1 上でエラーが検出されました。
が多発。こいつか・・・書き込み側のエラーは
S.M.A.R.T.の状態見ようとCrystalDiskInfo入れても「対応ディスクがみつかれませんでした」つーて表示してくれないし・・・
管理コンソールからHDDの状態確認しないと駄目かな。
当初の64bitで読み出し側で出ていたエラーの確認をしておきます。

Susumu Sasaki

unread,
Sep 8, 2015, 3:48:45 AM9/8/15
to FastCopy掲示板
2.11でも書き込み側の同じエラーが出た(えらく時間かかったけど)ので書き出し側のエラーはこちらの
ハードの問題だと思います。(S.M.A.R.T.が見えるか確認のため、いつもと違うパーティションのOSで実行)
続けて読み出し側のテストをします。

Hiroaki SHIROUZU

unread,
Sep 8, 2015, 10:30:10 PM9/8/15
to FastCopy掲示板
v3.04 では従来の妙な事象(GetFileTimeのABI違反?)が出た場合に、リカバリするコードを入れてあります。
その場合、"rsi is changed" といったメッセージが出るようにしてあります。
ただ、下手にリカバリするより例外で停止させたほうが良い可能性もあり、悩ましいところです。
Reply all
Reply to author
Forward
0 new messages