Error running PCA in FactoShiny

28 views
Skip to first unread message

François-Camille Grolleau

unread,
Apr 27, 2021, 1:17:19 PMApr 27
to FactoMineR users
Dear all,

I watched all François Husson videos on PCA and its implementation in FactoShiny. That's stellar content! Thank you very much for this.

I am having trouble making the shiny app work on my system, however. For all analyses (e.g., clustering, correspondence analysis, etc.) the app seems to run fine but for PCA after I click the RUN button, I always get the error message below.
Screen Shot 2021-04-27 at 19.08.03.png
As suggested in a previous posted I updated all the packages (i.e., FactoMineR, Factoshiny, FactoInvestigate) and Xquartz but I still encounter the same error.

Below are details on my software configuration and the simplest form of the code I ran.

I’d be very grateful for any help on this,
Thank you for this great work!

François,

- MacOS 11.1
- XQuartz 2.8.1 (latest version)
- R 4.0.5 (2021-03-31) (latest version)

###
if (!require("devtools")) install.packages("devtools")
library(devtools)
install_github("husson/FactoInvestigate", force=TRUE)
install_github("husson/FactoMineR", force=TRUE)
install_github("husson/Factoshiny", force=TRUE)
library(Factoshiny)

decathlon <- read.table("https://husson.github.io/img/decathlon.csv", header=TRUE,sep=";", dec = ".", row.names=1,fileEncoding = "latin1", check.names = FALSE)
decathlon$Competition <- as.factor(decathlon$Competition)
summary(decathlon)
res <- Factoshiny(decathlon)

Francois Husson

unread,
Apr 28, 2021, 5:00:11 AMApr 28
to factomin...@googlegroups.com
Dear Francois,

Your error is very strange because you have the last version of R (is it this last version taht is used in Rstudio), and the last version of the packages.
I have never seen this error.
If you use Rstudio, you have to click on the "Run" button, and not on the "source" button.

Tell me if you have always the error.
François
res <- Factoshiny(decathlon) --
Vous recevez ce message, car vous êtes abonné au groupe Google Groupes "FactoMineR users".
Pour vous désabonner de ce groupe et ne plus recevoir d'e-mails le concernant, envoyez un e-mail à l'adresse factominer-use...@googlegroups.com.
Cette discussion peut être lue sur le Web à l'adresse https://groups.google.com/d/msgid/factominer-users/972cb60f-7485-4d1c-aae1-e9c3c330c370n%40googlegroups.com.

--
Francois Husson
Department Statistics & Computer science
L'Institut Agro - AGROCAMPUS OUEST
65 rue de St-Brieuc - 35042 RENNES
Tel: +33 2 23 48 58 86
https://husson.github.io

François-Camille Grolleau

unread,
Apr 28, 2021, 5:36:05 AMApr 28
to FactoMineR users

Thank you very much for the speed reply!!

I checked and was using running the last version of R in R studio (4.0.5), clicking the run button (the same error occurs when clicking the source button). I also tried to use Factoshiny directly from R as in the image below. The Factoshiny interface opens OK in a webpage and after I click Run in the PCA section, I encounter the same error as before.

I’m surprised that other than PCA, all analyses (e.g., clustering, etc..) seem to work just fine.

I’m happy with any advice you can provide with respect to this,

Have a great one,

François 

Screen Shot 2021-04-28 at 11.19.14.png
Reply all
Reply to author
Forward
0 new messages