Ezgo 14 64bits 安裝 S4A 32bits 無法執行

72 views
Skip to first unread message

Hu天華

unread,
Nov 15, 2019, 1:58:14 AM11/15/19
to ezgo 軍師團
系統版本:Ubuntu 18.04.3 LTS          EzGO14

參考以下作法:



步驟:
# apt-get  install  arduino scratch
arduino 已是最新版本 (2:1.0.5+dfsg2-4.1)。
scratch 已是最新版本 (1.4.0.6~dfsg1-5)。

# apt-get  install lib32ncurses5  lib32z1
lib32z1 已是最新版本 (1:1.2.11.dfsg-0ubuntu2)。
lib32ncurses5 已是最新版本 (6.1-1ubuntu1.18.04)。

# dpkg --add-architecture i386
# dpkg -i /home/student/下載/S4A16.deb
# apt-get  install  squeak*
queak-plugins-scratch 已是最新版本 (1.4.0.2~svn.r83-2.1)。
squeak-plugins-scratch-dbg 已是最新版本 (1.4.0.2~svn.r83-2.1)。
squeak-vm 已是最新版本 (1:4.10.2.2614-4.1)。
squeak-plugin-image 已是最新版本 (3.8.479-0ubuntu1)。
squeak-image3.9 已是最新版本 (3.9.7067-0ubuntu1)。
squeak-sources3.9 已是最新版本 (3.9-0ubuntu1)。


錯誤訊息:

# s4a
could not find display driver vm-display-X11; either:
  - check that /usr/local/squeak-3.10-4/lib/squeak/3.10-4/vm-display-X11.so exists, or
  - use the '-plugins <path>' option to tell me where it is, or
  - remove DISPLAY from your environment.
Aborted (core dumped)

請問有解嘛?


AceLan Kao

unread,
Nov 17, 2019, 10:43:21 PM11/17/19
to ezg...@googlegroups.com
沒試過 s4a 但是我猜可以試試
unset DISPLAY && s4a

另一個奇怪的地方是
安裝的 squeak 是 3.9 但是錯誤訊息要的是 3.10-4 的
版本不一樣 可能要再確定一下沒有哪裡沒弄好

Hu天華 <ago...@gmail.com> 於 2019年11月15日 週五 下午2:58寫道:
> --
> --
> 歡迎參與 ezgo 軍師團的討論!
> 此論壇的位置為:http://groups.google.com/group/ezgo-tw?hl=zh-TW?hl=zh-TW
>
> *** 請注意,所有此群組中的留言,都可以在搜尋引擎中找到。若您對此有顧慮,請留意您的發言。 ***
>
> ---
> 這是 Google 網上論壇針對「ezgo 軍師團」群組發送的訂閱通知郵件。
> 如要取消訂閱這個群組並停止接收來自這個群組的郵件,請傳送電子郵件到 ezgo-tw+u...@googlegroups.com
> 如要在網路上查看這項討論,請造訪 https://groups.google.com/d/msgid/ezgo-tw/dae04687-2b76-403b-8638-dcca0938a75b%40googlegroups.com



--
Chia-Lin Kao(AceLan)
http://blog.acelan.idv.tw/
E-Mail: acelan.kaoATcanonical.com (s/AT/@/)
Message has been deleted

Hu天華

unread,
Nov 21, 2019, 1:41:41 AM11/21/19
to ezgo 軍師團
正確解法我找出來了     有需要可以參考

# apt-get  install  arduino scratch
# apt-get  install lib32ncurses5  lib32z1





https://wiki.squeak.org/squeak/6134


# dpkg --add-architecture i386
# apt-get update
# apt-get install libuuid1:i386 libglu1-mesa:i386 libsm6:i386


# dpkg --add-architecture i386
# dpkg -i --force-architecture /home/ravs/下載/S4A16.deb

dpkg: 因相依問題,無法設定 s4a:i386:
 s4a:i386 相依於 libcairo2 (>= 1.8.6).
 s4a:i386 相依於 libglib2.0-0 (>= 2.20.1).
 s4a:i386 相依於 libpango1.0-0 (>= 1.24.1).
 s4a:i386 相依於 libv4l-0 (>= 0.5.0).






補安裝 i386 套件
#apt --fix-broken install


#s4a
could not find module vm-sound-pulse
Aborted (core dumped)






https://groups.google.com/forum/#!topic/s4a-community/xfTCxCvHwNw
#ldd /usr/lib/s4a/Plugins/* | grep "not found"
libasound.so.2 => not found
libasound.so.2 => not found
libasound.so.2 => not found
libpulse-simple.so.0 => not found









https://baireuther.de/lhb/tag/scratch-4-arduino/

#apt-get install libpulse-dev:i386
#s4a










AceLan Kao於 2019年11月18日星期一 UTC+8上午11時43分21秒寫道:
> 如要取消訂閱這個群組並停止接收來自這個群組的郵件,請傳送電子郵件到 ezg...@googlegroups.com

Franklin Weng

unread,
Nov 21, 2019, 8:10:58 AM11/21/19
to ezg...@googlegroups.com

恭喜升級了!

如要取消訂閱這個群組並停止接收來自這個群組的郵件,請傳送電子郵件到 ezgo-tw+u...@googlegroups.com
如要在網路上查看這項討論,請造訪 https://groups.google.com/d/msgid/ezgo-tw/8b7040f3-712b-4e9f-b63d-311d2959bb94%40googlegroups.com
-- 
Franklin Weng
中華民國軟體自由協會常務理事
文件基金會(LibreOffice 法人代表)認證 LibreOffice 導入專家、訓練專家
文件基金會(LibreOffice 法人代表)第四屆董事會成員、認證委員會委員
signature.asc
Reply all
Reply to author
Forward
0 new messages