aide pour passage expoactes sous php 7.2

85 views
Skip to first unread message

Francois BIgey

unread,
Dec 30, 2020, 11:45:51 PM12/30/20
to Expoactes

Bonjour à tous.
J'essaie vainement de faire passer ma version expoactes sous php7.2
Suivant les préconisations de Gérad GARDETTE, j'ai récupéré les deux fichiers mysql2i.class.php et  mysql2i.func.php que j'ai placés dans tools.
Puis j'ai modifié les fichiers function.php, adlcutils.php et actutils.php ainsi que charge.php et traceip.php.
C'est là que le bât blesse, je suis ignare en cette matière. J'ai modifié ces fichiers avec Notepad++. mais bien qu'aucun message  d'erreur ne s'affiche j'ai droit à une jolie page blanche à l'appel d'expoactes sur mon site.
Qqun ayant pratiqué peut-il me venir en aide ? une copie d'écran des endroit modifiés sur ces fichier m'aiderai, à moins que vous ne puissiez m'envoyer ces fichiers modifiés.
Remerciement anticipés

Bin GARDETTE

unread,
Dec 31, 2020, 4:39:33 AM12/31/20
to expo...@googlegroups.com
Bonjour,

Rendons à César etc.... il me semble qu'en fait c'est Jean-Louis C. qui avait trouvé cette astuce et je l'avais validé en testant la chose.

Question toute bête... après avoir fait les modifs avez vous changé la version PHP du serveur ?

Personnellement je ne peux pas vous envoyer les fichiers modifiés car je suis passé définitivement aux versions 7.xx en modifiant tous les appels mysql_yyyy en mysqli_yyyy et que de plus ces fichiers ont évolué et ne sont plus ceux d'origine.

Pour info : mon hébergeur IONOS considère la version 7.2 de PHP comme obsolète en décembre 2020 et que si on veut la garder il faut payer 9,37€ TTC / mois. Le passage à 7.3 n'a pas posé de problème par contre avec la 7.4 j'ai du modifier qqchose.

Cordialement.
Gérard GARDETTE

Francois BIgey

unread,
Jan 3, 2021, 4:37:28 AMJan 3
to Expoactes
Bonjour
Ca y est c'est mis en place.
En fait je n'avais pas bien compris la manip du départ. Il fallait installer une nouvelle version, j'essayais vainement de modifier les fichiers sur mon serveur en ligne.
Je vous l'ai dit je suis ignare en la matière.
Donc nouvelle version installée dans un répertoire différent. Cela fonctionne parfaitement en php 7.3
Cdlt
Reply all
Reply to author
Forward
0 new messages