Unable to run ExecuteQuery using Java 10

69 views
Skip to first unread message

Robb Oliver

unread,
May 23, 2018, 10:14:23 PM5/23/18
to Execute Query
Ran into this issue when I tried to run ExecuteQuery on my Mac.  Any ideas?

I downloaded the most recent build of ExecuteQuery 4.4.2 (released May 23rd 2018) but got this error when I attempted to run it.

The minimum required Java version is 1.7.
The reported version is 10.0.1+10.

Please download and install the latest Java version
from http://java.sun.com and try again.

I know that java changed the way that it reports its version (1.6, 1.7, 1.8, 9.0, 10.0) but 9.0 has been out since September of last year.  Is this problem new with Java 10?  Is it something to do with the '+' in the version?

Mac OS X 10.13.4

Thanks.

Takis Diakoumis

unread,
May 23, 2018, 10:19:45 PM5/23/18
to execut...@googlegroups.com
Thanks for this.

I'll check it and get a new one out tonight. 

Takis

--
You received this message because you are subscribed to the Google Groups "Execute Query" group.
To unsubscribe from this group and stop receiving emails from it, send an email to executequery...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Takis Diakoumis

unread,
May 24, 2018, 6:19:56 AM5/24/18
to execut...@googlegroups.com
Hi

i'm not seeing this issue using the latest java10. i'm on linux mind you, not a mac.
I'm now wondering if its the mac launcher itself. 

Can you try running the jar file directly from one of the downloadable archives.

simply execute the eq.sh script from the unpacked directory in a terminal.

in the meantime i will aim to get in front of a mac this weekend and have a play myself.

thank you
Takis









--
You received this message because you are subscribed to the Google Groups "Execute Query" group.
To unsubscribe from this group and stop receiving emails from it, send an email to executequery+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.
Message has been deleted

Takis Diakoumis

unread,
May 28, 2018, 4:25:30 AM5/28/18
to execut...@googlegroups.com
hello

first, thanks for your work on this :)

i'll take a look at the installer on this. could still be a java launcher/path issue on the mac that has changed.
i'll rebuild and try another.

will modify script too. 

thanks again :)
Takis



On Fri, May 25, 2018 at 8:17 AM, Robb Oliver <robb....@gmail.com> wrote:
I downloaded, extracted, and ran the simple tar.gz version and it worked.  I did make a slight change to eq.sh because my JAVA_HOME has a space in the name which the script seemed to have some trouble with (I put quotes around the call to java: exec "$JAVA" ...)

So I double checked my previous failing scenario and realized that it was the installer JAR that was failing to run, not ExecuteQuery itself.  So the problem has more to do with executequery-installer-v4.4.2.jar.

Thanks for the help.
To unsubscribe from this group and stop receiving emails from it, send an email to executequery...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Execute Query" group.
To unsubscribe from this group and stop receiving emails from it, send an email to executequery+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply all
Reply to author
Forward
0 new messages