Dependency changes on master (Python 3)

8 views
Skip to first unread message

Johannes Sasongko

unread,
Feb 1, 2020, 12:49:31 AM2/1/20
to exaile...@googlegroups.com, exaile...@googlegroups.com
Hi all,

The master branch now requires Python 3. The other dependencies are the
same (for now), except you'll need Python 3 versions of those. DEPS.txt
should list everything you need; let us know if it's incomplete or unclear.

There are small changes in configuration format. Once you've run this
new version, older versions of Exaile will refuse to load your
configuration data. If you wish to backup your data first, they are
located in ~/.config/exaile and ~/.local/share/exaile.

Our automatic build pipelines haven't been updated, so at the moment if
you create a pull request on GitHub the tests will fail.

This upgrade to Python 3 is still a work in progress. Please play around
with it and report any regressions you find.

Johannes

Reply all
Reply to author
Forward
0 new messages