Can't install 1.0.7 on OS X Yosemite

102 views
Skip to first unread message

Nathan Sowatskey

unread,
May 12, 2015, 4:58:47 PM5/12/15
to eventm...@googlegroups.com

$ sudo gem install eventmachine

...

creating Makefile

make "DESTDIR=" clean

make "DESTDIR="

compiling binder.cpp

make: *** [binder.o] Segmentation fault: 11

make failed, exit code 2

Gem files will remain installed in /usr/local/lib/ruby/gems/2.2.0/gems/eventmachine-1.0.7 for inspection.

Results logged to /usr/local/lib/ruby/gems/2.2.0/extensions/x86_64-darwin-14/2.2.0-static/eventmachine-1.0.7/gem_make.out


Any ideas anyone please? XCode 6.3.1 is installed, this is happening in the midst an install for veewee. Several other gems have installed.

Many thanks

Nathan

杨保杰

unread,
Nov 27, 2015, 10:01:01 AM11/27/15
to EventMachine
我也碰到过,把ruby 版本设置为2.1.5 即可


在 2015年5月13日星期三 UTC+8上午4:58:47,Nathan Sowatskey写道:
Reply all
Reply to author
Forward
0 new messages