more trouble installing new etm

23 views
Skip to first unread message

lawquest

unread,
Nov 9, 2019, 3:22:38 PM11/9/19
to Event and Task Manager
pip install says I need python 3.6, at least for the wheel version (I have not tried the alternate etm).  Repository for Debian buster doesn't have 3.6 but instead has python 3.7.3.  Pip balks at 3.7.3, saying I have to have 3.6.

John

Daniel Graham

unread,
Nov 9, 2019, 4:07:05 PM11/9/19
to 'stef' via Event and Task Manager
Strange. Here’s the relevant line from setup.py:

REQUIRES_PYTHON = '>=3.6.0'

Notice that it requires a version greater than or equal to 3.6. I’m using 3.7.4 myself. Are you running a version of pip that uses python 3? Instead of running “pip install …” run “pip -V”. The “from” part of the output should have “Versions/3 …”. Usually you can run “pip3" instead of just “pip” to be sure you’re getting version 3 of python for the install.

-- Dan






On Nov 9, 2019, at 3:22 PM, lawquest <jo...@lawquest.com> wrote:

pip install says I need python 3.6, at least for the wheel version (I have not tried the alternate etm).  Repository for Debian buster doesn't have 3.6 but instead has python 3.7.3.  Pip balks at 3.7.3, saying I have to have 3.6.

John

--
You received this message because you are subscribed to the Google Groups "Event and Task Manager" group.
To unsubscribe from this group and stop receiving emails from it, send an email to eventandtaskman...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/eventandtaskmanager/85e2c6fe-d9d2-48e1-999b-75f372c836c2%40googlegroups.com.

lawquest

unread,
Nov 9, 2019, 8:23:30 PM11/9/19
to Event and Task Manager
Perhaps you can figure out what I am doing wrong from the following log:

"johwhi@debian:~$ cd new-etm
johwhi@debian:~/new-etm$ ls
etm_dgraham-4.0.0b4-py2.py3-none-any.whl
johwhi@debian:~/new-etm$ pip install etm_dgraham-4.0.0b4-py2.py3-none-any.whl
Processing ./etm_dgraham-4.0.0b4-py2.py3-none-any.whl
etm-dgraham requires Python '>=3.6.0' but the running Python is 2.7.16
johwhi@debian:~/new-etm$ alias python='/usr/bin/python3.7'
johwhi@debian:~/new-etm$ pip install etm_dgraham-4.0.0b4-py2.py3-none-any.whl
Processing ./etm_dgraham-4.0.0b4-py2.py3-none-any.whl
etm-dgraham requires Python '>=3.6.0' but the running Python is 2.7.16
johwhi@debian:~/new-etm$ python --version
Python 3.7.3
johwhi@debian:~/new-etm$ pip3 install etm_dgraham-4.0.0b4-py2.py3-none-any.whl
bash: pip3: command not found
johwhi@debian:~/new-etm$ pip install etm_dgraham-4.0.0b4-py2.py3-none-any.whl
Processing ./etm_dgraham-4.0.0b4-py2.py3-none-any.whl
etm-dgraham requires Python '>=3.6.0' but the running Python is 2.7.16
johwhi@debian:~/new-etm$ python --version
Python 3.7.3
johwhi@debian:~/new-etm$ pip install etm-dgraam
Collecting etm-dgraam
Could not install packages due to an EnvironmentError: 404 Client Error: Not Found for url: https://pypi.org/simple/etm-dgraam/

johwhi@debian:~/new-etm$ pip install etm-dgraham
Collecting etm-dgraham
  Could not find a version that satisfies the requirement etm-dgraham (from versions: )
No matching distribution found for etm-dgraham
johwhi@debian:~/new-etm$ python --version
Python 3.7.3
johwhi@debian:~/new-etm$ ls
etm_dgraham-4.0.0b4-py2.py3-none-any.whl
johwhi@debian:~/new-etm$ "

Thanks for any help here.

John








On Saturday, November 9, 2019 at 1:07:05 PM UTC-8, Dan wrote:
Strange. Here’s the relevant line from setup.py:

REQUIRES_PYTHON = '>=3.6.0'

Notice that it requires a version greater than or equal to 3.6. I’m using 3.7.4 myself. Are you running a version of pip that uses python 3? Instead of running “pip install …” run “pip -V”. The “from” part of the output should have “Versions/3 …”. Usually you can run “pip3" instead of just “pip” to be sure you’re getting version 3 of python for the install.

-- Dan





On Nov 9, 2019, at 3:22 PM, lawquest <jo...@lawquest.com> wrote:

pip install says I need python 3.6, at least for the wheel version (I have not tried the alternate etm).  Repository for Debian buster doesn't have 3.6 but instead has python 3.7.3.  Pip balks at 3.7.3, saying I have to have 3.6.

John

--
You received this message because you are subscribed to the Google Groups "Event and Task Manager" group.
To unsubscribe from this group and stop receiving emails from it, send an email to eventandtaskmanager+unsub...@googlegroups.com.

Daniel Graham

unread,
Nov 9, 2019, 9:48:12 PM11/9/19
to eventandt...@googlegroups.com
From your output, you are running python 2.7.16. Use pip3.

lawquest

unread,
Nov 10, 2019, 1:25:08 AM11/10/19
to Event and Task Manager
Thanks.

I downloaded pip3 and then

pip3 install etm-dgraham

worked.

lawquest

unread,
Nov 10, 2019, 12:55:38 PM11/10/19
to Event and Task Manager
Now, when checking, I see I am running etm 3.2.30.  Yet  when checking for updates, I see latest version is 4.0.0b4.  How do I get the latest version?

John

Daniel Graham

unread,
Nov 10, 2019, 5:52:46 PM11/10/19
to 'stef' via Event and Task Manager
3.2.30 is a version of etmtk (the old, Tk/Tcl based version of etm). I’m not sure I understand what you are trying to do.

— Dan

lawquest

unread,
Nov 10, 2019, 8:17:24 PM11/10/19
to Event and Task Manager
I am trying to open and use the new etm. I just deleted the old etm from synaptic. Now I get nothing.

I gather I probably have a path problem, though I don't know much about paths.  When I do pip3 install -U etm-dgraham, I get a list of "already satisfied, skipping upgrade: stuff but when I type etm I get nothing other than "/usr/bin/etm:" no such file or directory.

John

lawquest

unread,
Nov 11, 2019, 12:13:34 AM11/11/19
to Event and Task Manager
johwhi@debian:~$ pip3 install -U etm-dgraham
Requirement already up-to-date: etm-dgraham in ./.local/lib/python3.7/site-packages (4.0.0b4)
Requirement already satisfied, skipping upgrade: tinydb-serialization>=1.0.4 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (1.0.4)
Requirement already satisfied, skipping upgrade: pyperclip>=1.7.0 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (1.7.0)
Requirement already satisfied, skipping upgrade: prompt-toolkit>=2.0.9 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (2.0.10)
Requirement already satisfied, skipping upgrade: tinydb-smartcache>=1.0.2 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (1.0.2)
Requirement already satisfied, skipping upgrade: pytzdata>=2018.9 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (2019.3)
Requirement already satisfied, skipping upgrade: python-dateutil>=2.7.3 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (2.8.1)
Requirement already satisfied, skipping upgrade: MarkupSafe>=1.1.0 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (1.1.1)
Requirement already satisfied, skipping upgrade: style>=1.1.0 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (1.1.6)
Requirement already satisfied, skipping upgrade: tzlocal>=1.5.1 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (2.0.0)
Requirement already satisfied, skipping upgrade: ujson>=1.35 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (1.35)
Requirement already satisfied, skipping upgrade: wcwidth>=0.1.7 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (0.1.7)
Requirement already satisfied, skipping upgrade: Jinja2>=2.10 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (2.10.3)
Requirement already satisfied, skipping upgrade: six>=1.11.0 in /usr/lib/python3/dist-packages (from etm-dgraham) (1.12.0)
Requirement already satisfied, skipping upgrade: pytz>=2018.9 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (2019.3)
Requirement already satisfied, skipping upgrade: icalendar>=4.0.3 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (4.0.3)
Requirement already satisfied, skipping upgrade: pendulum>=2.0.4 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (2.0.5)
Requirement already satisfied, skipping upgrade: update>=0.0.1 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (0.0.1)
Requirement already satisfied, skipping upgrade: tinydb>=3.12.2 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (3.15.1)
Requirement already satisfied, skipping upgrade: ruamel.yaml>=0.15.88 in ./.local/lib/python3.7/site-packages (from etm-dgraham) (0.16.5)
Requirement already satisfied, skipping upgrade: ruamel.yaml.clib>=0.1.2; platform_python_implementation == "CPython" and python_version < "3.8" in ./.local/lib/python3.7/site-packages (from ruamel.yaml>=0.15.88->etm-dgraham) (0.2.0)
johwhi@debian:~$

Daniel Graham

unread,
Nov 11, 2019, 9:31:54 AM11/11/19
to 'stef' via Event and Task Manager
From the output, I would guess that the etm executable might be located in ~/.local/bin. Once you find it you can add that directory to your path or simply enter the entire path when you run etm, i.e., ~/.local/bin/etm.
 
-- Dan






-- 
You received this message because you are subscribed to the Google Groups "Event and Task Manager" group.
To unsubscribe from this group and stop receiving emails from it, send an email to eventandtaskman...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/eventandtaskmanager/d172bcc0-441c-4fb9-a579-a69e824f178e%40googlegroups.com.

lawquest

unread,
Nov 11, 2019, 10:50:07 AM11/11/19
to Event and Task Manager
That worked.  Thanks!  I will figure out how to add ~/.local/bin to path.

Now, if you don't mind, do I stand risk of hurting the old etm or its data by using the new etm on the same machine?  I recall you earlier said the two could exist peacefully side by side and would appreciate confirmation.

John
 
-- Dan






To unsubscribe from this group and stop receiving emails from it, send an email to eventandtaskmanager+unsub...@googlegroups.com.

Daniel Graham

unread,
Nov 11, 2019, 10:51:29 AM11/11/19
to eventandt...@googlegroups.com
The data stores are completely different - no worries.

-- Dan






To unsubscribe from this group and stop receiving emails from it, send an email to eventandtaskman...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/eventandtaskmanager/fdb81c62-61e9-41e6-a694-4aa4ba16cbc0%40googlegroups.com.

lawquest

unread,
Nov 11, 2019, 11:50:05 AM11/11/19
to Event and Task Manager
If I add ~/.local/bin to my path, how will the system know which etm I want to use?  Should I rename one of them first?  Will renaming cause other problems?

For now, I will just leave as is and run ~/local/bin/etm when I want to play with the new etm.

My thinking, if you can call it that, is that I will eventually learn the new etm and, if I like it, take the old etm out of my path (once I figure out how).

John

-- Dan






Daniel Graham

unread,
Nov 11, 2019, 12:21:41 PM11/11/19
to 'stef' via Event and Task Manager
You can run

$ set | grep PATH

to see which directories are already in your path. Pick one of these, e.g., "/usr/local/bin" and the name you would like to use for the new etm, e.g., “etm4”, and then run

$ ln -sf ~/.local/bin/etm /usr/local/bin/etm4

This will create a symbolic link called “etm-new" to the actual etm executable and put it in the directory “/usr/local/bin”. You can run the new etm with

$ etm4

-- Dan






To unsubscribe from this group and stop receiving emails from it, send an email to eventandtaskman...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/eventandtaskmanager/83bb5cca-76df-42c3-98f2-7c350e990a92%40googlegroups.com.

lawquest

unread,
Nov 11, 2019, 1:50:16 PM11/11/19
to Event and Task Manager
Not having much luck today:

johwhi@johwhi:~$ ln -sf ~/.local/bin/etm /usr/local/bin/etm4
ln: failed to access '/usr/local/bin/etm4': Permission denied
johwhi@johwhi:~$

Here is set path log:

johwhi@johwhi:~$ set | grep PATH
PATH=/home/johwhi/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session1
    local PATH=$PATH:/sbin;
    if [[ -z "${CDPATH:-}" || "$cur" == ?(.)?(.)/* ]]; then
    for i in ${CDPATH//:/'
    PATH=$PATH:/usr/sbin:/sbin:/usr/local/sbin type $1 &> /dev/null
    COMPREPLY=($( compgen -W "$( PATH="$PATH:/sbin" lsmod |         awk '{if (NR != 1) print $1}' )" -- "$1" ))
    local PATH=$PATH:/sbin;
    local PATH="$PATH:/sbin:/usr/sbin";
    COMPREPLY+=($( compgen -W         "$( PATH="$PATH:/sbin" lspci -n | awk '{print $3}')" -- "$cur" ))
    local PATH=$PATH:/sbin:/usr/sbin:/usr/local/sbin;
    COMPREPLY+=($( compgen -W         "$( PATH="$PATH:/sbin" lsusb | awk '{print $6}' )" -- "$cur" ))
johwhi@johwhi:~$


I ran the ln-sf (etc) in root and that seemed to work but etm4 does nothing in either # ro $. I get "command not found."

John

-- Dan






Daniel Graham

unread,
Nov 11, 2019, 1:53:37 PM11/11/19
to eventandt...@googlegroups.com
Use "/home/johwhi/bin” instead of “/usr/local/bin”. There is a space between the “ln" and the “-sf”. 

To unsubscribe from this group and stop receiving emails from it, send an email to eventandtaskman...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/eventandtaskmanager/5aabfbd1-3201-4604-9c24-da4563d3bd56%40googlegroups.com.

lawquest

unread,
Nov 11, 2019, 2:07:21 PM11/11/19
to Event and Task Manager
That worked.  Thanks.  I should have known that.

John
Reply all
Reply to author
Forward
0 new messages