Macro '!' (more readable than 'qfun')

15 views
Skip to first unread message

Polos Ruetz

unread,
Nov 2, 2013, 11:57:32 AM11/2/13
to eql-user
This new macro is quite obvious, and handles 3 different cases.

Examples:

1) ordinary calls:

(! "show" widget)
(! "currentDateTime" "QDateTime")


2) nested calls (see 'qfuns', where the order is reversed):

(! ("family" "font" "QApplication"))
(! ("toString" "data" ("index" row col) "model" *table-view*))

3) (rare) need of cast:

(! "setPos" ("QGraphicsItem" pixmap-item) pos)

All occurrencies of 'qfun', 'qfuns' in examples/sources are now
replaced with macro '!', which makes them more readable (in my
opinion).

Paul

P.S: This should also help to convert code between CommonQt and EQL.
Reply all
Reply to author
Forward
0 new messages