Is it still possible to get adjacent two nodes that are directly connected?

19 views
Skip to first unread message

Gautam Thaker

unread,
Sep 5, 2021, 3:21:33 PM9/5/21
to emulab-users
I recall doing some tests  in older days of emulab where two adjacent pairs of nodes  bring up ethernet connections over direct connected cable. (No network switch would be involved.)  Is this still possible?  With d430s? And so, would that be 1 Gb or 10Gb ethernet?

Thanks. I tried to search in the wiki for this issue, but I could not find something (may be I just didn't search for right terms.)

Gautam

Mike Hibler

unread,
Sep 6, 2021, 12:32:44 PM9/6/21
to emulab...@googlegroups.com
You remember correctly. It was the pc3000 nodes. But we disconnected those
wires quite a while back. Too many isolation concerns when paired nodes were
allocated to different experiments.

We do have an Apcon layer1 switch connecting some of the d710s and a couple
of user-allocatable HP Procurve switches. You should be able to join two
nodes at 1Gb through that. However, no one has used that setup in quite
awhile and the Apcon appears to be down. I will investigate next time I am
in (probably tomorrow).

The other possibility is to sign up for a CloudLab account. In the Cloudlab
Utah cluster we have user allocatable switches and nodes connected at 10Gb
via a couple of Netscout layer1 switches. Those work. :-)
> --
> You received this message because you are subscribed to the Google Groups
> "emulab-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an email
> to emulab-users...@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/
> emulab-users/44868333-5fdd-4af7-b6de-3a14ba8f81a0n%40googlegroups.com.

Leigh Stoller

unread,
Sep 8, 2021, 6:37:04 AM9/8/21
to emulab-users
at 12:32 PM, Mike Hibler <mi...@flux.utah.edu> wrote:

> We do have an Apcon layer1 switch connecting some of the d710s and a couple
> of user-allocatable HP Procurve switches. You should be able to join two
> nodes at 1Gb through that. However, no one has used that setup in quite
> awhile and the Apcon appears to be down. I will investigate next time I am
> in (probably tomorrow).

Hi. We got things straightened out, so you can now use this profile to
directly connect two D710s at 1Gbs:

https://www.emulab.net/portal/show-profile.php?uuid=9b19aa11-9384-11e9-93e7-e4434b2381fc

I tried it this morning, appears to work fine.

Leigh

Gautam Thaker

unread,
Nov 14, 2021, 11:37:49 PM11/14/21
to emulab-users
Thanks Mike and Leigh. I may try this this week. I assume I can use my own:

urn:publicid:IDN+emulab.net+image+CorbaTests//1node-rt-d430-RT

in Leigh's profile, which I will copy, to get my own OS?

In related, it appears d430 has 10Gb network interfaces. Are these the ones that get used by default?  (I don't think I did anything special when I made my image.) For example, at present pc703.emulab.net in my experiment  2node-rt-d430

root@node-1> ethtool enp6s0f1 |less      
Settings for enp6s0f1:
        Supported ports: [ FIBRE ]
        Supported link modes:   10000baseT/Full 
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: No
        Supported FEC modes: Not reported
        Advertised link modes:  10000baseT/Full 
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 10000Mb/s
        Duplex: Full
        Port: Direct Attach Copper
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Supports Wake-on: d
        Wake-on: d
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

Looks to be 10Gb. How can I enable 1 Gb links as well between these 2 nodes?
Gautam


Leigh Stoller

unread,
Nov 15, 2021, 8:13:17 AM11/15/21
to emulab...@googlegroups.com
at 8:37 PM, Gautam Thaker <ghth...@gmail.com> wrote:

> Thanks Mike and Leigh. I may try this this week. I assume I can use my own:
>
> urn:publicid:IDN+emulab.net+image+CorbaTests//1node-rt-d430-RT
>
> in Leigh's profile, which I will copy, to get my own OS?

Sure, you can do this in the profile.

> In related, it appears d430 has 10Gb network interfaces. Are these the ones that get used by default? (I don't think I did anything special when I made my image.) For example, at present pc703.emulab.net in my experiment 2node-rt-d430

I think the resource mapper does favor the 10G interfaces.

> Looks to be 10Gb. How can I enable 1 Gb links as well between these 2 nodes?
> Gautam

If you want a second link between the two nodes, create additional
interfaces and another link in the profile. Be sure to give it IP addresses
on a different subnet.

And to make that one 1G, do this:

link2.bandwidth = 1000000

Leigh

Reply all
Reply to author
Forward
0 new messages