Startup error in Eclipse after installing Elysium

80 views
Skip to first unread message

Nick Payne

unread,
Nov 26, 2011, 7:20:31 PM11/26/11
to elysiu...@googlegroups.com
I just installed Elysium from the Eclipse marketplace in Eclipse Indigo
SR1, and on restart after the installation I get an error dialog saying:

The org.eclipse.jdt.ui.javaElementFilters plug-in extension
"org.elysium.ui.javaElementFilters.LilyPondProjects" specifies a viewer
filter class which does not exist.
Plug-in org.elysium.ui was unable to load class
org.elysium.ui.library.LilyPondProjectViewerFilter.
An error occurred while automatically activating bundle org.elysium.ui
(495).

I've attached the log from the session - just startup Eclipse, answer
error dialog, shutdown.

Nick

.log

Harmath Dénes

unread,
Nov 26, 2011, 8:40:15 PM11/26/11
to elysiu...@googlegroups.com
Dear all,

I apologize for the inconvenience and thanks for the logs, I fixed the issue now, please Check for Updates again and the problem should be solved, please report if it persists.

thSoft

> <.log>

Nick Payne

unread,
Nov 26, 2011, 10:26:36 PM11/26/11
to elysiu...@googlegroups.com
Just ran a Check for Updates, and the update dialog indicates that the update can't complete because of items not found. See attached screen dump and log entries.



!ENTRY org.eclipse.equinox.p2.operations 4 0 2011-11-27 14:20:45.844
!MESSAGE Operation details
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:45.844
!MESSAGE Cannot complete the install because one or more required items could not be found.
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.844
!MESSAGE Software being installed: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.844
!MESSAGE Missing requirement: LilyPond IDE 0.2.0.201111270222 (org.elysium.ui 0.2.0.201111270222) requires 'bundle org.eclipse.xtext.ui 2.1.0' but it could not be found
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:45.844
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.844
!MESSAGE From: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.844
!MESSAGE To: org.elysium.ui [0.2.0.201111270222]

!ENTRY org.eclipse.equinox.p2.operations 4 0 2011-11-27 14:20:45.934
!MESSAGE Operation details
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:45.934
!MESSAGE Cannot complete the install because one or more required items could not be found.
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.934
!MESSAGE Software being installed: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.934
!MESSAGE Missing requirement: LilyPond IDE 0.2.0.201111270222 (org.elysium.ui 0.2.0.201111270222) requires 'bundle org.eclipse.xtext.ui 2.1.0' but it could not be found
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:45.934
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.934
!MESSAGE From: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.934
!MESSAGE To: org.elysium.ui [0.2.0.201111270222]

!ENTRY org.eclipse.equinox.p2.operations 4 0 2011-11-27 14:20:45.940
!MESSAGE Operation details
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:45.940
!MESSAGE Cannot complete the install because one or more required items could not be found.
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.940
!MESSAGE Software being installed: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.940
!MESSAGE Missing requirement: LilyPond IDE 0.2.0.201111270222 (org.elysium.ui 0.2.0.201111270222) requires 'bundle org.eclipse.xtext.ui 2.1.0' but it could not be found
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:45.940
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.940
!MESSAGE From: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:45.940
!MESSAGE To: org.elysium.ui [0.2.0.201111270222]

!ENTRY org.eclipse.equinox.p2.operations 4 0 2011-11-27 14:20:47.360
!MESSAGE Operation details
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:47.360
!MESSAGE Cannot complete the install because one or more required items could not be found.
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:47.360
!MESSAGE Software being installed: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:47.360
!MESSAGE Missing requirement: LilyPond IDE 0.2.0.201111270222 (org.elysium.ui 0.2.0.201111270222) requires 'bundle org.eclipse.xtext.ui 2.1.0' but it could not be found
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:47.360
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:47.360
!MESSAGE From: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:47.360
!MESSAGE To: org.elysium.ui [0.2.0.201111270222]

!ENTRY org.eclipse.equinox.p2.operations 4 0 2011-11-27 14:20:47.360
!MESSAGE Operation details
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:47.360
!MESSAGE Cannot complete the install because one or more required items could not be found.
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:47.360
!MESSAGE Software being installed: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:47.360
!MESSAGE Missing requirement: LilyPond IDE 0.2.0.201111270222 (org.elysium.ui 0.2.0.201111270222) requires 'bundle org.eclipse.xtext.ui 2.1.0' but it could not be found
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2011-11-27 14:20:47.360
!MESSAGE Cannot satisfy dependency:
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:47.360
!MESSAGE From: Elysium 0.2.0.201111270222 (org.elysium.feature.feature.group 0.2.0.201111270222)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-11-27 14:20:47.360
!MESSAGE To: org.elysium.ui [0.2.0.201111270222]

Regards

Nick


On 27/11/11 12:40, Harmath D�nes wrote:
Dear all,

I apologize for the inconvenience and thanks for the logs, I fixed the issue now, please Check for Updates again and the problem should be solved, please report if it persists.

thSoft

2011.11.27. d�tummal, 1:20 id�pontban Nick Payne �rta:

Harmath Dénes

unread,
Nov 27, 2011, 7:36:38 AM11/27/11
to elysiu...@googlegroups.com
Dear all,

as for now, unfortunately it seems you have to add or enable the update site http://download.eclipse.org/modeling/tmf/updates/ in Preferences > Install/Update > Available Software Sites before updating to the latest version of Elysium. (Hopefully the predefined update sites will contain the required dependency, Xtext 2.1 soon.)
(Please don't think I don't test the updates, it seems my test environment gets "unclean" after a while. I'm going to try a more managed deployment process.)

2011.11.27. dátummal, 4:26 időpontban Nick Payne írta:

> Just ran a Check for Updates, and the update dialog indicates that the update can't complete because of items not found. See attached screen dump and log entries.
>

> <gbdgdjfc.png>

> On 27/11/11 12:40, Harmath Dénes wrote:
>>
>> Dear all,
>>
>> I apologize for the inconvenience and thanks for the logs, I fixed the issue now, please Check for Updates again and the problem should be solved, please report if it persists.
>>
>> thSoft
>>

>> 2011.11.27. dátummal, 1:20 időpontban Nick Payne írta:
>>

Reply all
Reply to author
Forward
0 new messages