Error while reverting from errornous Elysium version.

10 views
Skip to first unread message

Helge Kruse

unread,
Nov 27, 2011, 3:35:16 AM11/27/11
to elysiu...@googlegroups.com
Hello Elysium developers and users,

Hello I clicked on check-for-update in my Eclipse yesterday.
The Elysium was one of the modules that were out of date. I started the
update for all and restarted Eclipse. Now I can't edit any Lilypond
source anymore.
The error I get is
ClassNotFoundException: An error occurred while automatically
activating bundle org.elysium.ui (768)

Then I tried to revert as suggested here:
http://groups.google.com/group/elysium-user/tree/browse_frm/thread/4d8b4f94ddf4915a/1d8a7f54fb545112?rnum=1&_done=%2Fgroup%2Felysium-user%2Fbrowse_frm%2Fthread%2F4d8b4f94ddf4915a%2F1d8a7f54fb545112%3Ftvc%3D1%26#doc_537f657132773acf

Unfortunately this doesn't work. The error message is:

An error occurred while collecting items to be installed
session context was:(profile=SDKProfile,
phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
action=).
No repository found containing:
org.eclipse.update.feature,org.elysium.feature,0.2.0.201107291145

At this point I checked for update again. The only available update is
Elysium 0.2.0.201111270222 with the status
The operation cannot be completed. See the details:

Cannot complete the install because one or more required items could not
be found.
Software being installed: Elysium 0.2.0.201111270222
(org.elysium.feature.feature.group 0.2.0.201111270222)
Missing requirement: LilyPond IDE 0.2.0.201111270222 (org.elysium.ui
0.2.0.201111270222) requires 'bundle org.eclipse.xtext.ui 2.1.0' but it
could not be found

I don't want to bother you with complains, it's even had to provide a
fix far beyond midnight! Would it be useful to remove Elysium from my
Eclipse installation and reinstall it from scratch? What is the most
secure way to do so?

Regards,
Helge

Reply all
Reply to author
Forward
0 new messages