minor xtext problems

57 views
Skip to first unread message

Curt Siffert

unread,
Sep 10, 2012, 1:44:20 AM9/10/12
to elysiu...@googlegroups.com
Hi, I am having a minor recurring problem that goes like this:

1) When I got the 2.16 upgrade for Elysium, I was able to open each of my *.ly files in turn, recompile them (command-R), and see all the errors go away. No more red squiggly lines.

2) A short time later, red squiggly lines appear under certain parts in my scores (commonly unrecognized \break variables), but without any errors showing up in my problems tab.

3) A few sessions later, when I start up Eclipse, my problems tab is full of errors again, from many of my files. I go through each of the files and command-R them, and the errors disappear again.

It's not a big deal but it does take a bit of time to recompile my files every so often - any idea on if this can be fixed?

Thanks!
Curt

Dénes Harmath

unread,
Sep 10, 2012, 5:44:45 AM9/10/12
to elysiu...@googlegroups.com
You don't need to recompile the files, just select the projects and perform Project > Clean... > Clean projects selected below. This shouldn't recompile them with LilyPond, only reparse them internally, so the error markers will go away after a while. Alternatively, you can manually delete the error markers in the Problems view.

Curt Siffert

unread,
Sep 12, 2012, 6:48:05 PM9/12/12
to elysiu...@googlegroups.com
Hi, the problems reappeared for me and the "Clean projects" approach didn't have any effect.

Deleting the markers will work but it does seem like it could be a minor bug with elysium's xtext handling.  Why would "Unknown variable: break" (for instance) keep reappearing (eventually) after a recompile makes it disappear?

Thanks,
Curt

Dénes Harmath

unread,
Sep 17, 2012, 4:57:02 AM9/17/12
to elysiu...@googlegroups.com
Please collect commands that Elysium doesn't recognize in issue 54, and I'll look into them.
Reply all
Reply to author
Forward
0 new messages