:PingEclim or any command stuck

51 views
Skip to first unread message

Abhinav Agarwal

unread,
Sep 19, 2018, 6:21:56 AM9/19/18
to eclim-user
Hi,

I have set up a headless server on remote server which access over ssh.
:ValidateEclim works fine but :PingEclim gets stuck(vim does accept any input).

I have enabled "debug" logs in eclimd and following is the output:
2018-09-19 10:09:56,732 INFO  [org.eclim.eclipse.EclimDaemon] Eclim Server Started on: 127.0.0.1:9091
2018-09-19 10:10:43,737 DEBUG [org.eclim.command.Main] args: [-editor, vim, -command, ping]
2018-09-19 10:10:43,746 DEBUG [org.eclim.command.Main] Main - command: ping

Any help would be helpful.

Thanks

Alexis De La Cruz Toledo

unread,
Feb 7, 2019, 4:02:59 AM2/7/19
to eclim-user
Does anybody find a solution for this issue? I got this similar issue with eclipse photon and eclim 2.8.0. Anyone can help us? please. Thank you.

Abhinav Agarwal

unread,
Feb 7, 2019, 7:51:03 AM2/7/19
to eclim...@googlegroups.com
It has been many months when I faced the issue and resolved it. I remember it was something to do with screen number :1, I used :2 or more.
:1 is reserved.

--
You received this message because you are subscribed to the Google Groups "eclim-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to eclim-user+...@googlegroups.com.
To post to this group, send email to eclim...@googlegroups.com.
Visit this group at https://groups.google.com/group/eclim-user.
For more options, visit https://groups.google.com/d/optout.

Alexis De La Cruz Toledo

unread,
Feb 12, 2019, 2:48:23 AM2/12/19
to eclim-user
I could not be able to solve my issue.

After eclimd has been started:
INFO  [org.eclim.eclipse.EclimDaemon] Eclim Server Started on: 127.0.0.1:10012

I ran the command: eclim -f ~/.eclimrc -command ping. And it is stuck.

My eclimrc looks like:
# Bind eclimd to all interfaces
nailgun.server.host=127.0.0.1

# Specifies the port that nailgun / eclimd listens on for client requests.
nailgun.server.port=10012

# Specifies the workspace directory to use
# See $ECLIPSE_HOME/configuration/config.ini for other osgi properties.
osgi.instance.area.default=@user.home/eclipse-workspace

# increase heap size
-Xmx256M


If I run pstack over eclim run command I got this stack:
#0  0x0000003fdf8ac82e in waitpid () from /lib64/libc.so.6
#1  0x000000000043ec82 in ?? ()
#2  0x000000000043ff1f in wait_for ()
#3  0x00000000004309f9 in execute_command_internal ()
#4  0x0000000000430bee in execute_command ()
#5  0x000000000041d536 in reader_loop ()
#6  0x000000000041ccf9 in main ()

I am under a proxy. And when I installed eclim I ran this command:
ant -Declipse.home=$ECLIPSE_HOME -Dhttp.proxyHost=$PROXY -Dhttp.proxyPort=$PROXY_PORT

I am connecting to a remote server via ssh -Y for PORT forwarding and I am using Cygwin with X server.

Another thing that I note, Is that there is a java program that locks $ECLIPSE_WORKSPACE directory. Looks like the eclim process and this java process are communicating between them, because when I kill the java program the eclim process goes away.

Thank you for your appreciable help.

Reply all
Reply to author
Forward
0 new messages