Continuous Integration - FEST Tests Failing

345 views
Skip to first unread message

Cecil Williams

unread,
Mar 20, 2009, 5:48:09 PM3/20/09
to easytesting
We are using Team City 4.0.2 with the agent running on a WindowsXP
machine. If the screen is locked (via screen saver or cntl-alt-del)
when the FEST tests run any assertions involving "requires message"
fail. If we unlock the screen the tests pass. Has anyone else
encountered this and do you have a solution other than keeping the
screen unlocked (security risk).

Thanks,

Cecil

Peter Murray

unread,
Mar 21, 2009, 1:23:38 AM3/21/09
to easyt...@googlegroups.com
The only solution that we have come up with for testing with TeamCity is to use build agents that are not connected to a domain or the internet (to reduce the security risk). The computer has to unlocked to allow our tests to run, so we do not attach keyboards or monitors on them, and use remote desktop to administer them.

We tried using Vista agents, but the build agent service runs on an isolated desktop (not the logged in user) and certain fest tests fail in this situation.

- Peter

Sent from my BlackBerry® wireless device

-----Original Message-----
From: Cecil Williams <nuk...@mac.com>

Date: Fri, 20 Mar 2009 14:48:09
To: easytesting<easyt...@googlegroups.com>
Subject: [easytesting] Continuous Integration - FEST Tests Failing

Ted Young

unread,
Mar 21, 2009, 1:27:30 AM3/21/09
to easyt...@googlegroups.com
I'm curious (not having TeamCity running): have either of you tried running the tests from within a VM (such that Windows inside the VM isn't screen-locked, but the host machine is)? Does that matter, or does the build agent not work inside VMs?

;ted

Peter Murray

unread,
Mar 21, 2009, 1:50:57 AM3/21/09
to easyt...@googlegroups.com
Yes that also works, we do it with linux servers running windows xp build agents in VMware Virtual Server.


- Peter

Sent from my BlackBerry® wireless device


From: Ted Young
Date: Fri, 20 Mar 2009 22:27:30 -0700
To: <easyt...@googlegroups.com>
Subject: [easytesting] Re: Continuous Integration - FEST Tests Failing

Cecil Williams

unread,
Mar 21, 2009, 9:10:19 AM3/21/09
to easytesting
Thanks for the suggestions. Both of these sound like good solutions.
We'll give them a try.

Cecil

On Mar 21, 12:50 am, "Peter Murray" <plm...@googlemail.com> wrote:
> Yes that also works, we do it with linux servers running windows xp build agents in VMware Virtual Server.
>
>  - Peter
>
> Sent from my BlackBerry® wireless device
>
>
>
> -----Original Message-----
> From: Ted Young <tedyo...@gmail.com>
>
> Date: Fri, 20 Mar 2009 22:27:30
Reply all
Reply to author
Forward
0 new messages