EW on Raspberry Pi compile fails.

Skip to first unread message

Steve Shuff

Nov 12, 2022, 12:35:51 PM11/12/22
to earthwo...@googlegroups.com

Hi All
Hope some person can shed some light on this error please.
For some other diagnostic purpose I am trying to install EW 7.7 on a raspberry pi (Raspbian stretch OS) following this link
I am getting the error as shown in the attached photo, I have no idea why it wont compile as I have been down this road before and it all worked ok
Any help appreciated, Thanks.
Steve Shuff.

Larry Baker

Nov 12, 2022, 1:30:46 PM11/12/22
to steves...@gmail.com, 'jona...@ntu.edu.sg' via Earthworm Community Forum, Larry Baker

One thing I recommend is always do a make clean_unix and a make clean_bin_unix first.

As far as this error, be sure to define GLOBALFLAGS in a single line in ew_linux.bash:

export GLOBALFLAGS="-fno-stack-protector -Dlinux -D__i386 -D_LINUX -D_INTEL -D_USE_SCHED -D_USE_PTHREADS -D_USE_TERMIOS -I${EW_HOME}/${EW_VERSION}/include"

On the web page, it shows up as two lines.  If you cut-and-paste from there, it will not work.

You received this message because you are subscribed to the Google
Groups "Earthworm Community Forum" group.
To post to this group, send an email to earthwo...@googlegroups.com
To unsubscribe from this group, send an email to
For more options, visit this group at

You received this message because you are subscribed to the Google Groups "Earthworm Community Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to earthworm_for...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/earthworm_forum/CADNpUBGo%3D1cRK7n3wQiZaXEJBFjd-njAmb_djrnNd4g8krPFhw%40mail.gmail.com.

Larry Baker

Nov 13, 2022, 1:54:18 PM11/13/22
to Steve Shuff, 'jona...@ntu.edu.sg' via Earthworm Community Forum, Larry Baker
Read the Earthworm Forum topic from Mario Rodríguez Marín dated Jul 28, 2018, 12:50:58 PM that Earthworm fails to build on a Raspberry Pi,
https://groups.google.com/forum/?hl=en#!topic/earthworm_forum/fOt7f5yiDv4.  El Berto provided a link to his modified Earthworm-7.7 source tarball.  Try that.

I added ARM processor support to Earthworm-7.10 in Earthworm TRAC ticket no. 672 dated August 1, 2018.  Unfortunately, the historical Earthworm TRAC system seems to be gone now, so I can't point you to the patches I applied (r7545, r7546, r7547, and r7548).

On Nov 13, 2022, at 8:59:41AM, Steve Shuff <steves...@gmail.com> wrote:


Schoolboy error ! I missed out the - in " -fno-stack-protector"

So now I am getting past that part when compiling but now I get an error relating to "-m32" as shown in the screenshot attached.any help is much appreciated .

Thanks .

On Sun, Nov 13, 2022 at 9:50 AM Steve Shuff <steves...@gmail.com> wrote:
Hi Larry,
Many thanks for your help,

I re-entered the statement as one line (not copied and pasted like had done before) and also did both make clean processes as you advised.
The error is still the same , I don't understand why as I am sure I have had this working some time in the past before migrating to EW 10.1 .
 I have attached my bash file in case anyone spots anything out of the ordinary.

The reason I am trying to get an older version up and running is that in EW 10.1 I can't get Trig2disk to work , 
Carlsta and Carlsub both seem to be functioning correctly and Trig 2 disk does write a Seisan file but there is no data in the file .
On opening the S file in Seisan a flat trace is observed and the file is only around 6Kb in size !! 
The test files that came with Seisan all show up correctly.
This I think may be down to Tri2disk, but cant be sure .
Thanks again..

Steve Shuff.

Steve Shuff.

El Berto

Dec 9, 2022, 5:12:22 AM12/9/22
to Earthworm Community Forum
I found a 7.10 Earthworm version on gitlab, I'm making some tests on PI400, it seems working.
Error "multiple definition of" looks solved.
I'll post PI3 working version asap.
Reply all
Reply to author
0 new messages