sendmail not working

8 views
Skip to first unread message

Victor Preatoni

unread,
Jul 4, 2022, 11:50:51 AMJul 4
to Earthworm Community Forum
Hi,

I configured Linux sendmail to relay system emails. If used by command line it works properly, but if an earthworm module calls it, fails.

For example, using ewhtmlreport module, I get the following log:

20220704_UTC_15:14:44 ewhtmlreport: Sending email alert to 1 recipients.
20220704_UTC_15:14:44 Debug: issuing this email command: cat /opt/earthworm/run_working/data/ewhtml/report__header.tmp  | /usr/sbin/sendmail -t
20220704_UTC_15:14:45 Debug: return value from command: 256


Checking syslog, I can see the following error:
Jul  4 12:09:41 earthworm startstop[146457]: sh: 1: cat: not found
Jul  4 12:09:42 earthworm sSMTP[146458]: Creating SSL connection to host
Jul  4 12:09:44 earthworm sSMTP[146458]: SSL connection using RSA_AES_256_GCM_SHA384
Jul  4 12:09:44 earthworm startstop[146458]: sendmail: No recipients specified although -t option used


So, it seems that when ewhtmlreport calls "cat /opt/earthworm/run_working/data/ewhtml/report__header.tmp  | /usr/sbin/sendmail -t" command, the cat command is failing.

Tests I did so far:
- Checked path and "cat" is on it.
- Tried manually running command and it works.
- Tried manually running command under "sh" shell, using same user as earthworm runs on, and it works.

Any help appreciated!
Thanks


Reply all
Reply to author
Forward
0 new messages