Continuing problems in IE8.

163 views
Skip to first unread message

Doug Wolfgram

unread,
Jan 29, 2013, 1:42:03 PM1/29/13
to dygraph...@googlegroups.com
I put the temperatures sample code on my server at the following location:

http://bar-www-dev.dpmc.com/graphtest.php

for some reason, the lines do not draw in IE 8 even though I have the latest code, excanvas and the meta tag. (view source)

Can anyone tell me why this does not work in IE8? The lines do not draw.  My Browser Mode and Document Mode both are set to IE8. 

Everything works fine in Chrome. 

Thanks for any suggestions


Dan Vanderkam

unread,
Jan 29, 2013, 1:56:58 PM1/29/13
to Doug Wolfgram, dygraph...@googlegroups.com
Try waiting until the DOMContentReady event has fired to add your chart. It's possible that excanvas isn't ready yet when you construct your dygraph.




--
You received this message because you are subscribed to the Google Groups "dygraphs-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dygraphs-user...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

Doug Wolfgram

unread,
Jan 29, 2013, 2:17:03 PM1/29/13
to dygraph...@googlegroups.com, Doug Wolfgram
That was it. Since I use jquery in may main application I got lazy and used jquery to wait until document is ready here as well. But nonetheless, it works. it is usually better to have your js at the top of your file anyway for standards compatibility issues.  

Now I have to figure out why my MAIN application doesn't work in IE8. :) Another long problem since it is so complex.

Thanks for the quick help!
Reply all
Reply to author
Forward
0 new messages