Problema com PDFs gerados pelo FastReport

341 views
Skip to first unread message

Rodrigo Sebben

unread,
Nov 20, 2017, 6:57:29 AM11/20/17
to dug...@googlegroups.com
Bom dia pessoal. Utiliza o fast report para relatórios, e em todo o relatório do sistema usa o conversor para PDF. Até então nunca tinha me dados problemas, só que agora, alguns cliente tem reclamado que ao abrir em certas maquinas, em vez de aparecer o texto padrão do campos do relatório, aparecem caracteres especiais do tipo !@#$%¨. Fui nessas maquinas e atualizei o Adobe reader para a a ultima versão, mas mesmo assim não funcionou. No componente de conversão não foi modificado nada. Até pensei que pudesse ser fonte, mas esses relatórios que dão problema estão usando Arial como fonte padrão.

Alguem mais já teve esse tipo de problema?

Att.
Rodrigo Sebben

Secaio

unread,
Nov 20, 2017, 7:22:34 AM11/20/17
to dug...@googlegroups.com
Bom dia!

O erro continua se vc abrir os relatórios no navegador web?

Nunca tive problemas com isso, porém hoje pela manhã o Reader aqui na minha máquina não tá abrindo nenhum pdf... Pc novo, windows 10... Simplesmente diz q tem erro no arquivo, que é pra entrar em contato com quem criou o pdf... blablabla  dai pelo browser vai sem stress.

 Aqui também estava normal até sábado pela manhã qdo usei ele pela última vez! 

No anexo a foto do erro... onde tem o adobe dizendo que não consegue abrir o arquivo e o arquivo aberto no edge (pelo menos pra isso ele serve) do lado.

--
--
Você recebeu esta mensagem porque está inscrito no "DUG-RS -
Delphi Users Group Rio Grande do Sul" em Grupos do Google.
Acesse o nosso BLOG em http://www.dug-rs.org e contribua com a comunidade Delphi do Rio Grande do Sul
Para postar neste grupo, envie um e-mail para dug...@googlegroups.com
Para cancelar a sua inscrição neste grupo, envie um e-mail para
dug-rs-unsubscribe@googlegroups.com
Para ver mais opções, visite este grupo em
http://groups.google.com.br/group/dug-rs?hl=pt-BR
 
Twitter: @dugrs
http://www.facebook.com/groups/dugrs/
http://www.Vimeo.com/dugrs

---
You received this message because you are subscribed to the Google Groups "DUG-RS - Delphi Users Group Rio Grande do Sul" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dug-rs+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Secaio
Sem título.png

Rodrigo Sebben

unread,
Nov 20, 2017, 7:46:15 AM11/20/17
to dug...@googlegroups.com
Tanto pelo Browser(firefox ou chrome) como pelo adobe reader, da o mesmo problema Secaio. Notei que o programa PDF XChange Viewer corrige o problema, mas mesmo assim, acredito que o problema ainda seja alguma opção na geração do PDF pelo Fast Report.

Att.
Rodrigo

Marcelo Bortolini

unread,
Dec 1, 2017, 11:57:12 AM12/1/17
to dug...@googlegroups.com
Rodrigo, já vi isso ocorrer, pra resolver tem que marcar a opção de exportar as fontes junto quando faz a geração do PDF pelo FAST.
Marcelo Bortolini

Rodrigo Sebben

unread,
Dec 5, 2017, 5:45:11 PM12/5/17
to dug...@googlegroups.com
Vlw Marcelo. Realmente resolveu o problema! muito obrigado!

Att.
Rodrigo Sebben
Reply all
Reply to author
Forward
0 new messages