Internal Server Error on geocoding one location

49 views
Skip to first unread message

Igor Menghini

unread,
Nov 9, 2014, 2:27:18 PM11/9/14
to dstk-...@googlegroups.com
Dear all,
first of all, let me compliment you for the great API, I've used it in few projects and it's absolutely wonderful!
Recently I bumped into a small and very odd issue: when geocoding the location "Wirral" I get a "Internal server error" response.

I tried to do that on my browser too and have the same response. Any other location (even invented one) work perfectly returning either valid results or "zero_results" responses.. but this query really seem to upset the server



Anyone able to shed some light? :)

Cheers,
Igor

Pete Warden

unread,
Nov 9, 2014, 3:23:16 PM11/9/14
to dstk-...@googlegroups.com
Thanks for the detailed bug report Igor! It gave me enough info to look at the error stack, here's what I saw:

NoMethodError - undefined method `<<' for nil:NilClass:
/home/ubuntu/sources/dstk/emulategoogle.rb:367:in `google_style_twofishes'
/home/ubuntu/sources/dstk/emulategoogle.rb:45:in `google_geocoder_api_call'
./dstk_server.rb:1322:in `GET /maps/api/geocode/:format'

It looks like the code's mishandling some of the handoff to Twofishes, but I'm not sure why it's triggering in that case in particular.

Pete


--
You received this message because you are subscribed to the Google Groups "dstk-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dstk-users+...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Check out Jetpac City Guides iPhone app - Just launched!

CTO Jetpac
Follow me on twitter @petewarden

Igor Menghini

unread,
Nov 11, 2014, 5:21:33 AM11/11/14
to dstk-...@googlegroups.com, pe...@jetpac.com
Thanks for the prompt response Pete,
I have no idea either why that happens...
I tried to introduce some spelling errors in the word "Wirral" and then everything works fine.. It also works fine if the location only contains the word Wirral (i.e. "Wirral%2C+North+West.+UK", "Wirral%2C+England", etc..). Not sure if that helps the troubleshooting.. :-/


My first thought would be that maybe there is a variable called "wirral" and that might screw up the process.. But that's hard to say without looking at the code.. and I'm not a programmer either so I might be talking rubbish :D

Igor

Lukas Norbutas

unread,
Dec 8, 2014, 3:39:51 AM12/8/14
to dstk-...@googlegroups.com, pe...@jetpac.com
Hello,

I saw this thread and wanted to add up. I had a very similar problem, perhaps there's something common behind these errors.
I get an error, when I try to geocode "purmer" or "groningen" with the API.

Here are the queries I use:

Do you guys perhaps have any advice on what I could do to solve this?

Best regards,
Lukas 
Reply all
Reply to author
Forward
0 new messages