Drools audit log view cannot be opened

259 views
Skip to first unread message

Gergely Bacsó

unread,
Dec 11, 2014, 5:15:55 AM12/11/14
to drools...@googlegroups.com
Hi,

I am struggling with the following problem:
I have a drools audit log file which seems to be valid, but cannot be opened by the Eclipse Drools plugin Audit view. On the UI it says absolutely nothing (the view remains empty, no errormessage), but I get this in the eclipse logs:
java.util.EmptyStackException
    at java
.util.Stack.peek(Stack.java:102)
    at java
.util.Stack.pop(Stack.java:84)
    at org
.drools.eclipse.debug.AuditView.createEventList(AuditView.java:515)
    at org
.drools.eclipse.debug.AuditView.refresh(AuditView.java:156)
    at org
.drools.eclipse.debug.AuditView.becomesVisible(AuditView.java:770)
    at org
.eclipse.debug.ui.AbstractDebugView$DebugViewPartListener.partVisible(AbstractDebugView.java:181)


The log file however seems perfectly valid:

<object-stream>
<org.drools.core.audit.WorkingMemoryLog>
 
<version>6.1</version>
 
<events>
   
<org.drools.core.audit.event.ObjectLogEvent>
     
<type>1</type>
     
<factId>1</factId>
     
<objectToString>Criterion of type TestCriterion id=0 name=Test action</objectToString>
   
</org.drools.core.audit.event.ObjectLogEvent>
...


The last time I have successfully used Drools audit log was with 5.6.0, I did not need this since then. Now I generated this with 6.0.1, then with 6.1.0, also tried to open them with the following Eclipse plugin versions: 5.6.0, 6.0.1, 6.1.0. To rule out any possible issue with my own Eclipse installation I downloaded a completely fresh Eclipse Luna and installed both version 6.0.1 and 6.1.0 eclipse plugins independently, but I got the exact same result.

Does this plugin work for everybody else and am I the only one who is experiencing this issue?

Thanks,
Gergely

Matteo Mortari

unread,
Dec 19, 2014, 1:08:13 PM12/19/14
to drools...@googlegroups.com
Hi, I'm experiencing similar behavior and stacktrace in the Eclipse log, when I get as a result several Audit logs file
( because of the many insert/fire etc therefore many audit records results in automatic file splits ).

When I have several audit logs, some logs do open in the Audit view correctly; other log files in the sequence do not open and as you describe Audit view is empty and that stacktrace output is produced in the Eclipse log.

Do you have the same experience?
I'm asking as you seem to mention about a single log file but I was wondering if it's actually one in a sequence of audit log.

I'm also wondering if this is due to the log containing some cross-reference to other log records not appearing in this file instance but the previous/next, making the java code which is constructing the items in the Audit log treeview fail with that stacktrace.

Gergely Bacsó

unread,
Dec 19, 2014, 1:19:14 PM12/19/14
to drools...@googlegroups.com
Hi,

First of all: this problem can be reproduced with only a single audit file.

I managed to get closer to the solution by spending a few hours reading Drools source code:
The Eclipse plugin has a class called AuditView, this class expects RuleFlowGroupNode-s in the right sequence, or it blows up:
http://grepcode.com/file/repo1.maven.org/maven2/org.drools/org.drools.eclipse/6.0.1.Final/org/drools/eclipse/debug/AuditView.java (see line 515, stack.pop())

Since my audit logs for some reason contain several of
AFTER_RULEFLOW_GROUP_DEACTIVATED entries without having any BEFORE_RULEFLOW_GROUP_DEACTIVATED entries preceding them, the AuditView fails to parse the log.
Currently I am manually removing these non-matched entries to be able to open the file, and planning to spend some time on further analysis after the holidays.

Gergely

Matteo Mortari

unread,
Dec 19, 2014, 1:38:01 PM12/19/14
to drools...@googlegroups.com
Thank you for your quick feedback, I will check if also my case reduces to yours of ruleflowgroup nodes out of sequence.

--
You received this message because you are subscribed to a topic in the Google Groups "Drools Setup" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/drools-setup/OMjVAiVT3oA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to drools-setup...@googlegroups.com.
To post to this group, send email to drools...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/drools-setup/4ed50f01-16b2-417b-bcb4-6565732509f7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Mark Proctor

unread,
Dec 20, 2014, 3:15:37 PM12/20/14
to drools...@googlegroups.com, Bob Brodt
please open a JIRA, so we can be sure to fix this.

Thanks

Mark
--
You received this message because you are subscribed to the Google Groups "Drools Setup" group.
To unsubscribe from this group and stop receiving emails from it, send an email to drools-setup...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages