Can't login with default credentials / Cluster topography log

36 views
Skip to first unread message

Maximiliano Alvarez

unread,
Oct 18, 2022, 3:46:19 PM10/18/22
to dotCMS User Group
Hi all,

im trying to update my actual dotcms (V5.2.3) to 5.3.8.14_lts_1e7f38b using kubernetes, i already have my postgres 9.6.7 and ES running.

First of all, before restore my 5.2.3 backup, when my 5.3.8 dotcms server is up, i keep receiving all this logs and idk why:

WindowsTerminal_NY7bMdTMOg.png

Despite that, i cant log in with default credentials: ad...@dotcms.com admin, it throws me this error:
WindowsTerminal_lF5jw4D5Dc.png

Those 2 errors are from 5.3.8, when i did restore my psql dump, i did the reindex and then about 10 min, the postgres db crashed, it said that max timeout is reached (30000 millis), everytime i do the restore, 10 min after, it crashes.

Thanks! 

Kind regards,

Maxi

Will Ezell

unread,
Oct 19, 2022, 10:37:06 AM10/19/22
to dot...@googlegroups.com
So first, why are you going to 5.3.8?  That cluster error goes away in the latest LTS - 22.03.  Also, I would upgrade your postgres as 9.6 is pretty old at this point.  Upgrade to postgres 14 at least if not 15

Second, the issue with the admin login is because your user does not have "Back End User" privileges.  In dotCMS ~5.2.4 we added distinct backend and front end user roles.  Run this SQL after the upgrade.  You might need to restart dotCMS after this to clear the caches.

insert into
users_cms_roles
   (
      id,
      user_id,
      role_id
   )
select
   gen_random_uuid(),
   'dotcms.org.1',
   id
from
   cms_role
   where
   role_key='DOTCMS_BACK_END_USER';






--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dotcms+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/889963c0-7f2d-4c18-9065-1a01dd730a98n%40googlegroups.com.


--



382 NE 191st St #92150
Miami, Florida 33179-3899
Main: 
305-900-2001 | Direct: 978.294.9429

Maximiliano Alvarez

unread,
Oct 19, 2022, 3:48:02 PM10/19/22
to dotCMS User Group
Thanks for the response!

I was upgrading to 5.3.8.14_lts because i thought it was a recent LTS release, but can you recommend me best stable docker image to upgrade?

I already understand those 2 errors, but do you have any clue about why after i did the restore of my 5.2.3 backup in 5.3.8.14_lts, ~10 min later, a max timeout error (30000 millis) break the cms?

Thanks in advanced again.

Maximiliano

Will Ezell

unread,
Oct 20, 2022, 10:26:42 AM10/20/22
to dot...@googlegroups.com
Maximiliano:

You can find our current releases here:

It is a bit confusing, as 5.3.8 is on the top of the list, but 5.3.8 is already 2 years old at this point. You should go to the latest 22.03 release. 

Maximiliano Alvarez

unread,
Oct 20, 2022, 2:29:52 PM10/20/22
to dotCMS User Group
Hi, i did reply but i think i didnt send it. 

Thanks for the responses, i already upgraded to 20.03.2 and my postgres to v13. Still having this issue:

WindowsTerminal_wjiBpudfSf.png

It happens when i restore my 5.2.3 postgres backup in this new version, maybe any new tables between versions? 

Im pretty new in cms so maybe im missing something.

Thanks in advance!

Maximiliano.

Will Ezell

unread,
Oct 20, 2022, 3:57:38 PM10/20/22
to dot...@googlegroups.com
Are you running from source? It looks like you are running out of connections which could mean that some annotations are not getting compiled.

How many db connections are you running with?  



Maximiliano Alvarez

unread,
Oct 25, 2022, 8:45:06 AM10/25/22
to dotCMS User Group
Hi, sorry for taking too much to answer. 

Im not understanding what "from source" is. Actually, im using a deploy from k8s which has dotcms's 22.03.2 image and postgresql 13. 
dbeaver_rtsSvk3Jwe.png 

For what i can see, those are the connections when i pull up the image and before the backup.

dbeaver_M5YB1NFiIf.png

And those are the connections when i've applied the restore from my dump.

I couldnt find the db.properties that is setting my db, i find one in web-inf/classes/ but it hasnt the env variables, this is it:

##Postgres default configuration
driverClassName=org.postgresql.Driver
jdbcUrl=jdbc:postgresql://dotcms/dotcms
username=dotcms
password=dotcms

##MySQL default configuration
##driverClassName=com.mysql.jdbc.Driver
##jdbcUrl=jdbc:mysql://localhost/dotcms?characterEncoding=UTF-8&useLegacyDatetimeCode=false&serverTimezone=UTC
##username={your db user}
##password={your db password}
##connectionTestQuery=SELECT 1

##Oracle default configuration
##driverClassName=oracle.jdbc.OracleDriver
##jdbcUrl=jdbc:oracle:thin:@localhost:1521:XE
##username={your db user}
##password={your db password}
##connectionTestQuery=SELECT 1 from DUAL

##MSSQL default configuration
##driverClassName=com.microsoft.sqlserver.jdbc.SQLServerDriver
##jdbcUrl=jdbc:sqlserver://{your server}.database.windows.net:1433;databaseName={your DB name}
##username={your user}@{your server}
##password={your db password}
##connectionTestQuery=SELECT 1

## Initial wait for a new connection in milliseconds
connectionTimeout=3000
## Pool Min and Max connections
minimumIdle=10
maximumPoolSize=60
## An idle connection will be removed from the pool after milliseconds (5m)
idleTimeout=300000
## Max lifetime of any connection
maxLifetime=120000
## Log potential leaks after milliseconds
leakDetectionThreshold=60000

when i tried to change the connectionTimeout to another value, it doesnt refresh, so the problem persist.

Thanks in advance, kind regards.

Maximiliano.

Will Ezell

unread,
Oct 25, 2022, 9:21:09 AM10/25/22
to dot...@googlegroups.com
Maximo:

Right, that db.properties file is not used and you should use environmental variables to configure the connection to your DB and not touch the db settings manually.  What are your environmental variables set to? See this page for more details.


The error is just that dotCMS cannot get a db connection - either the dotCMS db connection pool DB_MAX_TOTAL is set too low or your postgres instance max_connections are too small.
I would verify your environmental variables match what is expected in our documentation secondly, check the max connections set for in your postgres instance?


Maximiliano Alvarez

unread,
Oct 25, 2022, 9:49:27 AM10/25/22
to dotCMS User Group
Hi!

This is a extract from the db-deployment.yaml for k8s.

containers:
        - args:
            - postgres
            - -c
            - max_connections=400
            - -c
            - shared_buffers=128MB
          env:
            - name: POSTGRES_DB
              value: dotcms
            - name: POSTGRES_PASSWORD
              value: password
            - name: POSTGRES_USER
              value: dotcmsdbuser
          image: postgres:13

So, i need to add in env: DB_MAX_TOTAL? I thought max_connections=400 in the args would be enough?

Thanks!

Will Ezell

unread,
Oct 25, 2022, 9:51:34 AM10/25/22
to dot...@googlegroups.com
What are your settings for dotCMS?  

Maximiliano Alvarez

unread,
Oct 25, 2022, 9:54:25 AM10/25/22
to dotCMS User Group
 spec:
      containers:
        - env:
            - name: CATALINA_OPTS
              value: '-Xmx1g '
            - name: DB_PASSWORD
              value: password
            - name: DB_BASE_URL
              value: jdbc:postgresql://db/dotcms
            - name: DB_USERNAME
              value: dotcmsdbuser
            - name: DOT_ES_ENDPOINTS
              value: http://elasticsearch:9200
            - name: PROVIDER_DB_DBNAME
              value: dotcms
            - name: PROVIDER_DB_DNSNAME
              value: db
          image: dotcms/dotcms:22.03.2_lts_4fc0fb6
          name: dotcms

This are my envs in dotcms-deploy

Will Ezell

unread,
Oct 25, 2022, 10:12:42 AM10/25/22
to dot...@googlegroups.com
Try to add DB_MAX_TOTAL=200 to your dotCMS config.

Maximiliano Alvarez

unread,
Oct 25, 2022, 10:19:43 AM10/25/22
to dotCMS User Group
I already tried while i was waiting, haha, it doesnt work. Maybe i need to migrate something? Im thinking 5.2.3 its a pretty old version and i need to check something manually or add anything to the db tables. Also another error is thrown, it says FATAL: invalid value for parameter "TimeZone": "AGT". But in 5.2.3 i have the same error so i think its not the problem that crashes my dotcms. 

To apply my dump from postgres i need to drop dotcms database and create a new one, this new version of cms, need something from start in the database that maybe its not working?

Maximiliano Alvarez

unread,
Oct 26, 2022, 2:26:44 PM10/26/22
to dotCMS User Group
Will, i solved it! It was "Timezone" error, so it didnt break anymore. Last thing i see its happening is that all icons and some images from the frontend are lost after restoring the backup. Any clue?

Thanks for all the help!

Maxi.

Will Ezell

unread,
Oct 26, 2022, 2:55:32 PM10/26/22
to dot...@googlegroups.com
Nothing comes to mind about the images.  We'd need to see the error.  Also, we moved our default icon set to material icons so I think you would need to choose from those. 

Reply all
Reply to author
Forward
0 new messages