Key/Value Fields Do not display in backend contentlet after upgrade from 22.03 to 22.08 Agile

7 views
Skip to first unread message

Lex Medeiros

unread,
Aug 14, 2022, 4:05:02 PM8/14/22
to dot...@googlegroups.com
Dear group:

Happy sunday!

I upgraded  from Agile 22.03 to 22.08 a few days ago.  After I upgraded all front end worked perfectly.  I cleared cache, and reindexed.

Now, I noticed that the information contained in key/value fields on the vast majority of the contentlets of different contentTypes do not display in the back end or are displayed as if they contained "no values".  Just like this:

Screen Shot 2022-08-14 at 1.43.15 PM.png


However, when I export the contentlets, pull them in the front end via urlcontentmaps or content pulls I can obtain the data contained in those fields even though on the backend they I get a message stating "no values". See:

Screen Shot 2022-08-14 at 1.44.27 PM.png

It seems like all the content is inside the fields, but I can not access them via backend.  Any pointers on how to go about this?

The console error I get in these contentlets:
Error: TypeError, Cannot read properties of null (reading 'dataset')
need enterprise license Object

I am not doing anything "fancy" that requires a license in the backend.

Thanks for your help!

Regards,

Lex










Lex Medeiros

unread,
Aug 14, 2022, 4:22:19 PM8/14/22
to dot...@googlegroups.com
I furthered tested this issue by inputting the data contained in one of the problematic key/value fields into a test contentlet and I get this error when I try to save the contentlet.

  • Unexpected character ('L' (code 76)): was expecting double-quote to start field name at [Source: (String)"{Location:Osa Peninsula,Altitude:Sea level,Area:104,900 acres,Hours:8:00 a.m. to 4:00 p.m. daily,Telephone:2735-5036 or 2735-5580,Entrance Fee:$10.00}"; line: 1, column: 3]
Screen Shot 2022-08-14 at 2.21.25 PM.png

So I assume the issue is for some unexpected character.  What is the character? How can I resolve it?

Lex

Lex Medeiros

unread,
Aug 14, 2022, 4:27:36 PM8/14/22
to dot...@googlegroups.com
I am sorry.  I got the characters it does not like:  the ":" or the ";".  

I tried to escape them with a \ but it does not work.  Any other idea how to go about this issue is welcome!

Lex
Reply all
Reply to author
Forward
0 new messages