Error: dotcms_1 | 17:53:28.504 FATAL business.ESIndexAPI - No Elasticsearch, dying an ugly death

20 views
Skip to first unread message

Michael H

unread,
Nov 1, 2021, 11:28:40 PMNov 1
to dotCMS User Group
Hi all,

I'm attempting to test out dotCMS locally, but I'm receiving this error during setup:

dotcms_1         | 17:53:23.503  ERROR business.ESIndexAPI - Elasticsearch Attempt #24 : elasticsearch
dotcms_1         | 17:53:28.504  FATAL business.ESIndexAPI - No Elasticsearch, dying an ugly death

I'm installing via Docker on a local Macbook Pro (11.6.1).  The wget command runs, and Compose performs the steps until it gets to the Elastic Search step.

I'm not suppose to install Elastic Search myself, as there's nothing in the Quick Start that mentions this, so I'm wanted to reach out and ask about it.

The instructions I'm following are here: https://dotcms.com/docs/latest/quick-start-guide and I've included a more detailed screenshot as well.

Thanks for the help.
Screen Shot 2021-11-01 at 11.04.28 AM.png

Will Ezell

unread,
Nov 2, 2021, 9:09:12 AMNov 2
to dot...@googlegroups.com
Elasticsearch is required to run dotCMS successfully. The docker compose yml file that is downloaded and run here includes elasticsearch and works - I just tested it on my Macbook

wget -O docker-compose.yml https://dotcms.com/run/demo && docker-compose up

Is elasticsearch throwing any errors when it is starting up?


--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dotcms+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/b1d029cc-fb6d-48ac-a899-1418699f0e17n%40googlegroups.com.


--



382 NE 191st St #92150
Miami, Florida 33179-3899
Main: 
305-900-2001 | Direct: 978.294.9429

Michael H

unread,
Nov 2, 2021, 3:36:38 PMNov 2
to dotCMS User Group
Thanks for the response, Will.  I will give this a try soon, and let you know. 

Michael H

unread,
Nov 16, 2021, 12:13:55 PM (13 days ago) Nov 16
to dotCMS User Group
Hi Will,

I ran the comman you provided, and Elastic Search is still throwing the same error:

"dotcms_1         | 16:56:56.033  ERROR business.ESIndexAPI - Elasticsearch Attempt #1 : elasticsearch: Temporary failure in name resolution
dotcms_1         | 16:57:01.047  ERROR util.DotRestHighLevelClientProvider$1 - [host=http://elasticsearch:9200]"

I also tested with a yml file provided by John, and the same error occurs.

I've attached the full log to this message.

Thanks for the assistance.
dotcms_log_2.rtf

Will Ezell

unread,
Nov 16, 2021, 5:32:36 PM (13 days ago) Nov 16
to dot...@googlegroups.com
You can see elasticsearch die on this line - which is why dotCMS cannot connect to it. 

dotcms_elasticsearch_1 exited with code 137


It seems like you need to allocate more memory to your docker environment.  See this issue here:


Michael H

unread,
Nov 17, 2021, 3:54:11 PM (12 days ago) Nov 17
to dotCMS User Group
That worked.  Thanks!
Reply all
Reply to author
Forward
0 new messages