Agile Upgrade from 20.11.1 to 21.06

20 views
Skip to first unread message

Alex

unread,
Jul 25, 2021, 10:58:00 AMJul 25
to dotCMS User Group
Dear Group:

I tried to upgrade from 20.11.1 to 21.06.  When I executed the startup.sh script I get this error, either using Java 8 or Java 11. Any ideas what I have to do to fix this?

:/opt/dotcms-21.06/bin# ./startup.sh

JAVA_VERSION: 11.0

./startup.sh: 76: Syntax error: "(" unexpected (expecting ")")


When I look at the script startup.sh on line 76 takes me to this if expression:

# Lexicographic comparation

if [[ (($JAVA_VERSION < 11.0)) ]]; then 

  BYTE_BUDDY_VERSION="1.6.12";

fi

Regards,


Alex


Falzone, Chris

unread,
Jul 26, 2021, 8:53:36 AMJul 26
to dot...@googlegroups.com
Not exactly sure on that one .. if you back up one directory and run ./bin/startup.sh does it work correctly?  I think it is intended to run in the base directory, not from the bin directory directly.  

--
http://dotcms.com - Open Source Java Content Management
---
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dotcms+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dotcms/bacba51e-a7d5-44b3-a2c0-4b62abd0fec5n%40googlegroups.com.


--

Christopher Falzone

DevOps Engineer

A Q U E N T  /  VITAMIN T

Daniel Silva

unread,
Jul 26, 2021, 12:04:35 PMJul 26
to dotCMS User Group
Hi Alex, 

Try any of these: 
* Replace the shebang from #!/bin/sh to #!/bin/bash in the first line of the startup.sh
* Run with `bash bin/startup.sh` instead of `./bin/startup.sh`

Daniel

Lex Medeiros

unread,
Jul 27, 2021, 5:13:23 AMJul 27
to dot...@googlegroups.com
Dear Daniel:

Thank you so much for the instructions!  It worked!


Alex

Lex Medeiros

unread,
Jul 27, 2021, 5:36:55 AMJul 27
to dot...@googlegroups.com
Hi, Chris!

Thank you for the tip!

Alex

Reply all
Reply to author
Forward
0 new messages