AWS ECS Fargate | AWS Postgres RDS | DotRuntimeException: javax.naming.NameNotFoundException: Name [jdbc/dotCMSPool] is not bound in this Context. Unable to find [jdbc]

Skip to first unread message

Sarvesh Padwal

Nov 16, 2022, 9:15:40 AM11/16/22
to dotCMS User Group
I have setup dotCMS 22.10 on AWS Fargate with Postgres RDS.
When I setup this first time, It worked without any issue.
Today I tried to run the new task again in AWS ECS (basically restart), it is failing with error.

14:09:02.261 WARN hikari.HikariConfig - jdbc/dotCMSPool - leakDetectionThreshold is less than 2000ms or more than maxLifetime, disabling it.

14:09:02.264 INFO hikari.HikariDataSource - jdbc/dotCMSPool - Starting...

14:09:13.467 ERROR pool.HikariPool - jdbc/dotCMSPool - Exception during pool initialization.

org.postgresql.util.PSQLException: The connection attempt failed.
at org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl( ~[postgresql-42.2.8.jar:42.2.8]
at org.postgresql.core.ConnectionFactory.openConnection( ~[postgresql-42.2.8.jar:42.2.8]
at org.postgresql.jdbc.PgConnection.<init>( ~[postgresql-42.2.8.jar:42.2.8]
at org.postgresql.Driver.makeConnection( ~[postgresql-42.2.8.jar:42.2.8]
at org.postgresql.Driver.connect( ~[postgresql-42.2.8.jar:42.2.8]
at com.zaxxer.hikari.util.DriverDataSource.getConnection( ~[HikariCP-3.4.2.jar:?]
at com.zaxxer.hikari.pool.PoolBase.newConnection( ~[HikariCP-3.4.2.jar:?]
at com.zaxxer.hikari.pool.PoolBase.newPoolEntry( ~[HikariCP-3.4.2.jar:?]
at com.zaxxer.hikari.pool.HikariPool.createPoolEntry( ~[HikariCP-3.4.2.jar:?]
at com.zaxxer.hikari.pool.HikariPool.checkFailFast( ~[HikariCP-3.4.2.jar:?]
at com.zaxxer.hikari.pool.HikariPool.<init>( ~[HikariCP-3.4.2.jar:?]
at com.zaxxer.hikari.HikariDataSource.<init>( ~[HikariCP-3.4.2.jar:?]
at com.dotmarketing.db.SystemEnvDataSourceStrategy.apply( ~[dotcms_22.03.2_999999.jar:?]
at com.dotmarketing.db.DataSourceStrategyProvider.get( ~[dotcms_22.03.2_999999.jar:?]
at com.dotmarketing.db.DbConnectionFactory.getDataSource( ~[dotcms_22.03.2_999999.jar:?]
at com.dotmarketing.db.DbConnectionFactory.getConnection( ~[dotcms_22.03.2_999999.jar:?]
at com.dotmarketing.db.DbConnectionFactory.startTransactionIfNeeded( ~[dotcms_22.03.2_999999.jar:?]
at com.dotmarketing.db.LocalTransaction.wrap( ~[dotcms_22.03.2_999999.jar:?]
at com.dotcms.enterprise.license.LicenseManager$ ~[ee-22.03.2.jar:?]
at [?:?]
Caused by: connect timed out
at Method) ~[?:?]
at ~[?:?]
at ~[?:?]
at ~[?:?]
at ~[?:?]
at ~[?:?]
at org.postgresql.core.PGStream.<init>( ~[postgresql-42.2.8.jar:42.2.8]
at org.postgresql.core.v3.ConnectionFactoryImpl.tryConnect( ~[postgresql-42.2.8.jar:42.2.8]
at org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl( ~[postgresql-42.2.8.jar:42.2.8]
... 19 more

14:09:13.472 WARN db.DataSourceStrategyProvider - Error initializing datasource. Reason: Failed to initialize pool: The connection attempt failed.Trying to load datasource from context.xml ...

14:09:13.472 WARN db.DataSourceStrategyProvider - Failed to initialize pool: The connection attempt failed.

14:09:13.480 WARN db.DataSourceStrategyProvider - com.zaxxer.hikari.pool.HikariPool.throwPoolInitializationException(

14:09:13.492 ERROR db.TomcatDataSourceStrategy - ---------- Error getting dbconnection jdbc/dotCMSPool from context.xml

javax.naming.NameNotFoundException: Name [jdbc/dotCMSPool] is not bound in this Context. Unable to find [jdbc].

Will Ezell

Nov 16, 2022, 9:20:54 AM11/16/22
Is this a dockerized installation?  You need to specify your db connection using env variables.  You can see the correct variables here.  You should not need to modify anything else.

-- - Open Source Java Content Management
You received this message because you are subscribed to the Google Groups "dotCMS User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit


382 NE 191st St #92150
Miami, Florida 33179-3899
305-900-2001 | Direct: 978.294.9429

Sarvesh Padwal

Nov 16, 2022, 10:39:40 AM11/16/22
to dotCMS User Group
Hi Will,

Yes, It is dockerized application. It was working when I set it up the first time. When I try to re-run the container, it is failing

Reply all
Reply to author
0 new messages