with solr: correct # of results returned, but all objects in object_list are None

36 views
Skip to first unread message

Terence Collins

unread,
Jul 13, 2010, 2:18:28 PM7/13/10
to django-haystack
I can see that the data is correctly indexed in Solr, but when I run a
query via haystack my result in page.object_list are all None. I've
tried using load_all=false but it didn't affect this behavior.

Thanks for any ideas.

Daniel Lindsley

unread,
Jul 20, 2010, 2:24:27 AM7/20/10
to django-...@googlegroups.com
Terrance,


That's very odd and should not be the case. Without any code, I'd
be fumbling in the dark. I'd suggest walking through
http://docs.haystacksearch.org/dev/debugging.html#no-results-found-on-the-web-page.
If you still don't get any love after working your way through that,
post some code here and I'll do my best to help out.


Daniel

> --
> You received this message because you are subscribed to the Google Groups "django-haystack" group.
> To post to this group, send email to django-...@googlegroups.com.
> To unsubscribe from this group, send email to django-haysta...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/django-haystack?hl=en.
>
>

Daniel Lindsley

unread,
Jul 20, 2010, 2:25:08 AM7/20/10
to django-...@googlegroups.com
Terence,


Also, I'm a jerk for misspelling your name. My apologies.


Daniel

Andrey Aleev

unread,
Oct 14, 2016, 8:47:26 PM10/14/16
to django-haystack
Hey! I'm facing the same problem with Django 1.8.9, haystack 2.5.0 and solr 4.10.4. 
Anyone knows how to fix it?

вторник, 13 июля 2010 г., 21:18:28 UTC+3 пользователь Terence Collins написал:
Reply all
Reply to author
Forward
0 new messages