nav-toc is not showing in topics

44 views
Skip to first unread message

Saibul Haq

unread,
Jun 20, 2021, 1:57:59 AMJun 20
to DITA-OT Users
version: dita-ot-3.5.2

I just created a new plugin called org.custom.html6 and it extends from org.dita.html5

Trying to show nav-toc in all the pags. but the <nav> tag is not shown in <body> or above <main>

I just added the below lines in build.xml. 

<property name="html5.toc.generate" value="yes"/>
<property name="nav-toc" value="partial"/>

Even it is not adding <nav> for OOTB sources from <dita-ot>\docsrc\samples

Which Iam adding the below css is added to customized custom.css after generation.

nav[role="toc"] { float: left !important; width: 300px !important; } 
nav[role="toc"] li.active > a { font-weight: bold; }

Thanks in advance for you.

Saibul Haq

unread,
Jun 22, 2021, 2:07:03 AMJun 22
to DITA-OT Users
Am I missing anything?
Can someone help with this or give your suggestions. 

Kittu Reddy

unread,
Jun 27, 2021, 1:15:52 AMJun 27
to DITA-OT Users
Hi ,

I’m also facing the same issue, when trying to show the left nav-toc in all the pages with html5 custom plugin. Can someone please provide inputs ? Thanks in advance.
--
You received this message because you are subscribed to the Google Groups "DITA-OT Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dita-ot-user...@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/dita-ot-users/d55cb4c0-7667-4322-b7c5-01f7f6a27f44n%40googlegroups.com.

Saibul Haq

unread,
Jul 5, 2021, 2:50:55 AMJul 5
to DITA-OT Users
if you refer any .xsl in your plugin just comment the <feature tag and do dita --install and try the plugin.

Kittu Reddy

unread,
Jul 7, 2021, 8:44:02 PMJul 7
to Saibul Haq, DITA-OT Users
As mentioned I have commented and the issue was resolved, thank you.
Reply all
Reply to author
Forward
0 new messages