Embedded iframe under foreign tag is rendering as blank in html5

19 views
Skip to first unread message

Saibul Haq

unread,
Jun 9, 2021, 11:48:13 PMJun 9
to DITA-OT Users
Trying to show a google form under the iframe.  I have the below code in my concept and it renders only begin foreign and end foreign tags in the generated output. between these two it has empty <p/> tag when I do inspect in the browser. 

Am I missing anything or Do I need to add any plugin to include the CDATA at compile time. Advance thanks for your answers.


<concept id="what_is_a_cache">
<title>This is Concept Title</title>
<shortdesc>Everything you'll ever need to know about
<term>cache</term>s.</shortdesc>
<conbody>
<p>begin foreign</p>    
  
<p>
<foreign outputclass="html-embed"><![CDATA[
<iframe width="420" height="315" 
  frameborder="0" allowfullscreen="true">
</iframe>
]]></foreign>
</p>
<p>ends foreign </p>
</conbody>
</concept>

Radu Coravu

unread,
Jun 10, 2021, 12:36:27 AMJun 10
to Saibul Haq, DITA-OT Users
Hi,

The DITA OT does not have this functionality of the box. You would need to install this plugin that I created a while back:

Regards,
Radu

--
You received this message because you are subscribed to the Google Groups "DITA-OT Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dita-ot-user...@googlegroups.com.
To view this discussion on the web, visit https://groups.google.com/d/msgid/dita-ot-users/44e46bb0-79c2-4a5e-92de-b3cfa55a4b35n%40googlegroups.com.

Saibul Haq

unread,
Jun 11, 2021, 4:44:33 AMJun 11
to DITA-OT Users

Thanks. It works
Reply all
Reply to author
Forward
0 new messages