openmp error

8 views
Skip to first unread message

Luca Frediani

unread,
May 31, 2022, 3:46:16 AMMay 31
to dirac-users
Hi!

I'm trying to compile Dirac on my Mac. But I get the follwing error
"clang: error: unsupported option '-fopenmp'"
during the building step for "exatensor".

What I did:
1. Downloaded the tarball (version 22.0)
2. Run "./setup"
3. deactivated both openmp and pcm with "ccmake .."
4. run "make"

Let me know if you need more information about the installation and compilation.

Best,
Luca


Visscher, L. (Luuk)

unread,
Jun 8, 2022, 6:19:07 AMJun 8
to dirac...@googlegroups.com
Dear Luca,

Building with the clang compiler is problematic and not well supported by us. Best is to install the gnu compilers and make sure gcc points to these rather than the build-in apple command that will redirect to clang.

best regards,

Luuk




--
You received this message because you are subscribed to the Google Groups "dirac-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dirac-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dirac-users/e70dff8b-b872-4357-b37a-50a48e32a926n%40googlegroups.com.

Reply all
Reply to author
Forward
0 new messages