PowerFab 1000x hydraulics valves leaking

112 views
Skip to first unread message

Philippe Jacquet

unread,
Jun 11, 2014, 10:39:37 AM6/11/14
to diggers-du...@googlegroups.com
Hello,

I am the owner of a PowerFab 1000x (I guess) and since couple of months the
control command are leaking by the top.
It is actually only one of them. I did some research and figure out it is a
BLB Hydraulics command.
I tried to contact BLB, PowerFab, Sellers of BLB and nobody seems to be
able to help me.
I have no Tag on the control command and that it's one big problem for all
sellers.

If some of you have this machine, please, can you valid this control
command is the original one (see pictures) and if you can help me to find a
tag to be able to identify it.

Or maybe someone know how to fix my problem
Btw:I changed all o-rings, but one more time I am not sure if there are the
correct one.

Worst case scenario: What to choose if I decide to change the entire
control command.?

Thank you,
Philippe

Pilip79

unread,
Jun 16, 2014, 7:15:44 AM6/16/14
to diggers-du...@googlegroups.com
Hi,

Can we see the pictures look ugly from my computer ?
In case I sent it again.

Philippe
module_face1.jpg
module_face2.jpg
modules.jpg
modules2.jpg
Spools.JPG

Dig

unread,
Jul 4, 2017, 1:25:59 PM7/4/17
to diggers-dumpers-plant
HI, I have a powerfab 1000x & I have a leak same place as your powerfab had. Did you get your leak fixed. It was a few years ago you posted. I don't know if you still have the powerfab.

Thanks.

Dave

unread,
Nov 6, 2020, 10:01:45 AM11/6/20
to diggers-dumpers-plant
I also have the same issue on Powerfab 1250.  Did anyone manage to find out the correct size for the O rings?
Reply all
Reply to author
Forward
0 new messages