PDFGui Error defaults:: qt-5.6.2-vc9_6

31 views
Skip to first unread message

Marcel Maslyk

unread,
Jul 15, 2021, 3:49:11 PMJul 15
to diffpy-users
Hi all,
my name is Marcel and I am currently doing my Ph.D. in chemistry with focus on the crystallisation of cementious materials. 
As I am totally new to evaluation of total scattering data I have tried reading some papers by Professor Billinge, Professor Proffen and Dr. Keen. In addition I have started the book "Underneath the Bragg Peaks". 
All the materials take some time and thinking to get through but I think I am starting to get some kind of perspective on it. 
Therefore I would like to start using pdfgui to refine some pdf data. Using the procedure with the py27 environment I unfortunately get the following error:

                                                                                                                          
environment location: C:\University\Anaconda\envs\py27                                                         added / updated specs:           - diffpy.pdfgui[version='>=1.1.2']                                                                                                                                                                                                            The following NEW packages will be INSTALLED:                                                                        blas               pkgs/main/win-64::blas-1.0-mkl                                                                      
 ca-certificates    pkgs/main/win-64::ca-certificates-2021.7.5-haa95532_1                            cycler             pkgs/main/win-64::cycler-0.10.0-py27h59acbbf_0                                            diffpy.pdffit2     diffpy/win-64::diffpy.pdffit2-1.1-py27h6673631_1                                            diffpy.pdfgui      diffpy/win-64::diffpy.pdfgui-1.1.2-py27he35c5bd_2                                        diffpy.structure   diffpy/win-64::diffpy.structure-1.3.5-py27_0                                                    diffpy.utils       diffpy/win-64::diffpy.utils-1.2.1-py27_0                                                           icu                pkgs/free/win-64::icu-57.1-vc9_0                                                                    
 jpeg  pkgs/main/win-64::jpeg-9b-ha175dff_2                                                                
 libpng           pkgs/main/win-64::libpng-1.6.37-h7a46e7a_0                                                        
matplotlib         pkgs/free/win-64::matplotlib-1.5.3-np111py27_1                                               menuinst           pkgs/main/win-64::menuinst-1.4.16-py27h0c8e037_1                                   mkl                pkgs/free/win-64::mkl-2017.0.3-0                                                                     numpy              pkgs/free/win-64::numpy-1.11.3-py27_0                                                              openssl            pkgs/main/win-64::openssl-1.0.2u-h0c8e037_0                                              pycifrw            diffpy/win-64::pycifrw-4.4.1-py27_2                                                                  pyparsing          pkgs/main/noarch::pyparsing-2.4.7-pyhd3eb1b0_0                                       pyqt               pkgs/free/win-64::pyqt-5.6.0-py27_2                                                                  python-dateutil    pkgs/main/noarch::python-dateutil-2.8.1-pyhd3eb1b0_0                            pytz               pkgs/main/noarch::pytz-2021.1-pyhd3eb1b0_0                                                   pywin32            pkgs/main/win-64::pywin32-227-py27h0c8e037_1                                     qt                 pkgs/free/win-64::qt-5.6.2-vc9_6                                                                    
 sip    pkgs/main/win-64::sip-4.19.13-py27hc56fc5f_0                                                         
six             pkgs/main/noarch::six-1.16.0-pyhd3eb1b0_0                                                         
   tk              pkgs/free/win-64::tk-8.5.18-vc9_0                                                                
   wxpython         pkgs/free/win-64::wxpython-3.0-py27_0                                                            
    zlib               pkgs/main/win-64::zlib-1.2.11-h3cc03e0_3                                                                                                                                                                                                                    Proceed ([y]/n)? y                                                                                                                                 Preparing transaction: done                                                                                             Verifying transaction: done                                                                                             Executing transaction: done                                                                                         
ERROR conda.core.link:_execute(699): 
An error occurred while installing package 'defaults::qt-5.6.2-vc9_6'.             
Rolling back transaction: done                                                                                                        LinkError: post-link script failed for package defaults::qt-5.6.2-vc9_6                                    location of failed script: C:\University\Anaconda\envs\py27\Scripts\.qt-post-link.bat                                   ==> script messages <==                                                                                                 <None>   ==> script output <==                                                                                                   stdout:         1 Datei(en) kopiert.                                                                                                                                 stderr: Parameterformat falsch - 65001.                                                                                       return code: 1                                                                                                                                                       
A bit of searching using google shows that there are people who had similar issues when installing matplotlib for example. Unfortunately I am new to Python and don't have much experience regarding programming. 
Therefore I would like to ask if anybody had a similar issue or might know a solution to this error and might be willing to share it. 

Best regards and thanks in advance 
Marcel                                                

Peter Metz

unread,
Jul 19, 2021, 9:27:50 AMJul 19
to diffpy-users
Hi Marcel,

As you've noted, the error here seems to be with the qt dependency which isn't a PDFgui error, per se.

If you haven't worked through this yet, you could try installing the Qt packages alone and trying to determine what's causing the incompatibility in your environment (e.g as in https://python-qt-tutorial.readthedocs.io/en/latest/installing.html )

-Peter

Anna-Lena Hansen (IAM)

unread,
Jul 23, 2021, 11:40:11 AMJul 23
to diffpy...@googlegroups.com

Hi Marcel,

we had exactly the same problem last week. For us indeed, installing all necessary packages one after another worked well. We were not able to find what exactly solved the problem, but after a while it worked.

Sorry, not very sophisticated, but seems like no one has found the reason for it yet.

Cheers

Anna

--
You received this message because you are subscribed to the Google Groups "diffpy-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to diffpy-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/diffpy-users/164dbb82-8b4c-402a-9b6a-8069a3a87e7cn%40googlegroups.com.
-- 
Dr. Anna-Lena Hansen
anna-len...@kit.edu

Institute for Applied Materials - Energy Storage Systems - IAM-ESS
-Development of Scattering Techniques-
Karlsruhe Institute of Technology – KIT

Hermann-von-Helmholtz-Platz 1
D-76344 Eggenstein-Leopoldshafen
Tel.: +49 721 608-28512

Marcel Maslyk

unread,
Jul 25, 2021, 1:53:58 PMJul 25
to diffpy-users
Hi Peter and Anna-Lena,

thank you very much for your support. 
Unfortunately I haven't been able to run it. So far I tried uninstalling and reinstalling anaconda. 
Additionally I have tried to get it to run by using a clean miniconda prompt. 
So far nothing has worked unfortunately. The error remains the same. 
I have encountered the error on three different windows computers running on windows 10 and 7 (2 laptops , 1 tower). 
By chance I have installed it on a Mac where it somehow runs. 
It seems to be related to the encoding as I have found that the error is connected to the active code page 65001. 
Maybe it is related to the system language being German but as my informatic skills are very limited I have to gain more information. 
I just wanted to give a small update.

Best 
Marcel 
Reply all
Reply to author
Forward
0 new messages