xPDF 32bit error

20 views
Skip to first unread message

Adrian H Hill

unread,
Jul 21, 2015, 10:48:07 AM7/21/15
to diffp...@googlegroups.com
Hi all.

Yesterday I instaleld the xPDF 32 bit program (thanks Simon + others) and have justchecked it works correctly.  I do get an error on loading in the command prompt.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
WARNING:pyFAI.utils:Exception No module named fftw3: FFTw3 not available. Fallin
g back on Scipy
ERROR:pyFAI.io:h5py module missing
WARNING:pyFAI.opencl:Unable to import pyOpenCl. Please install it from: http://p
ypi.python.org/pypi/pyopencl
WARNING:pyFAI.azimuthalIntegrator:Unable to import pyFAI.ocl_azim
ERROR:pyFAI.azimuthalIntegrator:Unable to import pyFAI.ocl_azim_lut for Look-up
table based azimuthal integration on GPU
ERROR:pyFAI.azimuthalIntegrator:Unable to import pyFAI.ocl_azim_csr: pyopencl is
 not installed
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This seems to be to be related to just the 2-d detector integration.  Is there an easy way for me to fix this?

Thanks

Adrian

Xiaohao Yang

unread,
Jul 21, 2015, 10:50:52 AM7/21/15
to diffp...@googlegroups.com
These errors are safe to ignore. They do not effect the 2D integration. 

Best,
Xiaohao

--
You received this message because you are subscribed to the Google Groups "diffpy-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to diffpy-dev+...@googlegroups.com.
To post to this group, send email to diffp...@googlegroups.com.
Visit this group at http://groups.google.com/group/diffpy-dev.
For more options, visit https://groups.google.com/d/optout.



--
Xiaohao Yang

Applied Physics & Applied Mathematics
Columbia University
500 West 120th Street
Room 200 Mudd, MC 4701
New York, NY 10027

Email: xy2...@columbia.edu

Adrian H Hill

unread,
Jul 21, 2015, 10:55:05 AM7/21/15
to diffp...@googlegroups.com
Thanks Xiaohao.

Adrian
Reply all
Reply to author
Forward
0 new messages