Installation of Diaspora v0.6 on a Ubuntu v14.04 LTS server

11 views
Skip to first unread message

kire.sc...@googlemail.com

unread,
Sep 12, 2016, 3:06:30 PM9/12/16
to diaspora-dev

I try to install Diaspora according to the installation manual (https://wiki.diasporafoundation.org/Installation/Ubuntu/Trusty)

At the „Bundle“ paragraph I got a problem. The manual says: 


„This takes quite a while. You should get a green success message when it's finished […]“ 


but when I execute the following command: 


RAILS_ENV=production bin/bundle install --deployment --without test development --with postgresql


I get the following output (shortend):


[….]
Bundle complete! 137 Gemfile dependencies, 259 gems now installed.
Gems in the groups test and development were not installed.
Bundled gems are installed into ./vendor/bundle.
Post-install message from acts-as-taggable-on:
When upgrading

Re-run the migrations generator

    rake acts_as_taggable_on_engine
:install:migrations

This will create any new migrations and skip existing ones

Version 3.5.0 has a migration for mysql adapter

Post-install message from compass:

   
Compass is charityware. If you love it, please donate on our behalf at http://umdf.org/compass Thanks!

Post-install message from haml:

HEADS UP
! Haml 4.0 has many improvements, but also has changes that may break

your application
:

* Support for Ruby 1.8.6 dropped
* Support for Rails 2 dropped
* Sass filter now always outputs <style> tags
* Data attributes are now hyphenated, not underscored
* html2haml utility moved to the html2haml gem
* Textile and Maruku filters moved to the haml-contrib gem

For more info see:

http
://rubydoc.info/github/haml/haml/file/CHANGELOG.md

Post-install message from handlebars_assets:
Remember to rake assets:clean or rake assets:purge on update! this is required because of handlebars updates
Post-install message from rails-assets-blueimp-gallery:
This component doesn't define main assets in bower.json.
Please open new pull request in component'
s repository:
https
://github.com/blueimp/Gallery
Post-install message from rails-assets-jquery.ui:
This component doesn't define main assets in bower.json.
Please open new pull request in component'
s repository:
https
://github.com/jquery/jquery-ui

As you can see there is no green success message but a lot of „post-install“ messages and no warning or error message.

Now I am pretty confused and I don’t know what to do next. Maybe some can help me.


Thanks in advance.


Best wishes

Erik


Achilleas Pipinellis

unread,
Sep 13, 2016, 4:14:35 AM9/13/16
to diaspo...@googlegroups.com
On 09/11/2016 10:32 PM, kire.schumacher via diaspora-dev wrote:
> |
> Bundlecomplete!137Gemfiledependencies,259gems now installed.
> |

Since you see the above line, it means it worked. Go on to the next
step! The wiki needs updating :)


--
Blog: https://axilleas.me
Reply all
Reply to author
Forward
0 new messages