AWS port settings can not connect to Cassandra node public ip address connection failed

8 views
Skip to first unread message

Henry Hottelet

unread,
Dec 14, 2017, 7:59:54 PM12/14/17
to devops

I am running Cassandra 3.11.1 or Cassandra 2.1.5 on AWS EC2.

I have configured the port settings to allow incoming traffic according to these 2 attachments, and want to connect to the public ip address also shown in this attachment.

However, I am seeing a connection error in Datastax DevCenter 1.3.1 or 1.6 when I try to connect to the public ip address.

The specified host(s) could not be reached.
All host(s) tried for query failed (tried: /18.216.248.106:9042 (com.datastax.driver.core.TransportException: [/18.216.248.106:9042] Cannot connect))
[/18.216.248.106:9042] Cannot connect

I know that connecting to single node cassandra using stand alone cassandra has connected to DevCenter in the past, and am puzzled about why it does not connect on Amazon cloud.

Can someone who has experienced this before check my AWS port settings, and tell me where I have gone wrong?



AWSIPaddress.png
AWSPorts.png
Reply all
Reply to author
Forward
0 new messages