Fehler mit hyphsubst

159 views
Skip to first unread message

Martin Winter

unread,
Mar 12, 2021, 11:14:41 AMMar 12
to
Hallo,

um eine "gute" Silbentrennung zu erhalten, habe ich am Anfang eines
Tex-Dokuments immer das Paket "hyphensubst" geladen mit dem Befehl:

\RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}

Seit einiger Zeit erhalte ich nach dem Kompilieren den Hinweis:

Package hyphsubst Error: Unknown pattern `ngerman-x-latest'.
\ProcessOptions*

Mit der Trennung im folgenden Minimalbeispiel bin ich nicht zufrieden;
ob das an o.g. Package Error liegt, weiß ich nicht.

Minimalbeispiel:

\RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}
\documentclass{scrartcl}
\usepackage[ngerman]{babel}
\begin{document}
% Absatz 1
Der Versuch der automatischen Trennung des überaus langen Wortes
Wohnqualitätsgesetz gelingt leider nicht so, wie gewünscht -- genauer
gesagt wird das Wort überhaupt nicht getrennt.

% Absatz 2
Der Versuch der automatischen Trennung des überaus komplizierten Wortes
Wohnqualitätsgesetz zeigt, dass die Trennung nun doch an bestimmten
Stellen automatisch erfolgt, nämlich Wohn-quali\dots

% Absatz 3
Der Versuch der automatischen Trennung des recht komplizierten Wortes
Wohnqualitätsgesetz zeigt, dass die Trennung nun an bestimmten Stellen
gelingt, hier jetzt so: Wohnqua-litäts\dots

% Absatz 4
Der Versuch der automatischen Trennung des überaus langen Wortes
Wohnqualitäts"-ge"-setz gelingt leider nicht; mit einer entsprechenden
Trennhilfe klappt es natürlich: Wohnquqlitäts-gesetz.
\end{document}

In Absatz 1 wird nicht getrennt (Hinweis im Log-File: Overfull \hbox
(15.33444pt too wide) in paragraph).

In den Absätzen 2, 3 und 4 wird richtig getrennt.

Hat hier jemand einen Rat für mich?

Ich verwende Windows10, MiKTex2.9 und TeXstudio

Ich danke für Hinweise!

Martin

Ulrike Fischer

unread,
Mar 12, 2021, 1:03:09 PMMar 12
to
Am Fri, 12 Mar 2021 17:14:40 +0100 schrieb Martin Winter:

> Seit einiger Zeit erhalte ich nach dem Kompilieren den Hinweis:
>
> Package hyphsubst Error: Unknown pattern `ngerman-x-latest'.

> Minimalbeispiel:
>
> \RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}

Nach der Dokumentation von dehyph-exptl sollte man heutzutage eher

\usepackage[ngerman]{babel}
\babelprovide[hyphenrules=ngerman-x-latest]{ngerman}

verwenden.

> Ich verwende Windows10, MiKTex2.9 und TeXstudio

Mit texlive geht es, miktex spinnt bei mir aber auch. Für mich sieht
es nach einem miktex bug aus.

--
Ulrike Fischer
http://www.troubleshooting-tex.de/

Rolf Niepraschk

unread,
Mar 12, 2021, 1:10:39 PMMar 12
to
Am 12.03.21 um 19:03 schrieb Ulrike Fischer:
...
>
> Nach der Dokumentation von dehyph-exptl sollte man heutzutage eher
>
> \usepackage[ngerman]{babel}
> \babelprovide[hyphenrules=ngerman-x-latest]{ngerman}
>
> verwenden.
>
>> Ich verwende Windows10, MiKTex2.9 und TeXstudio
>
> Mit texlive geht es, miktex spinnt bei mir aber auch. Für mich sieht
> es nach einem miktex bug aus.
>

Interessanterweise wird damit das Wort »Wohnqualitätsgesetz« im ersten
Beispiel mit pdflatex auch nicht getrennt. Mit xelatex und lualatex
funktioniert es. Getestet habe ich es mit TeXLive 2021-pre.

...Rolf



Rolf Niepraschk

unread,
Mar 12, 2021, 1:25:45 PMMar 12
to
Am 12.03.21 um 19:10 schrieb Rolf Niepraschk:
...
> Interessanterweise wird damit das Wort »Wohnqualitätsgesetz« im ersten
> Beispiel mit pdflatex auch nicht getrennt. Mit xelatex und lualatex
> funktioniert es. Getestet habe ich es mit TeXLive 2021-pre.
>
> ...Rolf
>
Bitte ignorieren. Mit dem fehlenden

\usepackage[T1]{fontenc}

funktioniert es schon.

...Rolf


Martin Winter

unread,
Mar 12, 2021, 5:42:25 PMMar 12
to
Hallo,

vielen Dank!

Ulrike Fischer schrieb:
> Am Fri, 12 Mar 2021 17:14:40 +0100 schrieb Martin Winter:
>
>> Seit einiger Zeit erhalte ich nach dem Kompilieren den Hinweis:
>>
>> Package hyphsubst Error: Unknown pattern `ngerman-x-latest'.
>
>> Minimalbeispiel:
>>
>> \RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}
>
> Nach der Dokumentation von dehyph-exptl sollte man heutzutage eher
>
> \usepackage[ngerman]{babel}
> \babelprovide[hyphenrules=ngerman-x-latest]{ngerman}
>
> verwenden.
>

Das habe ich auch versucht: Das Ergebnis war das gleiche.

>
> Mit texlive geht es, miktex spinnt bei mir aber auch. Für mich sieht
> es nach einem miktex bug aus.
>

Inzwischen funktioniert MiKTeX überhaupt nicht mehr. Ich habe MiKTeX
deshalb deinstalliert und neu installiert. Jetzt kann ich überhaupt
nichts mehr kompilieren: Das Programm bricht mit der Fehlermeldung
"Konnte Default Compiler:PdfLaTeX: pdflatex.exe -enable-write18
-syntex=1 -interaction=nonstpmode "test".tex nicht starten.

Bei den Meldungen der Hinweis auf die unten angefügten log-Dateien, mit
denen ich leider nichts anfangen kann.

Vielleicht kannst du mir helfen; andernfalls würde ich doch texlive
ausprobieren.

Gruß
Martin

pdflatex.log:
2021-03-12 23:31:35,434+0100 INFO pdflatex - this process (8496)
started by 'texstudio' with command line: pdflatex.exe -enable-write18
-synctex=1 -interaction=nonstopmode test.tex
2021-03-12 23:31:35,450+0100 INFO pdflatex - allowing known shell commands
2021-03-12 23:31:35,450+0100 INFO pdflatex - allowing all shell commands
2021-03-12 23:31:35,488+0100 INFO pdflatex - going to create file:
pdflatex.fmt
2021-03-12 23:31:35,534+0100 INFO pdflatex.core - start process:
initexmf --dump-by-name=pdflatex --engine=pdftex
2021-03-12 23:31:38,399+0100 ERROR pdflatex - C:\Program Files\MiKTeX
2.9\miktex\bin\x64\initexmf.exe did not succeed; exitCode: 1
2021-03-12 23:31:38,399+0100 ERROR pdflatex - output:
2021-03-12 23:31:38,399+0100 ERROR pdflatex -
Sorry, but "MiKTeX Configuration Utility" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

C:\Users\Winter\AppData\Local\MiKTeX\2.9\miktex\log\initexmf.log

2021-03-12 23:31:38,399+0100 FATAL pdflatex.core - Die
Speicher-Dump-Datei konnte nicht gefunden werden.
2021-03-12 23:31:38,399+0100 FATAL pdflatex.core - Data:
fileName="pdflatex.fmt"
2021-03-12 23:31:38,399+0100 FATAL pdflatex.core - Source:
Libraries\MiKTeX\TeXAndFriends\texmfapp.cpp:717
2021-03-12 23:31:38,399+0100 FATAL pdflatex - Die Speicher-Dump-Datei
konnte nicht gefunden werden.
2021-03-12 23:31:38,399+0100 FATAL pdflatex - Info: fileName="pdflatex.fmt"
2021-03-12 23:31:38,399+0100 FATAL pdflatex - Source:
Libraries\MiKTeX\TeXAndFriends\texmfapp.cpp
2021-03-12 23:31:38,399+0100 FATAL pdflatex - Line: 717
2021-03-12 23:31:38,399+0100 INFO pdflatex - this process (8496)
finishes with exit code 1


initexmf.log:
2021-03-12 23:31:35,889+0100 INFO initexmf - this is MiKTeX
Configuration Utility 4.3 (MiKTeX 21.2)
2021-03-12 23:31:35,889+0100 INFO initexmf - this process (5016)
started by 'pdflatex' with command line: initexmf
--dump-by-name=pdflatex --engine=pdftex
2021-03-12 23:31:35,889+0100 INFO initexmf - Operating on the private
(per-user) MiKTeX setup
2021-03-12 23:31:35,904+0100 INFO initexmf - running:
miktex-makefmt.exe --engine=pdftex --dest-name=pdflatex --no-dump
pdflatex.ini --engine-option=-tcx=cp227.tcx --miktex-disable-maintenance
--miktex-disable-diagnose
2021-03-12 23:31:35,935+0100 INFO initexmf.core - start process:
miktex-makefmt.exe --engine=pdftex --dest-name=pdflatex --no-dump
pdflatex.ini --engine-option=-tcx=cp227.tcx --miktex-disable-maintenance
--miktex-disable-diagnose
2021-03-12 23:31:38,399+0100 ERROR initexmf - sub-process error output
has been saved to
'C:\Users\Winter\AppData\Local\MiKTeX\2.9\miktex\log\miktex-makefmt_2021-03-12-233138.out'
2021-03-12 23:31:38,399+0100 FATAL initexmf - The executed process did
not succeed.
2021-03-12 23:31:38,399+0100 FATAL initexmf - Info: fileName="C:\Program
Files\MiKTeX 2.9\miktex\bin\x64\miktex-makefmt.exe", exitCode="1"
2021-03-12 23:31:38,399+0100 FATAL initexmf - Source:
2021-03-12 23:31:38,399+0100 FATAL initexmf - Line: 0
2021-03-12 23:31:38,399+0100 INFO initexmf - this process (5016)
finishes with exit code 1


miktex-makefmt_2021-03-12-233138.out:
Running miktex-pdftex.exe...
This is pdfTeX, Version 3.141592653-2.6-1.40.22 (MiKTeX 21.2) (INITEX)

entering extended mode

(C:/Program Files/MiKTeX 2.9/tex/latex/00miktex/pdflatex.ini

(C:\Users\Winter\AppData\Roaming\MiKTeX\2.9\tex/generic/config\pdftexconfig.tex

)

(C:\Program Files\MiKTeX 2.9\tex/latex/base\latex.ltx

(C:\Program Files\MiKTeX 2.9\tex/latex/base\texsys.cfg)

./texsys.aux found





\@currdir set to: ./.





Assuming \openin and \input

have the same search path.





Defining UNIX/DOS style filename parser.



catcodes, registers, parameters,

LaTeX2e <2020-10-01> patch level 4

(C:\Program Files\MiKTeX 2.9\tex/latex/l3kernel\expl3.ltx

(C:\Program Files\MiKTeX 2.9\tex/latex/l3kernel\expl3-code.tex

(C:\Program Files\MiKTeX 2.9\tex/latex/l3kernel\l3deprecation.def)))

(C:\Program Files\MiKTeX 2.9\tex/latex/l3packages/xparse\xparse.ltx

(C:\Program Files\MiKTeX
2.9\tex/latex/l3packages/xparse\xparse-generic.tex))

hacks, control, par, spacing, files, font enco

Martin Winter

unread,
Mar 13, 2021, 7:52:06 AMMar 13
to
Hallo zusammen,

vielen Dank an Ulrike und Rolf für die Hilfe.

Derzeit funktioniert die Silbentrennung ohne Verwendung von
\RequirePackage[ngerman=ngerman-x-2021-02-26]{hyphsubst} und ohne
\babelprovide[hyphenrules=ngerman-x-2021-02-26]{ngerman}.

Wichtiger ist, dass auch MiKTeX überhaupt wieder funktioniert; dabei bin
ich recht chaotisch wie folgt vorgegangen:

1. MiKTeX deinstalliert und neu installiert: kein Erfolg
2. Aus einer Datensicherung alle Dateien im MiKTeX-Verzeichnis mit den
früheren Dateien überschrieben: kein Erfolg
3. Als ersten Schritt der abermalig geplanten Deinstallation habe ich
mithilfe der MiKTeX-Console im Benutzermodus unter dem Punkt
"Bereinigung" die Persönliche MiKTeX-Konfiguration zurückgesetzt. Damit
wurde der Ordner ...\AppData\Local\MiKTex gelöscht.
4. Vor dem endgültigen "MiKTeX entfernen" habe ich noch einmal versucht,
die tex-Datei zu kompilieren und seltsamerweise hat es problemlos geklappt.

Die Frage ist, ob es jetzt ratsam ist, Updates zu installieren --
miktex-qt5-bin-x64 vom 2021-03-08 erscheint mir zweifelhaft!

Martin Winter schrieb:

Martin Winter

unread,
Mar 13, 2021, 8:28:01 AMMar 13
to
Hallo,

ich habe jetzt verschiedene tex-Dateien problemlos kompiliert, auch
mehrmals.
Dann habe ich eine Datei, die
\RequirePackage[ngerman=ngerman-x-2021-02-26]{hyphsubst} enthielt
kompiliert, erhielt eine Fehlermeldung.

Seitdem funktioniert wieder gar nicht mehr.
Meldung:
Entschuldigung, aber pdflatex.exe schlug fehl. Die Log-Datei enthält
hoffentlich alle Informationen, um MiKTeX wieder in Gang zu bringen.
C:\Users\Winter\AppData\Local\MiKTeX\2.9\miktex\log\pdflatex.log
Prozess endete mit Fehler(n)

Hat jemand eine Idee?

Gruß
Martin

Martin Winter schrieb:

Julius Dittmar

unread,
Mar 13, 2021, 10:22:03 AMMar 13
to
Am 13.03.21 um 14:28 schrieb Martin Winter:
> Hallo,
>
> ich habe jetzt verschiedene tex-Dateien problemlos kompiliert, auch
> mehrmals.
> Dann habe ich eine Datei, die
> \RequirePackage[ngerman=ngerman-x-2021-02-26]{hyphsubst} enthielt
> kompiliert, erhielt eine Fehlermeldung.
>
> Seitdem funktioniert wieder gar nicht mehr.
> Meldung:
> Entschuldigung, aber pdflatex.exe schlug fehl. Die Log-Datei enthält
> hoffentlich alle Informationen, um MiKTeX wieder in Gang zu bringen.
> C:\Users\Winter\AppData\Local\MiKTeX\2.9\miktex\log\pdflatex.log
> Prozess endete mit Fehler(n)
>
> Hat jemand eine Idee?

Die .aux-Datei dieses Laufs löschen. Danach nochmal versuchen.

Rolf Niepraschk

unread,
Mar 13, 2021, 12:22:24 PMMar 13
to
Am 13.03.21 um 13:52 schrieb Martin Winter:
> Hallo zusammen,
>
> vielen Dank an Ulrike und Rolf für die Hilfe.
>
> Derzeit funktioniert die Silbentrennung ohne Verwendung von
> \RequirePackage[ngerman=ngerman-x-2021-02-26]{hyphsubst} und ohne
> \babelprovide[hyphenrules=ngerman-x-2021-02-26]{ngerman}.
>


Du solltest aber schon die Zeile

\babelprovide[hyphenrules=ngerman-x-latest]{ngerman}

bevorzugen, da dies von den Fachleuten empfohlen wird:

https://www.ctan.org/pkg/dehyph-exptl

...Rolf

Martin Winter

unread,
Mar 13, 2021, 1:48:04 PMMar 13
to
Hallo zusammen,

wenn es noch jemanden interessiert: Hier die neueste "Entwicklung":

Ich habe mithilfe der Tex Collection 2020 sowohl MiKTeX als auch
TeXstudio deinstalliert und global neu installiert - zunächst ohne
Updates zu installieren; meine verschiedenen "Testfiles" wurden dann
alle problemlos kompiliert.
Nach dem Installieren der Updates mithilfe der MiKTeX-Console traten
wieder Fehler auf, so dass das Kompilieren nicht funktioniert hat.

Anschließend habe ich wieder deinstalliert und MiKTeX nun lokal
installiert; ohne Updates hat alles funktioniert.
Nach dem Update in MiKTeX hat pdflatex.exe funktioniert, aber nicht
latex.exe. Im TeXstudio ist latex mit der Option -scr voreingestellt;
nachdem ich diese Option entfernt habe, läuft jetzt auch latex.exe.

Noch eine Beobachtung:
Vor dem Update waren in der MiKTeX Console bei Einstellungen - Sprachen
german-x-latest und ngerman-x-latest als installiert markiert, nach dem
Update fehlen die Häckchen in der Spalte "Installiert".

Danke noch einmal allen, die sich für mich Gedanken gemacht haben!

Martin


Ulrike Fischer

unread,
Mar 13, 2021, 2:46:57 PMMar 13
to
Am Sat, 13 Mar 2021 19:48:02 +0100 schrieb Martin Winter:

> Ich habe mithilfe der Tex Collection 2020 sowohl MiKTeX als auch
> TeXstudio deinstalliert und global neu installiert -

Ich finde es immer wieder erstaunlich. Du hast ein kleines Problem
-- irgendwelche Trennmuster sind nicht da -- und statt das Problem
anzugehen, reißt du lieber gleich das ganze Haus ab.

Was erwartest du denn von so einer Aktion? Wenn miktex einen Bug
hat, verschwindet sowas selten durch Neuinstallation.

> Noch eine Beobachtung:
> Vor dem Update waren in der MiKTeX Console bei Einstellungen - Sprachen
> german-x-latest und ngerman-x-latest als installiert markiert, nach dem
> Update fehlen die Häckchen in der Spalte "Installiert".

Du könntest eine lokale languages.ini verwenden, aber ich habe das
zu miktex gemeldet, und wahrscheinlich wird es sich in ein paar
Tagen von selbst auflösen.

https://github.com/MiKTeX/miktex-packaging/issues/233


--
Ulrike Fischer
https://www.troubleshooting-tex.de/

Martin Winter

unread,
Mar 13, 2021, 3:51:05 PMMar 13
to
Hallo,

Ulrike Fischer schrieb:
> Am Sat, 13 Mar 2021 19:48:02 +0100 schrieb Martin Winter:
>
>> Ich habe mithilfe der Tex Collection 2020 sowohl MiKTeX als auch
>> TeXstudio deinstalliert und global neu installiert -
>
> Ich finde es immer wieder erstaunlich. Du hast ein kleines Problem
> -- irgendwelche Trennmuster sind nicht da -- und statt das Problem
> anzugehen, reißt du lieber gleich das ganze Haus ab.

Ich habe das nicht mehr als Problem mit einem Trennmuster gesehen,
vielmehr wurde überhaupt kein tex-file mehr kompiliert. Selbst bei dem
folgenden Minimalst-Beispiel

\documentclass{article}
\begin{document}
test
\end{document}

gab es eine Fehlermeldung, es wurd keine dvi- oder pdf-Datei erzeugt,
sondern es wurde auf pdflatex.log verwiesen

Dort stand etwa folgendes:
2021-03-12 23:31:35,488+0100 INFO pdflatex - going to create file:
pdflatex.fmt
2021-03-12 23:31:35,534+0100 INFO pdflatex.core - start process:
initexmf --dump-by-name=pdflatex --engine=pdftex
2021-03-12 23:31:38,399+0100 ERROR pdflatex - C:\Program Files\MiKTeX
2.9\miktex\bin\x64\initexmf.exe did not succeed; exitCode: 1

Im initexmf.log gab es weitere Fehlermeldungen.

Leider bin ich nicht so firm, dass ich hiermit etwas anfangen könnte.

Um bei deinem Bild zu bleiben: Manchmal ist es wirklich einfacher, ein
Haus einzureißen und neu aufzubauen, als ein marodes Haus zu renovieren.

Und Melanie Reuter erhielt auf ihre Anfrage wegen TeXnicCenter vom
08.02.2021 genau diesen Rat: deinstallieren und neu installieren.

>
> Was erwartest du denn von so einer Aktion? Wenn miktex einen Bug
> hat, verschwindet sowas selten durch Neuinstallation.

Immerhin habe ich dadurch erfahren, dass das Problem wohl etwas mit
einem kürzlichen Update zu tun hat. Und selbst nach dem jetzt
durchgeführten Update hat pdflatex.exe funktioniert und latex.exe habe
ich jetzt auch noch zum Laufen gebracht.

Es ist mir auch immer noch nicht klar, wie das ursprünglichen Problem,
also der Bug mit dem Trennmuster, schließlich dazu geführt hat, dass
überhaupt nichts mehr ging.

Auf der Hilfe-Seite von MiKTex findet man den Satz: "It is highly
recommended that you choose a private installation." Bei Installation
von der DVD ist die globale Installation voreingestellt. Wegen dieses
"Widerspruchs" habe ich eben beide Installationen nacheinander versucht:
Und die private Installation funktioniert - zumindest bisher ;-).

Gruß
Martin

Uwe Siart

unread,
Mar 15, 2021, 2:34:15 AMMar 15
to
Rolf Niepraschk <Rolf.Ni...@gmx.de> writes:

> Du solltest aber schon die Zeile
>
> \babelprovide[hyphenrules=ngerman-x-latest]{ngerman}
>
> bevorzugen, da dies von den Fachleuten empfohlen wird:

Soeben stelle ich fest, dass damit die private Ausnahmeliste
(\hyphenation{}) nicht mehr berücksichtigt wird:

\documentclass{scrartcl}
\usepackage[T1]{fontenc}
\usepackage[main=ngerman]{babel}
\babelprovide[hyphenrules=ngerman-x-latest]{ngerman}
\hyphenation{Steg-lei-tung}
\begin{document}
\showhyphens{Stegleitung}
\end{document}

Laut Doku von 'dehyph-exptl' sollte das aber gehen.

Ist da ein Bugreport fällig oder benutze ich die Sachen hier falsch?

--
Uwe

Rolf Niepraschk

unread,
Mar 15, 2021, 3:11:29 AMMar 15
to
Am 15.03.21 um 07:34 schrieb Uwe Siart:> Rolf Niepraschk
<Rolf.Ni...@gmx.de> writes:
>
>> Du solltest aber schon die Zeile
>>
>> \babelprovide[hyphenrules=ngerman-x-latest]{ngerman}
>>
>> bevorzugen, da dies von den Fachleuten empfohlen wird:
>
> Soeben stelle ich fest, dass damit die private Ausnahmeliste
> (\hyphenation{}) nicht mehr berücksichtigt wird:
>
> \documentclass{scrartcl}
> \usepackage[T1]{fontenc}
> \usepackage[main=ngerman]{babel}
> \babelprovide[hyphenrules=ngerman-x-latest]{ngerman}
> \hyphenation{Steg-lei-tung}
> \begin{document}
> \showhyphens{Stegleitung}
> \end{document}
Ich kann dies bestätigen, womit ich meine Empfehlung widerrufe. Im
anderen Fall, also mit

\RequirePackage[ngerman=ngerman-x-latest]{hyphsubst}

liefert \showhyphens das richtig Ergebnis.

>
> Laut Doku von 'dehyph-exptl' sollte das aber gehen.
>
> Ist da ein Bugreport fällig oder benutze ich die Sachen hier falsch?
>
Ich denke, dass es wohl ein Bug ist. Am besten direkt zu "babel"

https://github.com/latex3/babel/issues

und CC nach trenn...@dante.de

...Rolf

Ulrike Fischer

unread,
Mar 15, 2021, 3:17:27 AMMar 15
to
Es geht wenn man explizit die Sprache nochmal auswählt:

\selectlanguage{ngerman}
\hyphenation{Steg-lei-tung}

Aber ich finde es etwas merkwürdig. Ich denke, du solltest es babel
mal melden.

Uwe Siart

unread,
Mar 15, 2021, 6:28:02 AMMar 15
to
Ulrike Fischer <ne...@nililand.de> writes:

> Aber ich finde es etwas merkwürdig. Ich denke, du solltest es babel
> mal melden.

Hab versucht, mich bei Github zu registrieren. Nach zehnmal
Würfelsuchen, sagt er mir fröhlich, dass ich zu langsam war. Da hab ich
jetzt keinen Nerv dafür. Man kann alles übertreiben.

--
Uwe

Ulrike Fischer

unread,
Mar 15, 2021, 8:13:16 AMMar 15
to
Am Mon, 15 Mar 2021 11:27:58 +0100 schrieb Uwe Siart:


>> Aber ich finde es etwas merkwürdig. Ich denke, du solltest es babel
>> mal melden.
>
> Hab versucht, mich bei Github zu registrieren. Nach zehnmal
> Würfelsuchen, sagt er mir fröhlich, dass ich zu langsam war. Da hab ich
> jetzt keinen Nerv dafür. Man kann alles übertreiben.

https://github.com/latex3/babel/issues/122

Uwe Siart

unread,
Mar 15, 2021, 10:28:49 AMMar 15
to
Ulrike Fischer <ne...@nililand.de> writes:

> https://github.com/latex3/babel/issues/122

Danke dir.

--
Uwe

Martin Winter

unread,
Mar 19, 2021, 5:41:22 AMMar 19
to
Hallo,

um die Dskussionsteilnehmer, bei denen ich mich hier noch einmal
bedanken möchte, über den weiteren Verlauf zu informieren, hier der
"Abschlussbericht":

Martin Winter schrieb:
Die mangelnde Trennung trat bei einem längeren Dokument auf; ich habe
dann ein Minimalbeispiel konstruiert, das diesen Fehler zeigte. Mein
dummer Fehler war, dass ich diese Datei "hyphen.tex" genannt habe; damit
war das MiKTeX-System "außer Gefecht" gesetzt.

Ich danke ganz herzlich Ulrike, die den Fehler mithilfe der Logdateien
gefunden hat.

Viele Grüße
Martin

Uwe Siart

unread,
Mar 20, 2021, 5:02:47 AMMar 20
to
Rolf Niepraschk <Rolf.Ni...@gmx.de> writes:

> Ich kann dies bestätigen, womit ich meine Empfehlung widerrufe.

Den Kommentaren zum Bugreport von Ulrike entnehme ich jetzt, dass

\babelprovide[hyphenrules=ngerman-x-latest]{ngerman}

schon aktuell der richtige Weg ist, die experimentellen Trennmuster zu
laden. Aber man sollte bei Verwendung von 'babel' die Ausnahmen mit
\babelhyphenation{} angeben und \hyphenation{} lieber nicht verwenden.

--
Uwe
Reply all
Reply to author
Forward
0 new messages