Grafikkarten-Wechsel

0 views
Skip to first unread message

Richard Fonfara

unread,
Sep 24, 2021, 2:48:27 PMSep 24
to
Hallo,

neuerdings habe ich bei Thunderbird und Firefox gelegentlich
Grafikstörungen: weiße Punkte auf schwarzem Feld, bunte Muster oder
Textauszüge wirr durcheinander. Ich vermute, dass meine Grafikkarte
hinüber ist, und möchte sie deshalb austauschen.

Nach meiner Erfahrung bedeutet dass, das X dann nicht mehr startet. Wie
kriege ich den X-Server zum Laufen?

Bitte ganz ausführlich schreiben, denn ich habe nicht allzu viel Ahnung
von Linux. Ich benutze übrigens Manjaro.

--
MfG
Richard

Marco Moock

unread,
Sep 24, 2021, 2:53:07 PMSep 24
to
Am Fri, 24 Sep 2021 20:48:25 +0200
schrieb Richard Fonfara <junk_s...@yahoo.de>:
In der Regel kommt das auf den verwendeten Treiber an. Ich selbst nutze nur Ubuntu und Debian und kann hier berichten, dass normalerweise der XServer auch mit einer neuen GraKa startet, er startet aber z.B. nicht richtig, wenn man manuell den nvidia-Treiber installiert und nicht entfernt hat.
Was ist denn aktuell für eine Karte drinnen und was für eine soll rein?
Mit welchem Treiber läuft diese?
Sollte das nicht auf Anhieb klappen kannst du auch die alte GraKa
wieder einbauen.
---
Marco

Richard Fonfara

unread,
Sep 24, 2021, 3:51:19 PMSep 24
to
Am 24.09.21 um 20:53 Uhr schrieb Marco Moock:

> Am Fri, 24 Sep 2021 20:48:25 +0200
> schrieb Richard Fonfara <junk_s...@yahoo.de>:
>
>> neuerdings habe ich bei Thunderbird und Firefox gelegentlich
>> Grafikstörungen: weiße Punkte auf schwarzem Feld, bunte Muster oder
>> Textauszüge wirr durcheinander. Ich vermute, dass meine Grafikkarte
>> hinüber ist, und möchte sie deshalb austauschen.
>>
>> Nach meiner Erfahrung bedeutet dass, das X dann nicht mehr startet.
>> Wie kriege ich den X-Server zum Laufen?
>>
>> Bitte ganz ausführlich schreiben, denn ich habe nicht allzu viel
>> Ahnung von Linux. Ich benutze übrigens Manjaro.
>>
> In der Regel kommt das auf den verwendeten Treiber an. Ich selbst nutze nur Ubuntu und Debian und kann hier berichten, dass normalerweise der XServer auch mit einer neuen GraKa startet, er startet aber z.B. nicht richtig, wenn man manuell den nvidia-Treiber installiert und nicht entfernt hat.
> Was ist denn aktuell für eine Karte drinnen und was für eine soll rein?

Momentan ist lt. Systeminformationen eine AMD Caicos [Radeo HD
6450/7450/8450 / R5 230 OEM] von einem Fremdhersteller namens Pegatron
drin. Ich habe hier eine Graka liegen, von der ich nicht so recht weiß,
was das für eine ist. Auf einem Aufkleber steht PIN:NEAT7300HD46-2080H.

> Mit welchem Treiber läuft diese?

In der KDE-Hardwarekonfiguration sieht das folgendermaßen aus:

Offene Quellen Installiert
video-linux x x
video-modesetting x
video-vesa x

Daraus werde ich nicht schlau. Wie müsste ich vorgehen, wenn ich da was
ändern wollte?

> Sollte das nicht auf Anhieb klappen kannst du auch die alte GraKa
> wieder einbauen.

--
MfG
Richard

Marco Moock

unread,
Sep 24, 2021, 4:20:11 PMSep 24
to
Am Fri, 24 Sep 2021 21:51:17 +0200
schrieb Richard Fonfara <junk_s...@yahoo.de>:
> Momentan ist lt. Systeminformationen eine AMD Caicos [Radeo HD
> 6450/7450/8450 / R5 230 OEM] von einem Fremdhersteller namens Pegatron
> drin. Ich habe hier eine Graka liegen, von der ich nicht so recht
> weiß, was das für eine ist. Auf einem Aufkleber steht
> PIN:NEAT7300HD46-2080H.
Das ist wohl eine GeForce 730. Die sollte vom freien nouveau-Treiber unterstützt werden.
Einfach einbauen und probieren
>
> > Mit welchem Treiber läuft diese?
Das wird entweder amdgpu oder radeon sein.
Prüfe das mit lspci -nnk
und poste ggf. den Teil zur GraKa.

> Daraus werde ich nicht schlau. Wie müsste ich vorgehen, wenn ich da
> was ändern wollte?
Hier müsste man ggf. einen Treiber deistallieren, kommt drauf an, welcher das ist und wie der installiert wurde. Da ich mich mit Manjaro nicht auskenne kann ich da kaum bis gar nicht helfen.

Dietz Proepper

unread,
Sep 25, 2021, 7:11:49 AMSep 25
to
Richard Fonfara <junk_s...@yahoo.de> wrote:

> Hallo,
>
> neuerdings habe ich bei Thunderbird und Firefox gelegentlich
> Grafikstörungen: weiße Punkte auf schwarzem Feld, bunte Muster oder
> Textauszüge wirr durcheinander. Ich vermute, dass meine Grafikkarte
> hinüber ist, und möchte sie deshalb austauschen.

i915? Ja, das habe ich am Laptop so seit ca. Juni gelegentlich. Es
scheint aber kein Hardwareproblem zu sein. Wenn ich (KDE-Kind) in den
Composer-Einstellungen z.B. die tearing-Einstellungen ändere, dann ist
der Effekt verschwunden. Kommt manchmal nach ein paar Stunden wieder.

Was die wahre Ursache ist - who knows.

Marco Moock

unread,
Sep 25, 2021, 7:33:46 AMSep 25
to
Am Sat, 25 Sep 2021 13:11:47 +0200
schrieb Dietz Proepper <dietz-...@rotfl.franken.de>:
Die Radeon ist kein Intel i915G (das ist ein Chipsatz mit IGP von Intel für Pentium 4) und wird auch nicht mit dem i915-Treiber für Intel-IGPs betrieben, entweder radeon, fglrx (uralt) oder amdgpu (sofern das diese Karte schon kann).

Dietz Proepper

unread,
Sep 25, 2021, 7:38:39 AMSep 25
to
Hab's auch erst im Nachgang gelesen.

Richard Fonfara

unread,
Sep 25, 2021, 3:20:24 PMSep 25
to
Am 25.09.21 um 08:26 Uhr schrieb Andreas Kohlbach:

> On Fri, 24 Sep 2021 20:48:25 +0200, Richard Fonfara wrote:
>>
[Grafikkarte defekt?]
>
> Das mag nur an einem Update des Treibers oder des Desktop-Environments
> liegen. Seit einiger Zeit ist eine der Leisten im Chromium-Browser
> schwarz, bis ich mit der Maus drüberfahre.
>
[...]
>
> Ich würde die Karte nicht austauschen. Vielleicht nur ein Bug im Treiber,
> der irgendwann behoben wird.

Heute gab's die Version 91.1.1 von Thunderbird (neben 185 weiteren
Updates für Manjaro). Ich hatte über 30 E-Mails und Newsletter zu lesen
und habe zu meiner Verwunderung keine Grafikstörungen festgestellt.
Vielleicht ist der Fehler damit ja behoben.

Ich werde zunächst keine Grafikkarte auswechseln und die Sache noch eine
Zeitlang beobachten.
>
> Sonst sollte auch Manjaro (kenne ich nicht) einen "safe-mode" haben,
> falls es mit veränderter Hardware nicht mehr normal bootet. Dann hat man
> eine niedrigere Auflösung, kann aber arbeiten, um andere Optionen zu
> testen, um das System wieder in der vollen Auflösung zu betreiben.
>


--
MfG
Richard
Reply all
Reply to author
Forward
0 new messages