Uhrzeit immer falsch trotz neuer Bios-Batterie

3 views
Skip to first unread message

Steve Frank

unread,
Mar 18, 2017, 5:41:05 PM3/18/17
to
Hallo NG,

kurioses Fehlerbild hier bei einem älteren Asrock AM2-Board.
Die Uhrzeit (und nur diese) ist beim Wiedereinschalten meist um
Stunden/Minuten nach hinten versetzt, sprich sie geht nach.
Bios-Batterie schon mehrfach ausgetauscht. Im laufenden Betrieb geht die
Uhr korrekt (wenn sie zuvor korrigiert wurde).
Momentan behelfe ich mir, durch die automatische Uhrzeitaktualisierung
über Windows, was aber nicht die Lösung sein kann.
Board platt? Wäre nur ein Taktgeber defekt, dann müßte die Uhrzeit
meiner Meinung nach auch im laufenden Betrieb nachgehen (nach erfolgter
automatischer Korrektur und Trennen der Netzwerkverbindung), was aber
nicht der Fall ist.
Mehrfach ist mir aufgefallen, dass die (falsche) Uhrzeit beim
Wiedereinschalten genau die ist, die aktuell war, als das Board/Rechner
zuletzt ausgeschaltet wurde.

Marcel Mueller

unread,
Mar 18, 2017, 6:58:53 PM3/18/17
to
On 18.03.17 22.41, Steve Frank wrote:
> kurioses Fehlerbild hier bei einem älteren Asrock AM2-Board.
> Die Uhrzeit (und nur diese) ist beim Wiedereinschalten meist um
> Stunden/Minuten nach hinten versetzt, sprich sie geht nach.
> Bios-Batterie schon mehrfach ausgetauscht.

- Defekter Uhrenchip oder Quartz.
- Treiberproblem.

> Im laufenden Betrieb geht die
> Uhr korrekt (wenn sie zuvor korrigiert wurde).

Logisch, da wird der Chip nicht gelesen. Der wird nur einmal beim
Starten benutzt.

> Momentan behelfe ich mir, durch die automatische Uhrzeitaktualisierung
> über Windows, was aber nicht die Lösung sein kann.

Das ist doch eine gute Lösung.
In Zeiten von 24/7 Internet braucht man die RTC eigentlich nicht mehr.
Wenn nicht der Anachronismus mit den 256 Bytes CMOS-RAM noch leben
würde, könnte man die Batterie komplett entfernen.

> Board platt? Wäre nur ein Taktgeber defekt, dann müßte die Uhrzeit
> meiner Meinung nach auch im laufenden Betrieb nachgehen (nach erfolgter
> automatischer Korrektur und Trennen der Netzwerkverbindung), was aber
> nicht der Fall ist.

Nope. Sobald die Kiste einmal an ist, übernimmt der Interrupt-Timer.

> Mehrfach ist mir aufgefallen, dass die (falsche) Uhrzeit beim
> Wiedereinschalten genau die ist, die aktuell war, als das Board/Rechner
> zuletzt ausgeschaltet wurde.

Dann steht die Uhr. Beim Herunterfahren schreibt das OS nämlich die Zeit
im Chip neu.


Marcel
Reply all
Reply to author
Forward
0 new messages