[Agent 1.3 - 8.0] Agent und SSL/TLS1.2/TLS1.3

1 view
Skip to first unread message

Thomas Barghahn

unread,
Jan 23, 2022, 2:38:19 AMJan 23
to
Hallo zusammen,

der Originalbeitrag von Ralph Fox ist hier zu finden:

| From: Ralph Fox <-rf-nz-@-.invalid>
| Newsgroups: alt.usenet.offline-reader.forte-agent
| Subject: Notice: Agent and SSL
| Message-ID: <p8hpuglnb0tot2oot...@4ax.com>
| Date: Sun, 23 Jan 2022 16:22:04 +1300

>If you use SSL in Agent 3.2 - 8.0, or if you want to use SSL, these days
>you may need to make the following configuration change in AGENT.INI.


> In the [Online] section of AGENT.INI,
> change the setting 'AllowedSSLProtocols' from this:

> AllowedSSLProtocols=0

> to one of these:
> * In Windows 11, and in Windows 10 version 1903 and later

> AllowedSSLProtocols=10880

> * In Windows before Windows 10 version 1903

> AllowedSSLProtocols=2688


>EXPLANATION

>When Agent's SSL was implemented, the highest version of SSL in
>use was TLS1.0. The AGENT.INI default setting AllowedSSLProtocols=0
>will support versions of SSL up to TLS1.0.

>Since then, TLS1.0 has been deprecated. Many mail servers and some news
>servers have stopped using TLS1.0. Many mail servers and some news servers
>now require a minimum SSL version of TLS1.2.

>The setting AllowedSSLProtocols=2688 will configure Agent to support
>SSL versions up to TLS1.2 (providing your Windows supports it; do not
>expect it to work on Windows 95).

>The setting AllowedSSLProtocols=10880 will configure Agent to support
>SSL versions up to TLS1.3 in Windows 10.1903 and later.

Thomas 😷

F'up to: <news:de.comm.software.forte-agent
--
+++ +++ +++ +++ +++ +++ +++ +++ +++ +++ +++ +++ +++ +
Geizige Menschen sind unangenehme Zeitgenossen - aber
angenehme Vorfahren!
+++ +++ +++ +++ +++ +++ +++ +++ +++ +++ +++ +++ +++ +
Reply all
Reply to author
Forward
0 new messages