SM: Lausige Darstellung der Youtube-INet-Präsenz

4 views
Skip to first unread message

Helge Adler

unread,
Dec 11, 2021, 12:47:45 AM12/11/21
to
Hallo Auskenner,

was meint ihr zu der Darstellung, wenn ich mit Seamonkey, aktuelle
Version 2.53.10, die Startseite von www.youtube.de aufrufe? *)

https://ibb.co/thBN78y

Das war auch schon mit der SM-Vorgängerversion solch eine lausige
Ansicht.
Damit kann ich auch keine Yt-Unterseiten aufrufen, bzw. bedienen. Mit
draufklicken auf eines der Ersatz-"Symbole" is also nix.

Sowie ich jedoch mit dem *Test*-Profil die youtube-Seite aufrufe,
sieht alles normal aus und funktioniert normal.

Auch möglich, daß nach einer Neuinstallation von SM erst einmal alles
wieder richtig präsentiert wird, aber nach einiger Zeit ist die
Darstellung von Yt wieder futsch.

Gleichzeitig werden andere Webseiten normal angezeigt und können
normal bedient werden!

An den Einstellungen im SM-Konfigurations-Menü sieht alles normal aus,
wie immer. Irgendwelche abwegigen Add-ones sind auch nicht
installiert.

Also, wie ist eure Meinung zu dem Fall? Was kann ich machen?
Mein Dank für jeden Tipp!


*) WIN10, 64-Bit-Version

Heiko Rost

unread,
Dec 11, 2021, 2:12:18 AM12/11/21
to
Helge Adler schrieb:

> was meint ihr zu der Darstellung, wenn ich mit Seamonkey, aktuelle
> Version 2.53.10, die Startseite von www.youtube.de aufrufe? *)
>
> https://ibb.co/thBN78y

Javascript deaktiviert oder ein AddOn mit entsprechender Funktion
(NoScript, Werbeblocker) installiert?

> Sowie ich jedoch mit dem *Test*-Profil die youtube-Seite aufrufe,
> sieht alles normal aus und funktioniert normal.
>
> Auch möglich, daß nach einer Neuinstallation von SM erst einmal alles
> wieder richtig präsentiert wird, aber nach einiger Zeit ist die
> Darstellung von Yt wieder futsch.

Wenn ein anderes Profil das Problem nicht zeigt, ist im Profil
irgendetwas verstellt. Eine Neuinstallation des Programms ist dann
nutzlos.

Gruß Heiko
--
Besser ein freier Teufel als ein gebundener Engel.
Peter Hille

Peter45

unread,
Dec 11, 2021, 4:12:51 AM12/11/21
to
Am 11.12.2021 um 06:47 schrieb Helge Adler:
> Hallo Auskenner,
>
> was meint ihr zu der Darstellung, wenn ich mit Seamonkey, aktuelle
> Version 2.53.10, die Startseite von www.youtube.de aufrufe? *)
>
> https://ibb.co/thBN78y
...
>
> Sowie ich jedoch mit dem *Test*-Profil die youtube-Seite aufrufe,
> sieht alles normal aus und funktioniert normal.
>
...

Hallo,

so wie ich das sehe, hast du in den Einstellungen unter Erweitert ->
HTTP-Verbindungen im Bereich User-Agent-String in deinem Profil
eingestellt, dass SeaMonkey sich als Firefox ausgeben soll. Dies war bis
Version 2.53.9.1 eine gute Einstellung. Seit 2.53.10 gibt sich SeaMonkey
dann jedoch als Firefox 68.0 anstelle von 60.0 aus, was Google
entsprechend quittiert. Im Testprofil steht der User-Agent vermutlich
auf als "SeaMonkey kompatibel mit Firefox ausweisen (Standard)", weshalb
das Testprofil sich entsprechend anders verhält.

Peter

Helge Adler

unread,
Dec 11, 2021, 7:28:25 PM12/11/21
to
Heiko Rost schrieb am 11.12.2021 um 08:12:
> Helge Adler schrieb:
>
>> was meint ihr zu der Darstellung, wenn ich mit Seamonkey, aktuelle
>> Version 2.53.10, die Startseite von www.youtube.de aufrufe? *)
>>
>> https://ibb.co/thBN78y
>
> Javascript deaktiviert oder ein AddOn mit entsprechender Funktion
> (NoScript, Werbeblocker) installiert?

Alle Scripte erlaubt, kein NoScript, nur der "natürliche", in SM
eingebaute Blocker.


>> Sowie ich jedoch mit dem *Test*-Profil die youtube-Seite aufrufe,
>> sieht alles normal aus und funktioniert normal.
>>
>> Auch möglich, daß nach einer Neuinstallation von SM erst einmal alles
>> wieder richtig präsentiert wird, aber nach einiger Zeit ist die
>> Darstellung von Yt wieder futsch.
>
> Wenn ein anderes Profil das Problem nicht zeigt, ist im Profil
> irgendetwas verstellt. Eine Neuinstallation des Programms ist dann
> nutzlos.
>
> Gruß Heiko
>

Danke, so war es auch!

"Peter45" machte die Ansage, daß im Bowser-Menü eine bestimmte
Einstellung "verbogen" war :-)

Helge Adler

unread,
Dec 11, 2021, 8:11:22 PM12/11/21
to
Hallo Peter, genau so dürfte es sich verhalten (haben), danke!

https://gs.statcounter.com/detect?

Ergebnis soeben:

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101
Firefox/68.0 SeaMonkey/2.53.10

Zwar hatte ich mehrfach diese drei Einstellung im Menü unter "HTTP"
verändert, aber wohl zu hektisch und nicht konsequent mit Neustart
etc.

Jetzt steht es dort auf "SM kompatibel mit FF" - und alles läuft
wieder normal.

Mal sehen, was sich demnächst mit der neuen SM-Version 2.53.10.1
ergeben wird. Unter der Updatesuche, automatisch wie auch im Hilfe-
Menü, macht sie sich bereits bemerkbar, aber unsere Entwickler haben
wohl noch nichts hochgeladen.

Falls ich es richtig verstanden habe, hinken wir generell ca. 2 Jahre
hinter dem aktuellen FF her, bis halt auf die rückportierten
Sicherheitsupdates.

Arno Welzel

unread,
Dec 12, 2021, 3:10:58 PM12/12/21
to
Helge Adler:

> Hallo Auskenner,
>
> was meint ihr zu der Darstellung, wenn ich mit Seamonkey, aktuelle
> Version 2.53.10, die Startseite von www.youtube.de aufrufe? *)
>
> https://ibb.co/thBN78y

Und passiert das auch mit einem neuen Profil?

[...]
> Auch möglich, daß nach einer Neuinstallation von SM erst einmal alles
> wieder richtig präsentiert wird, aber nach einiger Zeit ist die
> Darstellung von Yt wieder futsch.

Wieso "Neuinstallation"? Es genügt, ein neues Profil anzulegen, um zu
testen, ob etwas im aktuellen Profil kaputt ist.

Siehe auch
<https://support.mozilla.org/de/kb/firefox-profile-erstellen-und-loeschen>
- das gilt auch für Seamonkey.

--
Arno Welzel
https://arnowelzel.de

Helge Adler

unread,
Dec 12, 2021, 5:05:41 PM12/12/21
to
Arno Welzel schrieb am 12.12.2021 um 21:10:
> Helge Adler:
>
>> Hallo Auskenner,
>>
>> was meint ihr zu der Darstellung, wenn ich mit Seamonkey, aktuelle
>> Version 2.53.10, die Startseite von www.youtube.de aufrufe? *)
>>
>> https://ibb.co/thBN78y
>
> Und passiert das auch mit einem neuen Profil?

Hallo Arno,

Dank für dein Interess an der Angelegenheit!

Mit einem Testprofil war alles in Ordnung, ich glaube, ich hatte das
schon anderweitig gesagt.


> [...]
>> Auch möglich, daß nach einer Neuinstallation von SM erst einmal alles
>> wieder richtig präsentiert wird, aber nach einiger Zeit ist die
>> Darstellung von Yt wieder futsch.
>
> Wieso "Neuinstallation"? Es genügt, ein neues Profil anzulegen, um zu
> testen, ob etwas im aktuellen Profil kaputt ist.
>
> Siehe auch
> <https://support.mozilla.org/de/kb/firefox-profile-erstellen-und-loeschen>
> - das gilt auch für Seamonkey.
>

Korrekt, zusätzliches Testprofil anlegen, damit ging auch alles
gut. So konnte ich feststellen, daß SM im Prinzip normal arbeitet.

Die Neuinstallation früher jedoch war immer ein Drüberinstallieren der
vorliegenden SM-Setup-Datei, ähnlich wie beim SM-Update, über das
vorhandene Profil.
Es werden dabei ja wohl keine Einstellungen und wichtige
vorhandene Daten überschrieben. War auch schon einige Zeit her, sodaß
ich nicht mehr genau sagen konnte, was ich gemacht hatte, daher das
"auch möglich". Das hatte paarmal gegen SM-Abstürze geholfen.

User "Peter45" hatte den abschließenden Tipp gegeben, siehe dort: Im
Menü "Erweitert - HTTP" auf "SM/FF-kompatibel" umstellen - und fertig.
Jetzt geht's wieder.

Ach ja, fällt mir gerade ein:
Genau diese Einstellung hatte ich im Laufe der
vergangenen Wochen und Monate paar mal probeweise verändert, weil
manche Webseite nicht richtig funktionierte. Es kommen leider
Meldungen, die ähnlich lauten wie: "Ihr Browser wird nicht mehr
unterstützt" etc.
Gehe doch mal probeweise mit SM v2.53.10 zum Kundencenter-
LogIn der Telekom....

Arno Welzel

unread,
Dec 13, 2021, 6:19:53 AM12/13/21
to
Helge Adler:

[...]
> Ach ja, fällt mir gerade ein:
> Genau diese Einstellung hatte ich im Laufe der
> vergangenen Wochen und Monate paar mal probeweise verändert, weil
> manche Webseite nicht richtig funktionierte. Es kommen leider
> Meldungen, die ähnlich lauten wie: "Ihr Browser wird nicht mehr
> unterstützt" etc.
> Gehe doch mal probeweise mit SM v2.53.10 zum Kundencenter-
> LogIn der Telekom....

Genau deshalb nutze ich Browser wie Seamonkey nicht - wenn etwas nicht
korrekt läuft, weiß man nie, ob es am Browser liegt, oder an der Website
und wenn man sowas dann reklamiert beim Website-Betreiber wird der mit
großer Sicherheit dazu raten, einen Browser wie Firefox oder Chrome zu
verwenden.

Markus Ammann

unread,
Dec 13, 2021, 12:41:11 PM12/13/21
to
Seamonkey ist der hauptsächlich genutzte Brauser bei mir.
Wenn etwas nicht funktioniert - Fake-Useragent einstellen.
Meistens funktioniert dann die Website, dann war da ein unfähiger
Webdesigner am Werk.

In sehr seltenen Fällen funktioniert es auch mit Seamonkey trotz
Fake-Useragenten nicht. Habe hierzu weitere Brauser installiert,
zwei Firefox-Derivate, Safari und Chrome.

Unter anderem bei Youtube, spielt es keine Rolle, welchen Gecko-Brauser
man nimmt, es darf da *keinesfalls* Seamonkey im Useragent stehen.
Wie bespielsweise bei diesem Posting ;-).

Gruss Markus

--
Dieser Beitrag entstand durch hirnloses Herumtippen auf der Tastatur.
Jeglicher Sinn und Zusammenhang darin waere rein zufaellig und nicht
beabsichtigt.
DVD-Sammlung: http://www.howalgonium.ch/dvdsammlung.html

Joerg Lorenz

unread,
Dec 15, 2021, 1:39:11 AM12/15/21
to
Am 13.12.21 um 18:41 schrieb Markus Ammann:
> Arno Welzel wrote:
>> Genau deshalb nutze ich Browser wie Seamonkey nicht - wenn etwas nicht
>> korrekt läuft, weiß man nie, ob es am Browser liegt, oder an der Website
>> und wenn man sowas dann reklamiert beim Website-Betreiber wird der mit
>> großer Sicherheit dazu raten, einen Browser wie Firefox oder Chrome zu
>> verwenden.
>
> Seamonkey ist der hauptsächlich genutzte Brauser bei mir.
> Wenn etwas nicht funktioniert - Fake-Useragent einstellen.
> Meistens funktioniert dann die Website, dann war da ein unfähiger
> Webdesigner am Werk.

Die Argumentation erinnert mich an das Impfthema. Die Lösung existiert
und es gibt keinen nachvollziehbaren Grund, diesen Oldtimer SM noch zu
benutzen und dann alle paar Tage mit Gejammer über Probleme hier
aufschlagen.

Sorry, aber das musste jetzt mal sein.


--
De gustibus non est disputandum

Arno Welzel

unread,
Dec 15, 2021, 9:29:22 AM12/15/21
to
Markus Ammann:

> Arno Welzel wrote:
[...]
>> Genau deshalb nutze ich Browser wie Seamonkey nicht - wenn etwas nicht
>> korrekt läuft, weiß man nie, ob es am Browser liegt, oder an der Website
>> und wenn man sowas dann reklamiert beim Website-Betreiber wird der mit
>> großer Sicherheit dazu raten, einen Browser wie Firefox oder Chrome zu
>> verwenden.
>
> Seamonkey ist der hauptsächlich genutzte Brauser bei mir.
> Wenn etwas nicht funktioniert - Fake-Useragent einstellen.
> Meistens funktioniert dann die Website, dann war da ein unfähiger
> Webdesigner am Werk.

Es ist natürlich leicht zu sagen, dass es "unfähige Webdesigner" sind,
wenn man selbst noch nie sowas gemacht hat. Aber YouTube ist keine
simple Website sondern ein recht komplexes System, dass nur
oberflächlich so aussieht, als wäre das nur ein bisschen HTML mit Videos
drin.

Ein "Webdesigner" kümmert sich auch nicht um User-Agents. Es geht hier
eher um Softwareentwickler, die web-basierte *Anwendungen* erstellen.
Und die müssen damit klarkommen, dass dutzende Versionen von Chrome,
Edge, Safari, Firefox und noch diversen mobilen Browsern wie Samsung
Internet, Android Browser, Brave usw. existieren.

Leider arbeiten aber nicht alle Browser absolut identisch. Je nach
Betriebssystem und Version des Browsers ist sind völlig unterschiedliche
Audio- und Videoformate vorhanden. Der Benutzer soll aber immer etwas zu
sehen bekommen und das in brauchbarer Qualität, egal ob sein Browser VP1
oder H264 haben will. Zudem wird mit HLS-Streaming über ein weltweit
verteiltes Content-Delivery-Netzwerk gearbeitet und das Frontend passt
sich an die verfügbare Bandbreite, Fenstergröße etc. automatisch an.

> In sehr seltenen Fällen funktioniert es auch mit Seamonkey trotz
> Fake-Useragenten nicht. Habe hierzu weitere Brauser installiert,
> zwei Firefox-Derivate, Safari und Chrome.

Ja, diese seltenen Fälle sind das, was ich meine - nicht jeder Browser
verhält sich identisch. Ich habe aber für solche Ratespielchen weder
Lust noch Zeit - deshalb nutze lieber gleich einen Browser, der auch bei
Anbietern von Websites bekannt ist und nicht nur so tut, als wäre er
Firefox.

Arno Welzel

unread,
Dec 15, 2021, 9:31:43 AM12/15/21
to
Arno Welzel:

[...]
> Leider arbeiten aber nicht alle Browser absolut identisch.

Ergänzend dazu:

<https://caniuse.com>

<https://caniuse.com/?search=HLS>

Nur damit man mal einen Eindruck bekommt, wie komplex das Thema sein kann.

Axel Berger

unread,
Dec 15, 2021, 12:34:15 PM12/15/21
to
Arno Welzel wrote:
> Es geht hier
> eher um Softwareentwickler, die web-basierte *Anwendungen* erstellen.

Mit anderen Worten, es geht hier ausschließlich um den mist, den der
Endnutzer *nicht* haben will und den er, wenn er könnte, liebend gern
loswürde.

Klar, Gängelung und Mißbrauch von Schwachstellen geht nicht
übergreifend, valider, sauberer und standardgerechter Code schon.


--
/¯\ No | Dipl.-Ing. F. Axel Berger Tel: +49/ 221/ 7771 8067
\ / HTML | Roald-Amundsen-Straße 2a Fax: +49/ 221/ 7771 8069
 X in | D-50829 Köln-Ossendorf http://berger-odenthal.de
/ \ Mail | -- No unannounced, large, binary attachments, please! --

Arno Welzel

unread,
Dec 18, 2021, 6:14:43 AM12/18/21
to
Axel Berger:

> Arno Welzel wrote:
>> Es geht hier
>> eher um Softwareentwickler, die web-basierte *Anwendungen* erstellen.
>
> Mit anderen Worten, es geht hier ausschließlich um den mist, den der
> Endnutzer *nicht* haben will und den er, wenn er könnte, liebend gern
> loswürde.

Also ich will ISPConfig zur Verwaltung eines Servers garantiert nicht
"loshaben" wollen. Ebenso finde ich Web-Obwerfläche von Nextcloud sehr
hilfreich.

> Klar, Gängelung und Mißbrauch von Schwachstellen geht nicht
> übergreifend, valider, sauberer und standardgerechter Code schon.

Falsch. Auch die diversen Online-Video-Chat-Tools wie Jitsi Meet,
Nextcloud Talk etc. laufen nicht mit allen Browsdern, weil sie
Funktionen nutzen, die nicht übergreifend und erst recht nicht in allen
Versionen gibt.

Wenn alle Browser identisch wären, bräuchte man <https://caniuse.com> nicht.

Axel Berger

unread,
Dec 18, 2021, 8:08:28 AM12/18/21
to
Arno Welzel wrote:
> Also ich will ISPConfig zur Verwaltung eines Servers garantiert nicht
> "loshaben" wollen.

Der normale Endnutzer verwaltet keine Server und Serververwalter lassen
ihre Wartungssoftware ganz sicher nicht in Skripten der Browser
irgendwelcher hergelaufenen Besucher ausführen. Das was Endnutzern
aufgezwungen wird verfolgt andere Zwecke.

> Auch die diversen Online-Video-Chat-Tools wie Jitsi Meet,
> Nextcloud Talk etc. laufen nicht mit allen Browsdern, weil sie
> Funktionen nutzen, die nicht übergreifend und erst recht nicht in allen
> Versionen gibt.

Das ist richtig. Deshalb laufen sie zumindest hier bei mir nicht im
Browser sondern in den bereitgestellten dezidierten Applikationen. Für
nur einmal mag das übertrieben sein, aber bei regelmäßiger Benutzung
keineswegs.

Arno Welzel

unread,
Dec 18, 2021, 1:45:54 PM12/18/21
to
Axel Berger:

> Arno Welzel wrote:
>> Also ich will ISPConfig zur Verwaltung eines Servers garantiert nicht
>> "loshaben" wollen.
>
> Der normale Endnutzer verwaltet keine Server und Serververwalter lassen
> ihre Wartungssoftware ganz sicher nicht in Skripten der Browser
> irgendwelcher hergelaufenen Besucher ausführen. Das was Endnutzern
> aufgezwungen wird verfolgt andere Zwecke.

Aber sicher doch. Meine Endnutzer wollen selbstverständlich auch ihre
eigenen E-Mail-Postfächer oder Website dort verwalten können. Wenn ich
denen erzähle, sie sollen sich doch per Konsole auf dem Server anmelden
und Konfigurationsdateien ändern, zeigen die mir zurecht den Vogel.

Nebenbei - ISPConfig ist Open Source: <https://www.ispconfig.org>

>> Auch die diversen Online-Video-Chat-Tools wie Jitsi Meet,
>> Nextcloud Talk etc. laufen nicht mit allen Browsdern, weil sie
>> Funktionen nutzen, die nicht übergreifend und erst recht nicht in allen
>> Versionen gibt.
>
> Das ist richtig. Deshalb laufen sie zumindest hier bei mir nicht im
> Browser sondern in den bereitgestellten dezidierten Applikationen. Für
> nur einmal mag das übertrieben sein, aber bei regelmäßiger Benutzung
> keineswegs.

Für Jitsi und Nextcloud Talk gibt es aber keine "dedizierte Applikation"
für den Desktop. Die gehen *nur* im Browser. Einzig für Android und iOS
gibt es Apps dafür.

Axel Berger

unread,
Dec 18, 2021, 5:00:12 PM12/18/21
to
Arno Welzel wrote:
> Für Jitsi und Nextcloud Talk gibt es aber keine "dedizierte Applikation"
> für den Desktop. Die gehen *nur* im Browser.

Zugegen, viele kenne ich von den zahlreichen Möglichkeiten nicht, nur
Edumeet, Jitsi und Zoom. Aber für die beiden letztgenannten davon habe
ich browserunabhängige Apps auf dem Windowsrechner.

Arno Welzel

unread,
Dec 18, 2021, 9:19:02 PM12/18/21
to
Axel Berger:

> Arno Welzel wrote:
>> Für Jitsi und Nextcloud Talk gibt es aber keine "dedizierte Applikation"
>> für den Desktop. Die gehen *nur* im Browser.
>
> Zugegen, viele kenne ich von den zahlreichen Möglichkeiten nicht, nur
> Edumeet, Jitsi und Zoom. Aber für die beiden letztgenannten davon habe
> ich browserunabhängige Apps auf dem Windowsrechner.

Für Jitsi Meet gibt es keine Desktop-App, nur etwas auf Basis von
Electron, was faktisch auch nichts anderes ist, als Chrome mit einem
Applikations-Framework drumherum:

<https://github.com/jitsi/jitsi-meet-electron>

Und nein, "Jitsi Desktop" ist nicht das selbe.

Helge Adler

unread,
Feb 16, 2022, 6:20:03 AMFeb 16
to
> ergeben wird.....


Uuuund ..... AUTSCH!

Obwohl alles auf "Seamonkey kompatibel mit Firefox ausweisen
(Standard)" eingestellt ist und damit der Browser auch wochenlang bei
den üblichen Webseiten funktionierte, inkl. Youtube, tritt der alte
Fehler nun erneut auf - nur halt woanders. Also gewisse Elemente
werden mit SM (aktuelle Version 2.53.10.2) nur als Grauschimmer
angezeigt und können nicht angeklickt werden (siehe
Eröffnungsposting im Dezember).

Es geht diesmal um https://shops.audi.com/de_DE/web/tradition/

Ein Versuch, die Seite mit MS-EDGE dazustellen, gelingt zunächst, nach
einigen Blättern in den Unterseiten passiert dort jedoch *manchmal*
das gleiche, wie mit SM: Grauschimmer-Elemente und klicken auf die
Ersatzteilkataloge funktioniert nicht mehr. (Anderer Rechner mit
sauberem Windows 21H2)

Dumm, daß sowas immer dann passiert, wenn man drauf angewiesen ist....
:-/


Was ist dazu die Meinung der Auskenner hier? Was stellen sich die
anderen Browser auf der Webseite an? Sollte der eine oder andere
Programmierer erschossen werden? Danke für 'nen Tipp!

Ralf Lehmeier

unread,
Feb 17, 2022, 12:38:07 PMFeb 17
to
Helge Adler schrieb:
...


Sollte der eine oder andere
> Programmierer erschossen werden?

Lieber nicht, es sind schon so wenige.

Helge Adler

unread,
Feb 23, 2022, 5:26:46 PMFeb 23
to
Ja, vermutlich machte der Schusswaffengebrauch keinen Sinn.... :-(


Jetzt gerade wieder mit EDGE ausprobiert:

https://shops.audi.com/de_DE/web/tradition/

Gehe ich mit Edge dorthin, kann ich die zig Ersatzteilbildchen
anklicken und es werden mir die dahinter-/darunterliegenden Details
des ET-Katalogs angezeigt. Also funktioniert es prinzipiell, wie vom
Programmierer gewollt und vom Anwender erwartet.

Mit SM v2.53.10.2 derzeit halt nicht. :-(

Nur ausgegraute Symbole, Mausklicks haben keine Funktion.


Hhhhmmm... habe auf 'diesem' Rechner vor meiner Nase kein Firefox etc.
drauf. Nur SM und Edge. Könnte mal ein freundlicher Zeitgenosse mit
aktuellem Firefox dort nachschauen und berichten, was passiert?

Christian Potzinger

unread,
Feb 23, 2022, 11:59:12 PMFeb 23
to
Am 23.02.2022 um 23:26 schrieb Helge Adler:

> Könnte mal ein freundlicher Zeitgenosse mit aktuellem
> Firefox dort nachschauen und berichten, was passiert?

Firefox 97.0.1 x64.

Die Seite funktioniert hier[tm] tadellos.
--
ryl: G'Kar
Reply all
Reply to author
Forward
0 new messages