dcm4che/tools

85 views
Skip to first unread message

Jonathan Brooks

unread,
Jun 11, 2024, 12:02:42 PMJun 11
to dcm4che
Hi,

I'm sure this is something really stupid - but when I've installed the binaries for the dcm4che-5.32.0 tools and try to run storescu I get the following error:

Error: LinkageError occurred while loading main class org.weasis.core.util.NativeLibrary
java.lang.UnsupportedClassVersionError: org/weasis/core/util/NativeLibrary has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 55.0
/opt/dcm4che-tools/dcm4che-5.32.0/lib//libopencv_java.so is missing. Try to download https://github.com/nroduit/mvn-repo/raw/master/org/weasis/thirdparty/org/opencv/libopencv_java/4.9.0-dcm/libopencv_java-4.9.0-dcm-.so
/opt/dcm4che-tools/dcm4che-5.32.0/lib//libopencv_java.so: Permission denied
rm: cannot remove '/opt/dcm4che-tools/dcm4che-5.32.0/lib//libopencv_java.so': No such file or directory
Cannot download the native library related to the architecture , try it manually.

FYI: the library libopencv_java.so is present in the folder:
/opt/dcm4che-tools/dcm4che-5.32.0/lib/linux-x86-64

Is this an LD_LIBRARY_PATH thing?

Hope someone can help.

Cheers, Jon

fleetwoodfc

unread,
Jun 11, 2024, 1:56:32 PMJun 11
to dcm4che
Check your java version - requires 17 or higher.

Jonathan Brooks

unread,
Jun 11, 2024, 2:22:16 PMJun 11
to dcm4che
FYI downloading and "installing" 5.29.2 gave me a working storescu... 

Jonathan Brooks

unread,
Jun 11, 2024, 2:24:41 PMJun 11
to dcm4che
Thanks again fleetwoodfc!

I have 
java -version
openjdk version "11.0.23" 2024-04-16
OpenJDK Runtime Environment (build 11.0.23+9-post-Ubuntu-1ubuntu122.04.1)
OpenJDK 64-Bit Server VM (build 11.0.23+9-post-Ubuntu-1ubuntu122.04.1, mixed mode, sharing)

I guess the higher numbered versions refer to Oracle's JAVA?

What's the recommended version to use?

Cheers, Jon

fleetwoodfc

unread,
Jun 11, 2024, 7:31:22 PMJun 11
to dcm4che
You need openjdk 17 or higher to use dcm4che 5.32.0.
If you just need the storescu then dcm4che 5.29.2 should be ok to use.

Nicolas Roduit

unread,
Jun 14, 2024, 12:39:45 PMJun 14
to dcm4che

El Trigueñón

unread,
Jun 25, 2024, 2:20:17 PMJun 25
to dcm4che
bt desde cuba, tengo un srvidor dcm4chee instalado en debian 8 y el jboss me este error,  no se que hacer gracias
WhatsApp Image 2024-06-20 at 18.05.20.jpeg
WhatsApp Image 2024-06-20 at 18.04.52.jpeg

El Trigueñón

unread,
Jun 25, 2024, 3:11:22 PMJun 25
to dcm4che
saludos gpo tengo instalado un servidor dcm4chee en debian deonde cuando ejecuto paar accder a la dcm4chee me pone este error.
ESTADO HTTP 404 - /DCM4CHEE-WEB3 y además fallo el arranque del manejador de protocolo la direccion 8080 ya se esta usando.
Reply all
Reply to author
Forward
0 new messages