Working with the Ansible install on Windows

117 views
Skip to first unread message

w. Patrick Gale

unread,
Aug 24, 2022, 11:18:07 AM8/24/22
to Dataverse Dev
From reading some threads, it seems that some have been successful in getting Dataverse to run from a Windows machine but I have had no luck. I tried WSL2 and Docker and the bottleneck for me are the systemd calls, which WSL2 does not readily support (some claim to get it working but I have yet to find a working example). I tried the  Systemd integration example at [https://hub.docker.com/r/rockylinux/rockylinux] with no luck but they did not mention the OS distro or shell they were using to execute the commands.

Do any of the Windows developers have scripts to spin up a Dataverse instance they would be willing to share? I have tried everything from Ansible to Docker but they all fail when they hit anything involving systemd. I am guessing there are some additional setup assumptions that are missing from the documentation.

thank you

Akio Sone

unread,
Aug 24, 2022, 2:21:35 PM8/24/22
to Dataverse Dev
While I'm using Windows/Linux machines, my quick answer to your question is to get a Linux machine or make your windows machine dual boot with Ubuntu, etc., esp. since an older-spec windows machine has now way to be upgraded to Windows 11, if its disk is not fully used, it would be better to give it a second life as a Linux machine.  When WSL2 was released several years ago, I tried to install Dataverse within it and failed due to WSL2's limitations; after docker for window was based on WSL2 a few years ago,  I tried to install full docker within WSL2 and run Dataverse-DAO within it, and it did not work. I assume you had already tried a solution to enable systemd: https://gist.github.com/djfdyuruiry/6720faa3f9fc59bfdf6284ee1f41f950 and read the following article: https://www.theregister.com/2021/11/17/ubuntu_team_systemd_windows_wsl2/ 

Akio Sone

Akio Sone

unread,
Apr 5, 2023, 1:29:16 PM4/5/23
to Dataverse Dev
The following preview page shows how to run a containerized Dataverse with docker-compose:


While this aims at unix-like platforms, I followed the example in the section of "Building and Running" of the page and successfully logged in the landing page of Dataverse with the following settings:

A. Platform, etc.

Windows: Windows 11 Pro 22H2; OS build 22621.1413
Java: openjdk 11.0.18 2023-01-17
Maven: Apache Maven 3.9.0 (9b58d2bad23a66be161c4664ef21ce219c2c8584)

B. Trial settings

(0) A cloned Dataverse by Git for Windows with the line-ending setting is set to always LF (core.autocrlf=input)

Warning: by default, GitHub Desktop for Windows seems to ignore its user's global settings of git.

(1) the console is Git Bash on Windows Terminal

(2) docker-engine/docker-compose are those provided by Rancher Desktop backed by WSL2: Ubuntu 22.04.

(3) Before running 'scripts/dev/docker-final-setup.sh', jq must be installed on Windows; for how to install jq on Windos, see this page: https://stedolan.github.io/jq/download/)

 Akio Sone
H.W. Odum Institute

Reply all
Reply to author
Forward
0 new messages