Payara upgrade required

21 views
Skip to first unread message

Philip Durbin

unread,
Dec 7, 2020, 4:27:00 PM12/7/20
to datave...@googlegroups.com
My fellow Dataverse developers,

We recently merged pull request #7422 which requires you to update to Payara 5.2020.6 or higher. Here's a handy link: https://s3-eu-west-1.amazonaws.com/payara.fish/Payara+Downloads/5.2020.6/payara-5.2020.6.zip

I ended up keeping the same versions of PostgreSQL and Solr but I cleared out their data before proceeding (this is just a dev environment so I don't care about the data). Once I had the newer version of Payara in place, I ran the installer as with a new installation.

There are other approaches you can take but I think the above is the most straightforward for developers. Production installations will be given different (data preserving!) instructions in the 5.3 release notes*.

Happy hacking!

Phil


shla...@gmail.com

unread,
Dec 8, 2020, 12:10:11 PM12/8/20
to Dataverse Dev
For those of us who have yet to upgrade to 5.0 w/ Payara.... when we go to DV 5.0 should we just start with Payara 5.2?

--
Sherry

James Myers

unread,
Dec 8, 2020, 12:19:59 PM12/8/20
to datave...@googlegroups.com

FWIW: I’ve installed 5.1 instances using Payara 5.2020.6 as the first payara instance, so I think going directly to that (versus 5.2020.2 as in the instructions) should be fine. That said, I haven’t been involved in tracking payara’s updates so others may know better.

 

-- Jim

--
You received this message because you are subscribed to the Google Groups "Dataverse Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-de...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dataverse-dev/93ec0c80-ba5a-4cca-90e0-4779dc50767fn%40googlegroups.com.

Durand, Gustavo

unread,
Dec 8, 2020, 1:44:17 PM12/8/20
to datave...@googlegroups.com
Yes, I don't see any reason not to go straight to that version.

On Tue, Dec 8, 2020 at 12:20 PM James Myers <qqm...@hotmail.com> wrote:

FWIW: I’ve installed 5.1 instances using Payara 5.2020.6 as the first payara instance, so I think going directly to that (versus 5.2020.2 as in the instructions) should be fine. That said, I haven’t been involved in tracking payara’s updates so others may know better.

 

-- Jim

 

From: datave...@googlegroups.com [mailto:datave...@googlegroups.com] On Behalf Of shla...@gmail.com
Sent: Tuesday, December 8, 2020 12:10 PM
To: Dataverse Dev
Subject: [Dataverse-Dev] Re: Payara upgrade required

 

For those of us who have yet to upgrade to 5.0 w/ Payara.... when we go to DV 5.0 should we just start with Payara 5.2?

--

You received this message because you are subscribed to the Google Groups "Dataverse Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-de...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dataverse-dev/93ec0c80-ba5a-4cca-90e0-4779dc50767fn%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Dataverse Dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-de...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages