NoClassDefFound after upgrading from dataverse 4.9.1 to dataverse 4.9.4

68 views
Skip to first unread message

Michel Bamouni

unread,
Nov 21, 2018, 4:55:01 AM11/21/18
to Dataverse Users Community
Hi,

After upgrading my dataverse 4.9.1 to 4.94, When I try to create, visualize a dataset, I have the error "Internal Server Error ".
I the server.log, I see that the root cause is:
 StandardWrapperValve[Faces Servlet]: Servlet.service() for servlet Faces Servlet threw exception
java.lang.NoClassDefFoundError: Could not initialize class edu.harvard.iq.dataverse.provenance.ProvInvestigator


Does someone already have this error when upgrading to 4.9.4?

Best regards,

Michel

Philip Durbin

unread,
Nov 21, 2018, 7:06:18 AM11/21/18
to dataverse...@googlegroups.com
Hmm. Are you able to reproduce this issue on https://demo.dataverse.org ?

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.
To post to this group, send email to dataverse...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/dataverse-community/9e65fefd-e957-49b8-b333-7ff543810ce5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


--

Michel Bamouni

unread,
Nov 21, 2018, 7:33:00 AM11/21/18
to Dataverse Users Community
Hi Phil,

I don't have this error on dataverse demo.

Regards,

Michel


Le mercredi 21 novembre 2018 13:06:18 UTC+1, Philip Durbin a écrit :
Hmm. Are you able to reproduce this issue on https://demo.dataverse.org ?

On Wed, Nov 21, 2018 at 4:55 AM Michel Bamouni <olimi...@gmail.com> wrote:
Hi,

After upgrading my dataverse 4.9.1 to 4.94, When I try to create, visualize a dataset, I have the error "Internal Server Error ".
I the server.log, I see that the root cause is:
 StandardWrapperValve[Faces Servlet]: Servlet.service() for servlet Faces Servlet threw exception
java.lang.NoClassDefFoundError: Could not initialize class edu.harvard.iq.dataverse.provenance.ProvInvestigator


Does someone already have this error when upgrading to 4.9.4?

Best regards,

Michel

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-community+unsub...@googlegroups.com.

Philip Durbin

unread,
Nov 21, 2018, 7:48:18 AM11/21/18
to dataverse...@googlegroups.com
Ok, can you please open a support ticket by emailing sup...@dataverse.org? Please note that tomorrow is Thanksgiving and the day after is a holiday as well.

We'll try to remember to summarize the solution to the Google Group. If you could provide detailed steps of how to reproduce the problem and a copy of your server.log file it would be much appreciated.

Thanks!

Phil

On Wed, Nov 21, 2018 at 7:33 AM Michel Bamouni <olimi...@gmail.com> wrote:
Hi Phil,

I don't have this error on dataverse demo.

Regards,

Michel


Le mercredi 21 novembre 2018 13:06:18 UTC+1, Philip Durbin a écrit :
Hmm. Are you able to reproduce this issue on https://demo.dataverse.org ?

On Wed, Nov 21, 2018 at 4:55 AM Michel Bamouni <olimi...@gmail.com> wrote:
Hi,

After upgrading my dataverse 4.9.1 to 4.94, When I try to create, visualize a dataset, I have the error "Internal Server Error ".
I the server.log, I see that the root cause is:
 StandardWrapperValve[Faces Servlet]: Servlet.service() for servlet Faces Servlet threw exception
java.lang.NoClassDefFoundError: Could not initialize class edu.harvard.iq.dataverse.provenance.ProvInvestigator


Does someone already have this error when upgrading to 4.9.4?

Best regards,

Michel

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.

To post to this group, send email to dataverse...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Sherry Lake

unread,
Nov 21, 2018, 8:07:24 AM11/21/18
to dataverse...@googlegroups.com
Just out of curiosity, did you update all the incremental versions on the way to 4.9.4 (update to 4.9.2 & then 4.9.3)?

Did you test between each upgrade? That’s what we do as we step through multiple updates. 

Sherry Lake

On Wed, Nov 21, 2018 at 4:55 AM Michel Bamouni <olimi...@gmail.com> wrote:

Michel Bamouni

unread,
Nov 21, 2018, 9:25:07 AM11/21/18
to Dataverse Users Community
Hi Sherry,

I merged the steps to upgrade from  4.9.1 to 4.9.3 and the steps from 4.9.2 to 4.9.3 in one procedure.
After this, I followed the differents steps ans I deployed the 4.9.4 war.

In addition, Sherry did you upgrade to 4.9.4? If true, does 4.9.4 work for you?

Regards,

Michel

Le mercredi 21 novembre 2018 14:07:24 UTC+1, Sherry Lake a écrit :
Just out of curiosity, did you update all the incremental versions on the way to 4.9.4 (update to 4.9.2 & then 4.9.3)?

Did you test between each upgrade? That’s what we do as we step through multiple updates. 

Sherry Lake
On Wed, Nov 21, 2018 at 4:55 AM Michel Bamouni <olimi...@gmail.com> wrote:
Hi,

After upgrading my dataverse 4.9.1 to 4.94, When I try to create, visualize a dataset, I have the error "Internal Server Error ".
I the server.log, I see that the root cause is:
 StandardWrapperValve[Faces Servlet]: Servlet.service() for servlet Faces Servlet threw exception
java.lang.NoClassDefFoundError: Could not initialize class edu.harvard.iq.dataverse.provenance.ProvInvestigator


Does someone already have this error when upgrading to 4.9.4?

Best regards,

Michel

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-community+unsub...@googlegroups.com.

Sherry Lake

unread,
Nov 21, 2018, 9:34:52 AM11/21/18
to dataverse...@googlegroups.com
Hi Michael,

Not yet. We are planning upgrading, from 4.8.4, 1st week in December.

On Wed, Nov 21, 2018 at 9:25 AM Michel Bamouni <olimi...@gmail.com> wrote:
Hi Sherry,

I merged the steps to upgrade from  4.9.1 to 4.9.3 and the steps from 4.9.2 to 4.9.3 in one procedure.
After this, I followed the differents steps ans I deployed the 4.9.4 war.

In addition, Sherry did you upgrade to 4.9.4? If true, does 4.9.4 work for you?

Regards,

Michel

Le mercredi 21 novembre 2018 14:07:24 UTC+1, Sherry Lake a écrit :
Just out of curiosity, did you update all the incremental versions on the way to 4.9.4 (update to 4.9.2 & then 4.9.3)?

Did you test between each upgrade? That’s what we do as we step through multiple updates. 

Sherry Lake

On Wed, Nov 21, 2018 at 4:55 AM Michel Bamouni <olimi...@gmail.com> wrote:
Hi,

After upgrading my dataverse 4.9.1 to 4.94, When I try to create, visualize a dataset, I have the error "Internal Server Error ".
I the server.log, I see that the root cause is:
 StandardWrapperValve[Faces Servlet]: Servlet.service() for servlet Faces Servlet threw exception
java.lang.NoClassDefFoundError: Could not initialize class edu.harvard.iq.dataverse.provenance.ProvInvestigator


Does someone already have this error when upgrading to 4.9.4?

Best regards,

Michel

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Dataverse Users Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to dataverse-commu...@googlegroups.com.

To post to this group, send email to dataverse...@googlegroups.com.

Juan López

unread,
Sep 29, 2020, 9:34:14 AM9/29/20
to Dataverse Users Community
Hi!

I'm having the same error thrown in my dataverse ... the only difference is that we didn't update our dataverse, it just stopped working out of nowhere.

Did you find a solution for this issue?

Best regards,

Juan

Philip Durbin

unread,
Oct 1, 2020, 1:46:09 PM10/1/20
to dataverse...@googlegroups.com
Hi Juan,

I'm assuming you're part of the installation at https://github.com/IQSS/dataverse/issues/7270

I just left a brief comment there. I'm sorry to hear you're having so much trouble.

Phil

Reply all
Reply to author
Forward
0 new messages